Please reply me officially: Where is the Mongolian campaign unit data?

I tried to find the campaign units and their related data in ebps/attribute/races. There are indeed most of the campaign units in ebps/attribute/races, but there are no Mongolian campaign units. Note that there are only hero units in the Mongolian campaign folder, and there are no conventional units. For example, the unique Mongolian knight in the campaign (different weapon models), I need to find this one to make an appearance mod. Please reply me officially.


1 Like

Hey @ahioz9426 ,

I didn’t work on Mongol Civilization fully yet (I had focused on other civilizations more); but I had applied many things and fixes for Mongol Civilization too. I will try to find that armor and weapon types you show here and try to add them to my mod too.

Please subscribe to my mod named Civilization Conquest: Civilization Conquest - v2.0.4.7

You can see the pictures and patch notes from here: Civilization Conquest AOE4 Forums

1 Like

The shield and mount seem to be bound to the character model. Do you have a solution?

You are also welcome to pay attention to my mod. You can make more suggestions and comments here. Thank you!



I used the Man-At-Arms model to make that Historical Weapon to ground units and even added a shield spear model too.

Shield is model bound; but you can apply weapons to other units too.

I managed to add Mongol Spear to HRE model. But most of the time, I get Pre-Cached Red Box model error.



In addition, the quiver is also bound, so model replacement is most limited to the same type of units. For example, archers should not have shields, and remote units should have quivers. Although the models of characters and mounts are two parts (sometimes you will notice that their models are misaligned), they are still bound.


Most of the time, these limitations make me angry. I do all kind of changes but still, I cannot achieve what I wanted. It is really sad to be this limited.

I will check and test your mod too.



Absolutely agree. Now the mod function is still very limited, and even all model resources in the game are incomplete. I hope the production team can update and add more content as soon as possible.



Which civilization’s spear model is this? I couldn’t find - the name of the spear. Is it Chinese Civilization Spearman weapon? thank you.

1 Like

This is the weapon model of Chinese spearmen in era 1 and era 2


Thank you friend.

I have added one from Chinese and one from HRE to Mongol horseman. No Pre-Cached red box model error appeared.

but the weapon attack animations become short

Which path did you replace? If you simply change the model, you only need to replace the first path.

By the way, I would like to recommend some models that are deeply hidden:

  1. the Hand Axe of the French scout.

  2. Turkish machete of Indian Knight / warrior.

  3. the Arabian machete of the Indian Scout (or ABS, I can’t remember).

  4. two kinds of spears / halberds of French and Mongolian spearmen.

  5. golden crossbow of Mongolian crossbowmen (probably originally prepared for incremental arrows Technology).

  6. the spear of a war elephant.

  7. Guns and axes of Rus streltsy.

  8. Lance of monk of Rus.

  9. ABS archers upgrade the composite bow after exclusive technology.

  10. the short sword of an ordinary scout.


From the first path mean - would you show it with picture please? When it starts hitting the enemy with 2hand mace - the location where the unit holds the 2hand mace weapon is changing, so it holds the weapon a little more up; but when combat finishes it holds the weapon from correct place. I tried to change the x - y - z coordinates but I didn’t see any difference. So I confused where I have done wrong to make the combat animation correctly.

After that,

I have tried to add Mongol Knight Spear to HRE spearman and I have made the changes like this. However, in game it doesn’t appear but only a “Pre-Cached” model red box error.

This content editor is testing me really. It works fine for one civilization and then it doesn’t work for the other. Or sometime it works fine then next game it doesn’t work and give Pre-Cache red box model error for the new weapon I try to add.

However, when I do the same thing for Mongols to add the Chinese weapon you said, there was no problem.

@ahioz9426 If it is possible would you try from your side too please about how to add Mongol Knight weapon on HRE spearman (HRE Campaign Spearman Infinite model) without any red box error please? thank you very much.

1 Like

If you simply replace the model and do not change other data, you only need to operate the item indicated by the arrow, and other operations are not required.

The three arrows in the figure represent the model of melee knife, siege torch and charging spear.

At present, only models can be replaced, and the actions are locked (or I may not find the action path), so do not replace models that differ too much, or this will happen:

Because the rider only uses the action of spear, if you replace him with a short weapon, the model will be misaligned.

1 Like

HRE Spearman has the same logic. Find the charging weapon of Mongolian Knight / Chinese Spearman (era3/4), that is, the model path of Chinese halberd, and then replace it with these three options of HRE Spearman.
These three spears are the spears in the conventional and close combat States, the spears in the Garrison State, and the spears in the approaching / charging state.

1 Like

If I simply replace the model, I haven’t encountered red word or red square at present. (occasionally, the HP is halved after the unit is upgraded, and this can be solved by repeating the replacement operation.) you may need to eliminate other factors.

1 Like

I have followed and done the same steps as you said but I still got “Pre-Cache” red box model error for the HRE spear infinite corpse unit with Mongol Knight 4 weapon - charge version to place that x3 places you show in the picture. I think that something bugged in my mod, I don’t know why is not happening.

This issue same for the French one hand axe weapon when I try to add it to English Civilization… Or shield wall units, thy are all “pre-cached” red box model error.

I think that AOE4 developers should fix these issues.

You can try to create a new mod test.

1 Like

I created a new mod and followed the same steps as changing the animator_attachments with Mongol Knight 4 weapon for every weapon in the HRE infinite spearman 1st Age unit, and I still have the same “pre-cached” red box model error.

If it is possible would you try at your computer too?

I created a new mod and tested that everything was normal.

Some prerequisites:

  1. I always test tuning packs.

  2. when cloning, I selected the first two items (because if the third item is selected, there will be exceptions such as more / less options).