Replace Object effect is bugged: HP no longer scale

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

*** GAME BUILD #: Version 101.102.15522.0 (#81058) 10944061**
*** GAME PLATFORM: Steam**
*** OPERATING SYSTEM: Windows 10**

:arrow_forward: ISSUE EXPERIENCED


When using the “replace object” trigger effect to replace one object with another, the object’s current HPs no longer scale in relation to maximum HP as they used to. When replacing one unit with another, in most cases it will keep the same absolute number of HP as the old, instead of the same percentage of max HP as would happen earlier.


Replacing a full health 30/30 HP Archer with a Knight will make it a damaged 30/100 HP Knight instead of a full health 100/100 HP Knight as intended.

Replacing a full health 100/100 HP Knight with an Archer will make it an overpowered 100/30 HP Archer instead of a full health 30/30 HP Archer as intended.

In some situations, units are affected differently. E.g., a unit being healed by a monk when it’s replaced will not keep more than the max HP of the new unit.

Buildings that get replaced won’t scale either, but they seem to never keep more HP than the max HP of the new object, unlike replaced units.

I’m currently polishing a scenario that makes heavy use of the Replace Object effect, but this new bug completely ruins it. I’ve spent endless hours making it, but I can’t publish it until this bug has been fixed.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. In Scenario Editor, place a unit
  2. make a trigger with the Replace Object effect, which changes the unit to one with either higher or lower HP.
  3. Test the scenario and notice the HP.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

The new unit’s actual HP should be the same percentage in relation to its max HP as the old unit. E.g. units at half health should be replaced with new units at half health, as before update 81058.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.


Thank you for reporting this bug. The campaign scenario I published a while back has the same issue when the “Replace Object” effect is triggered. Hopefully it is fixed soon.


I was just about to report the same thing. Affects all units I’ve tried it with.

Same! They just barely fixed Modify Attribute (attack/armor) in time for the new generation of game-breaking bugs to make an appearance. Honestly this years-long game of Bug Whack-a-mole is as predictable as it is tiresome and absurd. You could set your watch to it. New patch, update or DLC → new batch of bugs that effs up all but the most rudimentary scenarios. Usually not fixed in less than 1-2 months, and almost always replaced by something equally bad.

I’ve said this for a couple years now, making sure the Scenario Editor features still work with each new update needs to be a wayyyyyy higher priority. This pattern of “Release shiny new thing: Fix bugs (much) later” just screws creators over month after month, again and again. Seriously, stop wasting our time.


I agree, I reported this bug too plus yet another one in the Scenario Editor. it’s getting tiresome to hunt and report those in stead of the devs after each and every update. It seems to get worse and worse too.


The team is aware of this one.
Thanks for the report :slight_smile:


I hoped that the last Hotfix 82587 would have fixed that bug, but apparently it didn’t, which is unfortunate.


The bug still lives on after the RoR update.
I don’t want to be negative, but I really wish that fixing known, scenario-breaking bugs like this would be prioritized.

1 Like

Sorry for the inconveniences, as you said, this isn’t fixed yet.

Is there any ETA as to when this bug will be fixed? As even within the released road map of fixing the game for the whole summer isn’t even mentionning the bug, yet it cripples dramatically custom and official single player content.

1 Like

Aaaaaaand after laste game patch, it would appear that the bug is still not fixed. I honestly don’t know how this isn’t made a priority, it even affects latest RoR scenarios…


I see from a bit of testing that this bug still lives on.

MLC8896, do you know which official scenarios are affected?
I haven’t tested them for this and only know about Montezuma 5 (The Boiling Lake).

1 Like

A lot of custom campaigns, I can also think of a ROR Macedon scenario, where transports don’t get their HP. Basically all scenario involving replace object effect are basically affected.

The bug is still not fixed, I’m using a custom scenario of mine to check upon the bug, and it’s still there after June patch. Hopefully they’ll eventually switch manpower from getting Minecraft gimmicks in the game and actually fix bugs.


@Felizon89 Any updates or information on this? We’re digging into the 4th month since this bug was introduced, and not a whisper of anything actually being done about it. Just seems like bugs in most other areas of the game, no matter how minor, get pushed to the front of the line. Whatever the reasons for this, it’s incredibly shabby and endlessly frustrating to people who put so much effort into creating custom content.

I get the that Editor has always been a bit of a bumpy ride, but all this new stuff has been a disaster for the core functionality of the game.


I don’t know if that is related to this bug, but I noticed something else lately:

Replaced units cannot garrison on their own, because the garrison button does not appear in their action menu. But if you select a replaced unit with a normally created unit, then the button does appear and you can garrison both.

I don’t see that bug when I try to reproduce it. Maybe it was fixed with today’s update?

The one with hp not scaling has still not been fixed though.

I just checked today, and yes, it looks like the bug was fixed somehow by last patch (not the HP not scaling bug though!).

Before it was like this:

Actually the bug is still there, but only when you replace an Invisible Object by a unit. If you replace any other object with a unit, it is fine (flags included). But units replacing Invisible Objects cannot be garrisoned at the moment still.

Thus, I believe this is an issue tied to the Replace Object bug (HP not scaling).

Any information regarding this bug?

Still there after two major patches.


1 Like

the officials do not solve the problem about it since then.@Felizon89


generally takes about 6 months to a year for fixes… almost 6 months now so hopefully by next patch including the persian rework