Replay does not work

Game Version:

  • Build: december patch
  • Platform: Steam


multiplayer replays end way before the end of the game, at what appears a random time.
there’s no error message, the replay looks like the game is over.
i’ve been experiencing this issue from the launch da, every replay is affected by the problem.


Replays seem to always stop the second any player leaves in addition to any other replay problems there might be.

Not really sure of all the cases in which a replay stops working. Sometimes a fix is as simple as just starting the replay again from the beginning.

nope, it affects 100% of replays, no matter how many you start them.
i don’t see this bug reported often, but still…

Replays seemed to have been fixed. You can watch multiplayer ones now.

EDIT ~ nvm, replays still stop replaying once a single player leaves

hooray! i wasn’t expecting it, good news!

Nope. This has always been a problem. Wanted to watch a replay last night, I thought being over a month since I last attempted to watch one it might be fixed…it still ends way before the end of game!

Unfortunately, the replay recording ENDS when someone leaves (not resign, actually leave the multiplayer game). So anything that happened after someone left has not been recorded at all.

After the latest patch I downloaded. Everytime I want to rewatch any replay. The replay ends after like 10 seconds of it starting

Anybody having the same issue?

1 Like

Having similar issue. Was watching the replay of my own matches (played after the latest patch) and they all ended in the middle of the match.

Posted here.

Can someone check with the latest update if there is any change to the replays?

I am a Steam user
I have the same problem but in rare times I obtain o well recorded replay

Game Version:

  • Build: 101.101.35584.0 4714640
  • Platform: Steam


When booting an old replay (from a played or a spectated game, pre-dating the Frebruary game update 35584 from February 27th), the game finishes after a few seconds and I can’t spectate it…

Reproduction Steps:

  1. Select an old replay that you know to be several minutes long.
  2. Launch it.
  3. It stops after a few seconds: the game is said to be finished…

When using Demo Loop the game doesn’t go further than 17 sec game time :cry: :cry: :cry:

Further investigation shows that any recording pre-dating the February patch (Game update 35584 - February 27th) can’t be replayed beyond the 12-17 sec game time. The recording made after that date can be watched in full.

Game Version:

  • Build 35584.471640
  • Platform Steam


today i tried some of my replays, and it seems they dont saved fully, i mean all of them ended near castle age (or sometimes in castle age)
i attached an image which shows the size of files (all of them 2,3 MB)
(some of these games are 3 hour)

Reproduction Steps:

  1. play a multiplayer game
  2. watch the replay in super fast mode (i haven tried the normal mode but i think it doesn’t matter)

Same trouble here, quite annoying.

I noticed this as well.

Have you also tried to watch replays pre-dating the February patch???
I can’t make them go further than 17 seconds game time though they ran fine before…
Those problems could be related?

i just tried my couple days ago replays, but yes they could be related.

i hope they notice and fix it