Replays are bugged

I played a 1v1 quick match tonight, then a 1v1 AI skirmish.

After, I wanted to watch the 1v1 quick match. I clicked on it and it said the right people in the game.

Then when it loaded it changed names to a game I played the day before and the replay was the game from the day before.

I tried several times and same result.

I closed game and restarted the game and then all was okay.

I have seen this bug several times, when I finished playing a match, I then wanted to see the rec, but I found it is overwritten with another match, for example, I just played a 1v1 match, but it is replaced by another 3v3 match I had some time ago, does anyone experienced a similar bug?

Also reported here Recorded Games in Ranked 1v1 Saving Over Eachother but this is for age 3

I’ve found that it’s not overwritten. It just takes awhile for the correct one to appear. Not sure if it’s being verified or being uploaded to a CDN.

What happens to me is I finish a match, and when want to view the replay, it’s the replay from a previous game and not the one I just finished. It generally corrects itself after an hour or so I’ve noticed.

I think it’s just a cloud delay - I found that restarting the game fixed this issue for me.

Restarting fixes it. Have seen it numerous times.

Thank you guys, I also noticed that restarting the game seems to fix the issue, but this is a bug not a delay, because the information displayed in the UI didn’t match with the data loaded, I am going to update this thread with images for more context, I hope this can be solved and we don’t need to restart the game every time

Hey, still replays are bugged. Clicking some game replay and it’s loading some other game replay instead

Yeah, please fix “1v1” still record is something else.


Worked for me too. Thanks

one of my replays is completly missing. i know i played a game on BF one day ago but the game is not in my history anymore. i have ofc restarted the game.

The whole replay system is broken …
I want to play my last match … And nothing answers at all. nationality, game length, position and more.

Horror so many mistakes in the game … for 60 euros?

Restarting your game should fix this.

And how to restart the game?
pc can be restarted but game can’t?

Exit the game and launch the game again. It normally makes replays function correctly. Maybe it won’t work for you but it has for myself and others. We shouldn’t have to do this though hopefully they fix it.

Unfortunately, it doesn’t work

That is a shame. Maybe tomorrow’s patch will help you.

1 Like

Likely not for past replays, but maybe for future replays made.

The patch announcement thread says past replays won’t be usable:

I really hope AoE4 doesn’t suffer the same fate as AoE2 with saves and replays, where patches render them completely inaccessible or non-functional (useless) the vast majority of the time. Why is almost every non-AoE game I’ve played able to let them be functional after patch updates?

I somewhat understand for AoE2, based on what people say it’s about how units get different HP, attack, etc., through balance changes and all that info is embedded in saves/replays, and the game and all its commands just play out start to finish (in replays), iirc?

But for AoE4, surely they can record units, unit positions, and unit stats (along with building data) for the actual game played, so that no matter what patches come out, those recordings are not messed up, right?

They seem fixed since the recent update? Thanks Relic. I don’t think you even listed it as a bug fix? Seems to be fixed though. I’m watching a replay of game I just played without restarting the game. I could never do that before.

1 Like