Replays are bugged

Some games are not recorded. Some are recorded but the map is labelled wrongly and it says you were defeated but when you play the recording it’s actually one where you won. The timeline also says you were defeated despite it being one where you won. The supposed length of the recording doesn’t match the length of time you see on the timeline.


How can you access the recorded games in the first place?

In the bottom left of the main menu after you start AOE4 you see your name with a little icon. Click that icon and it brings up your stats and things you’ve earned etc. There you will find your recorded games.

1 Like

Thank you so much, it’s so hidden in the UI that most people think that replays are not available in this game.

I would like to add two more issues here:

  1. When I switch to my opponent’s perspective, the colors of the two players are messed up (he shows as blue, but if I select the units they are red).
  2. I can click on buttons and it produces effects (i.e. if I click on “build Royal Knight” while watching a recorded game it will start queueing the Royal Knight).

CC: @OMGBoxShark

Also when you change view from player to player it ghosts all buildings that where once revealed in the fog of war. This only happens if you are not on reveal all.

In my Match history, I had 2 games playing against the same opponent, one I lost, one I won. I already downloaded and watched the replay of the match I lost, but now when I go to the game I won, the Overview shows the map type and the result (surrender victory) correctly, but when I go to the Timeline and the Statistics, it shows what of the game I lost, and when I try to watch the replay, it shows me the replay of the game I lost too. I tried many times but still the same problem.


Actually maybe it wasn’t the same opponent for those 2 matches, instead it just showed the wrong opponent name. Anyway, my match history seems to be a mess now, can’t distinguish what info is correct info and what’s wrong.

I can now confirm that match history is defintely a mess. I’ve just finished a game and then go to match history, click the latest game (showed all the right info on the list), but going into the match details, so many info was wrong, and when I watched the replay, it was a totally different game. Please fix this devs, I want to watch replays to improve my skills!

Yes, same happens to me. The match history is a mess.

It’s all mixed up definitely. I found that yesterday, however I found after coming back on the game today it had fixed itself a little? Maybe it needs a day at all to sort itself out?

Watching a replay now and the minimap is messed up. Buildings and walls the wrong colour. For example my buildings and my wall are different colours when they should be the same obviously as they are both mine.

Found out that just quit and reopen the game fixes the issue, but when a new game is finish, its replay will definitely be wrong.


Showing wrong matches in match history.
Example: Clicking the first game which is a 2v2 match pulls up an earlier 4v4 match that I had

After restarting the game it works properly


Yup have it as well.
Highly annoying, good catch.

Hey all, thanks for all of these reports with match replays. We’ll have our team investigate.


I keep getting this when linking the account.


Please help what to do.


Hey misterMBBS, I think you need to create a separate report for this. I am facing this issue as well after doing the steps mentioned above. Maybe I will use your screenshots to create a separate thread.

Edit: The main thread for this issue is here: Can't link my Microsoft/Xbox live account

1 Like

I am having the exact same problem.

Thank you :slight_smile: Really appreciate your help.