Scout line upgrades cancel unit's current action - Single Player

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 6228353
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


In single player matches against the AI, I usually set a few Scouts to, well, scout by setting random waypoints across the map. The Scouts halt their current action (no matter what that is) as soon as they get upgraded to Light Cavalry (same thing happens from LC → Hussar). That’s usually in the middle of a Town Center and the moment I realize what’s happening they’ve been often killed.

This started happening after the last major update (the one including Burgundians & Sicilians) and was fine before. I have no mods installed.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Start a single player game against the AI
  2. Get to Feudal Age as usual
  3. Create 4 or so Scouts and SHIFT+RIGHT CLICK randomly around the map. The queued waypoints should be enough so the Scouts are still moving when you hit Castle.
  4. Reach Castle Age
  5. Initiate the Light Cavalry upgrade
  6. Watch your Scouts stop moving once the upgrade is complete

For point 3. it’s also valid to set your Scouts to follow or defend another unit. The upgrade also cancels those orders.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

The Scout line upgrades should not cause the Scouts to stop their current action.


Am I really the only one with this issue? Or maybe it was an intentional change and I missed a changelog or two?

I even uninstalled-reinstalled AOEIIDE and the issue remains.

I checked and it happens to me as well.
When upgrading to light cav, the scouts’ stance will change to aggressive regardless of what it was before, sometimes their shift-queue for walking will be canceled too, and actions like follow or guard(guard another unit) will be canceled.

1 Like

Thank you. I thought I was going crazy because this is not reported anywhere. I checked these forums, on Steam, reddit, etc.

Could it be that the bug is not present in the more popular multiplayer matches so nobody has noticed? It’s very consistent for me in single player skirmish. No matter the map size, AI difficulty, number of AI players, etc. as soon as I upgrade the Scouts they stop what they are doing.

Can others try to reproduce it too? Previous to the Burgundians/Sicilians major update the bug wasn’t there.

i find it hard to believe it wont happen in multiplayer matches, but will in single player.

I think it happens to me on multiplayer when i think about it. After a scout rush i usually send 1 scout to scout the whole map. lots of times i find it standing somewhere as a light cav, and i just assume i stopped it at some point and thats why it didnt explore the whole map. this bug is probably the reason

1 Like

I actually noticed the issue when auto scout stopped working and defensive stance changed to aggressive.

Is it exclusive for the Light Cavalry line or any unit which is upgraded?

1 Like

This is only affecting Scout Cavalry. Even eagle scouts don’t seem to get bothered by this. They also don’t change stance to aggressive.


Interesting. Thanks for the confirmation that the bug is widespread, folks. Should reporting it here be enough or is there a way to open a bug ticket?

@GMEvangelos sir this is a minor but a new issue (introduced with LotW)

1 Like

Issue still present after the latest update (46295). I suppose the fix is in the pipeline but thought about testing and reporting it again just in case it was already resolved but not mentioned.

Thanks for reporting this bug. We will look into it!

1 Like

I have tried to reproduce this issue on the latest beta build, and it didn’t happen. Works fine for me. scouts don’t cancel their actions or their shift queue. And they don’t change formation or stance.

I tried the beta too and it still happened, but maybe they keep pushing updates to the beta?

I quickly went back to the regular version when I realized ranged units were not adding arrows to towers or castles. I didn’t see that reported either.

they fixed the ranged arrows thing in the latest beta update which was pushed around 7 days ago

i tried this scouts thing on the same build and there was no issue

I just re-installed the beta, reached Castle with the Franks and 5 or so Scouts, upgraded to Light Cavalry and they all immediately stopped moving, so I can confirm the issue, at least for me, it’s still present in the latest beta.

Other details of this last test:

  • Map: Rivers, Large
  • AI difficulty: Moderate
  • AI enemies: 5, locked teams
  • Speed: casual
  • Pop cap: 150
  • Every other setting set to default

I have the high res textures pack installed and no mods other than the gun tracers and larger onager projectiles active. I have disabled all mods and even re-installed AoE II from scratch at one point to discard an issue with my pc. Same thing.

As I mentioned in my first post, this started with the LotW update and was fine before, so I really, really doubt it’s just my system/setup.

1 Like

Ah my bad I missed a step in the test…

Forgot to press Light Cavalry upgrade in my test xD

So yeah you are correct its probably still happening

Does this happen only to Scouts or to any unit for example Archer to Crossbow?

1 Like

Only mounted scouts, which is, Mesoamerican Eagle Scouts are unaffected. Best civ to test this is Turks since they get the auto-upgrade bonus for LC.

I haven’t seen the behavior in any other type of unit. I’m sure at some point I tried reproducing it with the infantry line upgrades and the units kept doing whatever they were doing when the next upgrade hit them (correct behavior).

Weirdly, my scouts stop moving but they don’t change their stance to aggressive as others have reported. I have my AoE settings to defensive as default so I don’t know if that has anything to do with it.

I tested this again on the latest released patch, and the issue seems to affect only one specific situation

If you select 1 scout alone and shift queue him, his shift queue gets cancelled upon getting upgraded to Light Cavalry

while if you are several scouts and shift queue them, or a single scout or several scouts and normally click them to move anywhere, nothing happens when upgraded to light cavalry


That’s strange, for me it happens with multiple scouts with queued waypoints.

I found it to not be consistent with multiple scouts. sometimes it happens, sometimes it doesnt. however, a single scout is the most crucial thing because of scouting.