Smoke on the Water Achievement (Lake Poyang) Not Firing

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: ######
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


The achievement isn’t popping up after I acquire 20 dragon ships (and have 20 active at the same time). I’ve tried the scenario several times and each time it doesn’t fire. I’ll also note the cost of the ships is only 70 gold versus the 100 gold that I’ve seen before.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Attempt to buy 20 dragon ships in the Lake Poyang historical battle scenario

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

Achievement would pop up.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.


Also receiving the same result and unable to trigger the achievement.

UI displays 70 gold instead of 100 gold cost.

Tried to trigger by purchasing the ships individually or all at once and then ensure there were 20+ ships alive simultaneously.

I have the exact same issue

Same issue here. I made 60 boats in a row still doesn’t trigger. Please fix this, thank you.

Hello. I have the same problem. At least i tried to buy ships in a row, have them all alive at once, buy all 20 at once, wait until victory, wait until loose, bought 82 ships in one match, restarted level 16 times and tried it all over again and I still wasn’t granted the acheivement. Also tried to check local files for bugs - it’s useless here too.

I hope it’ll be fixed as soon as possible.

Same issue here, v.101.101.44834.0 6148570

Doesn’t matter if you purchase them all at once or one by one, still does not work

1 Like

Thank you all for keeping us appraised of the situation! I’ve bumped this topic and informed the proper people that it is causing issues. Hang tight; it may be a few patches until it’s fixed, but it is on the list!

1 Like

Thanks GME – Since the last update, I can re-confirm that it is not working as well; Turkish Delight is also not working.


Same problem here, as you can see in my screenshot it doesn’t even count them in the combat mode panel. It says War Ships : 5 , and those are my transport Ships.

It’s working now, but only if you play from the beginning; using a saved game from before the last update, wont work.

Yes I confirmed that after seeing Snekkyboi29’s post I tried again and it works. I tried in a new game immediately because he said so. Thank you mate.