Some in-game gold texts are disapearred in the latest version

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: v.100.13.29985.0
  • GAME PLATFORM: Steam and Microsoft Store, both platforms
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


The gold texts in the game can’t be shown correctly. (Please see the pictures below.)

I haven’t played video games for a long time. Yesterday I installed a new Intel Arc A770 Graphic card and started to play AoE3. And then I had this issue.

I tried the both MS strore and Steam version, reinstall the game, updating the OS, updating all the drivers by the Intel driver and sppoert assistant tool, enabling the resizable BAR according to official instructions, but the issue still remains.

I also tried unplug the monitor and plug it back to the integrated graphics of the Intel Core i7-12700 on my pc, because I remember several weeks (or months) ago I can still play AoE3 without any problem on the same machine using the same method. But now it doesn’t work either.

So now I am not sure what causes the problem, because the new hardware seems work fine, and I also tried to run other 3D games and apps and they work fine too. Only AoE3 has this bug. Please help. Thank you.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • Less than 25% of the time / matches I play (RARELY)
  • 25% of the time / matches I play (SOMETIMES)
  • 50% of the time / matches I play (FREQUENTLY)
  • 100% of the time / matches I play (ALWAYS)

100% so far.

:arrow_forward: ############ STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Start the game and I see the issue.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

All the texts should be shown completely.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

It seems that all the gold texts and the buttons or frames containing them are disapeared or broken.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe3Ysav) or GAME RECORDING (.aoe3Yrec) of the match where you encountered the issue. Link it below if using an external file service.



Additional information:

This bug appears in the latest version of AOE 2 too. All the gold text can’t sbe shown correctly.

another information:

I force the machine using the integrated graphic, not the discrete graphics card by setting graphic perference to Power saving:

System→Display→Graphics settings→Choose Age of Empires 3 and click the option→ set Graphic perfornace to Power saveing GPU

and the problem solved…

However, I have to downgrade the grpahic settings or the game will lag.

Is this the peoblem of software or hardware? Is anyone using Intel’s new discrete graphics card like me encounter this problem too?

intel drivers, unfortunate to happen, problems like this should be patched over time in driver updates, gpu software, this has nothing to do with the game itself, now what i find really interesting is that only parts of UI with shader effects on them suffer from this issue