The gold text of UI can't show correctly (MSstore version)

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.102.8319.0 (#73855) 0
  • GAME PLATFORM: Microsoft Store only
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


The gold text can’t show correctly as shown in the picture below.

I have experienced the similar issue in Age of Empires 3, and have reported in the III - Report a Bug:

Recently with the latest graphic driver, this issue is solved completely in AoE3.
But it still remains in AoE2.
And this issue only appear in the Microsoft store version only. The Steam version doesn’t has this problem.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: ############ STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Start the game and I can see this issue immediately

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

The texts should be shown currectly.

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.


Hi @Kuoting
Do you still have this issue?If so, can you try trinstalling the game?
What’s the resolution of your monitor?

Thanks for the report!

Yes. I just reinstalled the MSstore version again, removed all unofficial mods, and checked if there is update in the MSstore application. But the issue still there.

I set the resolution to 2560x1440 at both version. The graphic card is Intel Arc A770.

The first picture is MSstore version, the second is Steam version.

Do you have your graphic card driver up to date? If so, can you try to install an older version of the driver?

Yes I always update the driver through intel driver & support assistant tool when it informed me there is a new driver. I don’t know where the old version drivers are.

I bought A770 in late November. All I know is that the problem happened after I installed this card. So probably all the drivers after November 22 have this problem.

Could you try installing a version 30.xxxx… of the driver?

Is there a link? I can only find the latest drivers on the intel website.

Intel® Arc™ & Iris® Xe Graphics - WHQL - Windows*?

Ok I found it. But I can’t install them…

I tried igfx_win_101.1743.exe, igfx_win_101.1736.exe and igfx_win_101.1325.exe. All shows the same message.

The Chinese text says

I contacted the Intel Customer Support. In the last reply he said If the same game on the steam platform does not have a similar failure, it may not be caused by the driver.

I recently contacted Intel customer service again, and they informed me that the issue is caused by the MStore version. They suggested that I should continue to ask you for help.

The issue only occurs when I’m using an Intel discrete graphics card. When I connect the monitor to the integrated card, the problem disappears.

Will you address this issue? Or you do not provide support to the Intel discrete graphics card?