Sorry, failed to connect to multiplayer services. Server certificate authentication failed

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: newest
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

Sorry, failed to connect to multiplayer services. Server certificate authentication failed.

Source : AccountLoginEvent
Error Code : 0xffffffff
Extended Code: 0xfffffff3

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.


Same issue, this seems very frequent these days.

What worked for me is setting up my computer date 2 days behind so I put 15 of april instead of 18 of april and now it works after I restart the game.

their certificates expired so setting the date back makes the certificate still valid it seems

Nope, it crashes the game.

exactly what I though so that’s why I tried to set the date 2 days behind. Now it works

Try restarting the game

That’s what i did, but when i join a game it crashes.

I can’t even load AOE3:DE
“Unable to connect to online services, extended error. Please try again later.”

Also getting:
“You have lost network connectivity. Please check you internet connection and restart the game.”

Weird that I can post in an online forum with no network connectivity (rolls eyes)

Having the same exact issue. Played 4 multiplayer games last night. Now I’m unable to connect. Please advise.

i try that… it works… but i have to restart the game.

@Developers/Multiplayer Host: Please renew the certificate for AOE II

Workaround: set your computer date / time to yesterday.

1 Like

I’ve submitted a bug to the developers
WhatsApp Image 2021-04-18 at 21.47.05

It should work now. Certificate has been renewed


Why do the renew for 1 year instead of 5 or 10?
Reall absurd

Working. Nice work, sir. Thanks for the submission.

It is a HTTPS certificate. Nowadays it is common to have an one year lifespan:
The idea here is that the shorter an SSL/TLS leaf certificate’s validity period, the more secure the certificate is.

During renewal the keys are updated to the latest security standards.

1 Like

Hi, i have the same certificate problem. I submitted request also, but i am wondering about how did you solved this problem ? Did the game devolopers sent you new certificates or what ?

Hello! I am having this problem in 2023. Can these certificates still be obtained?

Hello everyone! I also have this problem, is there a way to fix it?