Still Late Game Lag - unplayable

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 7694700
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10 and Mac (with Crossover)

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.

I still have the problem when playing online that the clock turns red in late game and then the game is no longer playable. The problem happens to me and my friends every time, starting around the third time. The problem occurs both on Windows 10, Mac (via crossover) and via cloud gaming (Paperspace, Shadow). I get over 1100 points in the benchmark with all three variants.

Reinstalling did not help, nor did changing the graphics settings.

The problem was definitely not present before the anniversary update, with the exact same hardware and settings.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

100% of the time.

  • Less than 25% of the time / matches I play (RARELY)
  • 25% of the time / matches I play (SOMETIMES)
  • 50% of the time / matches I play (FREQUENTLY)
  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Just play online.
  2. Go to third or fourth time.

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.

Do you have a 6600 XT?

No I have tried with a RTX 5000 and the M1 (Mac).

And still the problem? So you are the first one i heard without a 6600XT that has this problem.

Can someone confirm that this fix helped?

I don’t have malwarebytes and whitelisted on my NOD32 didn’t fix.

1 player with poor PC will lag the entire game, thats just how the game was designed back in the days.

1 Like

has nothing to do with it - if you would be able to read then you wouldnt waste your and ours with such an useless post. but thanks. i think ai’s just have poor pc too so the entire game laggs :kappa

guess you can’t read and understand computer. if you could think for a bit and you dont have to waste our time with this stupid post.

i think you need more brain power kappa!

wtf is your problem men? can you just vanish please - a new post gives me hope for a fix.
It has nothing to do with a player having a potato pc. Its always laggs. Offline and online. Most of the time after people hit feudal age.
It has nothing to do with a weak system.
There you can read
https://forums.ageofempires.com/t/game-stutters-with-rx-6600-xt/188040/6
and there

Alot of people with AMD cards have that problem.
For months I cant play this game now even I got again a new pc. Second time since DE.
And now you come here want to be cool and you are just foreign shame.

took the words right out of my mouth!

it has everything to do with a weak system!

I think you are either unable to read or understand. The game worked fine with EXACTLY the same hardware and AFTER the update it no longer works with EXACTLY the same hardware, what’s so hard to understand about that?

1 Like

I think its sad we have more than 1 person than n1ceking who needs some more brain power!

maybe with all of your intellect and try to grasp that maybe and just maybe one other person lagging the game in multiplayer late game might actually have have nothing to do with your non-changing hardware then perhaps you would get it.

I think you really are the dumbest person ever. Again, for the mentally retarded among us:

All 3 players participating in the multiplayer game have changed absolutely nothing on the hardware. There are always 3 of us playing and we have the same setup. Do you get it now? No, then please just stay away.

1 Like

stop exposing your stupidity to the internet bruh. maybe time to shut up and think, clearly you didn’t bother to read what I typed even though I just explained in the previous post.

here I thought it couldnt be worse, your stupidity definitely takes the cake.

Please just go annoy somewhere else before i report you. Thanks

Hi guys!

We know that the game have lag for some users, but just for be sure, I recommend you to try some things that can improve your performance:

  1. Deleting your user files. For deleting your user files, you should:

a. Make sure that your Steam Cloud is disabled in Steam, AoE2 game, Properties, General.
b. Go to C:\Users\YOUR_USER\Games\Age of Empires 2 DE.
c. Copy your user folder to a safe place, it has lots of numbers.
d. Delete the original folder
e. Verify your files in Steam, AoE2 game, Properties, Local Files.
f. Open the game again. A new user folder will be created.

If this works, then copy back the files from your old user folder. Those files are in the folder -C:\Users\YOUR_USER\Games\Age of Empires 2 DE<0>\Savegame, Recorded Games and Save games.

If this does not work you can also try:

  1. Reinstall the game
  2. Unable your mods
  3. Uninstall/unable your antivirus or add the game to exceptions list
  4. Reinstall your graphic drivers, update Windows
  5. Update direct X
  6. Make sure that your game is not running on the integrated GPU
  7. Uninstall Citrix (if you have it)
  8. Restart your PC and close as many background programs as you can before starting the game.
  9. Disable Enhanced Graphics if your hardware is not very fast
  10. Installing latest VC++ redistributables from here (both x86 and x64 variants):

Good luck!

1 Like

LOL says the guy who attack the other person first with a sh*tty attitude then resort to report to silence the other. typical people nowadays.

go ahead and report me see if I care, tell them how much your feelings got hurt.

Hey!

Thank you for your respond. I took my time and tested it. Took me like 1 1/2 hour.
It was not the first time I tried your fixing ideas, others told me that all read. But for you I tried it again.
All of 11 fixing points didnt made a different.

I want to point out some things again and made it clearer.
Please don’t focus on one user that joined here random that contribute nothing to my/our problem.

My system Amd Ryzen 5 3600 and my new bought 6600 XT Hellhound should be not to weak for this game.
Some months ago I played this game on my old system with FX-6300 and a RX 570 8GB and had a long time no problems.
Some periods ago you guys released a patch were alot of people (including me) expierenced a bug that after alot of people reached feudal age began to receive hard spikes.
Even if I to pass over that - like playing deathmatch - the game runs smooth for the first 5 minutes then the stutter begins - online or offline - with human players or without - with AI or without AI.
Some people with even stronger system then mine expierenced this bug - so the arguments of this random user here in this thread have no valid point.

In the reddit thread some user posted that his fix of the problem was to plugin a second monitor. For me this isnt an option because I have my second monitor permanent plugged in.
Maybe other guys here can test it and look if it helped.
(and yes I already tested it how games running when I unplug or plugin the second monitor - both made no difference).

Once again I want point out im glad someones is posting from officials and trying to help but im really desperate.
For months I want to play this game and im not possible. For me AoE 2 DE is one of the last “real” gaming expierence. And I would be really happy to enjoy this again.

Edit: The user jredubr9 made this post in this thread: Stuttering, lag, game has become unplayable online - #12 by n1ceking
Can someone give me more details? What does he mean with “navi”?

I could avoid the issue altogether by forcing the game to run on the integrated graphics card. It’s nuts.
I got a 6800M but have to run on the integrated graphics to avoid the issue.
Maybe it’s an issue with Navi, since the integrated from 5900 HX is a Vega one.
If AMD made some change in their “code” or in their graphic architecture it would sense in my mind that an old code like AoE 2 has problems with that.

Second Edit: Guys one question I have in my mind. Do you guys own " Dawn of the Dukes"? Because I don’t. Maybe thats the source of our problem? (fingers crossed")