Stuck in Loading Screen

I was able to play a few missions in campaign, but when trying to load the fourth mission, I started getting stuck at the loading screen around 80%. What’s weird is this is the case when trying to load any game type it seems.

I have updated my graphics driver and restarted. I have also uninstalled and reinstalled the game and downgraded graphics but I still get stuck when loading into a game around 80%. Anyone else having this issue or know of a fix?


Hmm, so this only happens now when you start the 4th campaign mission (with the English?), or in any game type, like multiplayer/custom game vs ai etc?

Any game type. Doesn’t matter which one it is. Skirmish, multiplayer, and campaign have the same issue now.

OK, let me think. Have you tried switching off antivirus?

This is happening to my friend as well, exact same problem. Have you found a solution?

1 Like

AoM IV is allowed through the firewall.

No, antivirus, not firewall. This was happening in one of past Relic’s games and switching off antivirus helped, because it was running a scan of the loaded files and it glitched the game.

It’s just an idea though, you can give it a try.

1 Like

It could be as well Windows Defender related or by lack of free disk or memory swap space.

Alright, so I just tried freeing up a ton of space. Basically deleted ALL my games. Now I have plenty of space on my SSD and hard drive. I have disabled antivirus/windows defender and still have the same issue after all that. Not really sure what do at this point.

1 Like

Yeah I’ve been having the exact same issue. 4th mission, won’t load past around 80%, and no other modes load past it too now.

1 Like

Damn, thats a shame for you guys not being able to play. There was a similar issue in Company of Heroes 2 (Relic previous game on same engine) where forcing your monitor to run on lower refresh rate for that game with a launch parameter solved the problem, but since you say were able to play a few missions until this happened, I dont know.
Try to contact some AoE4 developers here in the forum, I saw that they finally responded to some posts in the bugs sections, or just repost this there.

Also, try steps presented in this article, I know they are for GTA5, but they are applicable for any game that is stuck in loading screen:

see also whats mentioned at “Other Recommendations” in the article above ^

I also found one strictly about AoE4, although not about loading being stuck specifically:

Same issue 80% loading then stuck.

Hey guys, there’s another thread in Bugs with a developer response. I gave them information and figured I’d give the link to sort of consolidate this issue.

1 Like

try deleting all your save files in your documents folder, that worked for me.


I have tried more than the above, I did ALL OF THE FOLLOWING AND MORE:

  1. Contacted support
  2. Deleted saved game files
  3. Reinstalled game
  4. Moved game to new driver
  5. Reset RAM
  6. Reinstalled drivers
  7. Reinstalled game again
  8. Waited 30+ days for DEVS TO DO SOMETHING
  9. Tried all this again just today
  10. Created Outlook account in order to be able to:
  11. Created XBOX account in order to be able to:
  12. Created AOE account in order to be able to post this here

This is seriously a game breaking issue, i paid full amount and have been unable to play this game whatsoever for almost two months now!.