Town Center Disappears

:arrow_forward: GAME INFORMATION

  • BUILD #: Latest Beta as of 10/12/20
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

My Town Center has disappeared in various multiplayer games on the latest beta version available in Steam as of this week. I don’t recall having this issue during the Stress Test beta. It has happen in a few games, and seems to happen later in the game.

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • 50% of the time / matches I play (FREQUENTLY)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play as Germans using the latest version of beta on Steam
  2. Age up to the 4th age.
  3. Observe Town Center disappearing

:arrow_forward: EXPECTED RESULT

:question: What was supposed to happen if the bug you encountered were not present?

The Town Center should not disappear and remain present to the player.

:arrow_forward: ACTUAL RESULT

:question: What actually happened (what went wrong) because of the issue you’re reporting?

The Town Center disappears.

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE (.aoe2record) of the match where you encountered the issue.

I don’t have a game file, but can record and attach one next time it happens (if helpful).

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.

Please see attached.

2 Likes

Same issue - occurred when playing multiplayer 2v2 as Russia.
My friend could also not see or target the town centre, but I could select it with F1 and still use.
Occurs much less frequently: ~10% of games.

Not sure on reproduction.

1 Like

This was an issue in the legacy Age of Empires III as well, though far less common. It feels like its carried over and may have gotten worse.

3 Likes

:arrow_forward: GAME INFORMATION

  • BUILD #: ######
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

At some point my tc visually dissappeared in the game. i coulst still use it with my hotkey, but it wasnt there anymore (look at minimap and normal battlefield).

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • Less than 25% of the time / matches I play (RARELY)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

“This bug was present in the legacy version of the game. Going to industrial age with a civ that has German style buildings (Russians, Swedes and Germans) seems to be the trigger for this. It doesn’t happen every time you go industrial though, which is intriguing…” Thanks for pointing that out!

  1. Choose Russian, swede, germans
  2. go to industrial
  3. ?

:arrow_forward: IMAGE & ATTACHMENTS

3 Likes

Finally sweden balanced

1 Like

This bug was present in the legacy version of the game. Going to industrial age with a civ that has German style buildings (Russians, Swedes and Germans) seems to be the trigger for this. It doesn’t happen every time you go industrial though, which is intriguing…

1 Like

I had this bug on legacy version before. Could be a hangover from that, but it would be good to fix it regardless.

1 Like

:arrow_forward: GAME INFORMATION

  • **BUILD #:100.12.5208.0
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

My town center disappeared just after reaching Age 4 when playing as Sweden. It seems to be just a visual bug because I can still select it by using a hotkey (not by clicking with the mouse) and receive shipments there, build vills, etc.

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS) (please note that I just played a single game after the patch…)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Advance to Age 4 as Sweden (unsure about other civs)
  2. The TC may disappear

:arrow_forward: EXPECTED RESULT

The TC should not disappear…

:arrow_forward: ACTUAL RESULT

The TC disappeared but I could still select it by using a hotkey and receive shipments, build vills, etc.

This appears to be an issue for civs that use the Sweden, German and Russian building architecture, and I think a similar bug was filed. I experienced it on a previous version of the game while playing as the Germans many times, but knock on wood, haven’t experienced it recently (though many of my games have been ending in age 3, so that may have something to do with it).

This is extremely helpful! I’ve captured all of the information in this thread and added it to our tracking task. Thanks for taking the time to post and include your experiences with this issue!

2 Likes

Anytime man!
@EaglemutOP probably knows more about this issue than me. (that can be said about any bug in the old game tbh) :stuck_out_tongue:

:arrow_forward: GAME INFORMATION

  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

German TC dissapeared once i Aged to the Industrial Age

:arrow_forward: FREQUENCY OF ISSUE

First time, on first try with germans

:arrow_forward: REPRODUCTION STEPS

  1. Use Germans
  2. Age up to the industrial age
  3. TC dissapears

:arrow_forward: EXPECTED RESULT

Not to…

:arrow_forward: ACTUAL RESULT

You can see in the image below that the units are attacking the ground in the middle, where the TC was supposed to be, (and he is, but is now invisible)

1 Like

We need Sherlock Holmes

Hi My game starts with no tc
grafik

:arrow_forward: GAME INFORMATION

  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

when i have reach age 4 i couldn’t see my both tc on the map but still going to train vills

:arrow_forward: FREQUENCY OF ISSUE

  • Less than 25% of the time

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

:arrow_forward: EXPECTED RESULT

:question: What was supposed to happen if the bug you encountered were not present?

:arrow_forward: ACTUAL RESULT

:question: What actually happened (what went wrong) because of the issue you’re reporting?

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE (.aoe2record) of the match where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS




Its a Legacy bug, and happend in AOE3 CC too.
Its not that easy to fix, many tried many failed.
Avoide playing Sweden or Germany while this happens to you.

Tbh the biggest and easiest fix would be redoing the B-set for them. But what do i know, im a simple modder :slight_smile:

:arrow_forward: GAME INFORMATION

  • BUILD #: ######
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

first time it dissapear with russia, this map on 1vs1 versus AI

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. i think i advanced to age IV
  2. its not in staleth mode because i can move villagers trasspassing it.

:arrow_forward: EXPECTED RESULT

:question: What was supposed to happen if the bug you encountered were not present?

:arrow_forward: ACTUAL RESULT

:question: What actually happened (what went wrong) because of the issue you’re reporting?

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE (.aoe2record) of the match where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.

It’s not related to the map. It’s an old bug with Russia, Germany, and now Sweden iirc.

1 Like