[TRACKING] 36202: Disconnect within 5 Minutes of joining a Match

On Thursday I called my ISP and asked them to be put me on a static IP address. I’ve been meaning to do this for a while for work purposes, instead of using Dynamic DNS (although it does cost me €5 per month). Now my IP is solely dedicated to me.

After doing this on Thursday I haven’t had a single disconnect - around 8 multiplayer games in now. It used to disconnect almost every time. I’m still cautious as I’ve had good periods before, but never this long without a disconnect. Fingers crossed the CGNAT issue was my problem and it’s fixed for me (albeit at a cost).

2 Likes

Old fashioned PPOE is mainly used with VPN and DSL land lines. So it could very well be that the MTU solution only works for those situations. Some routers have also the option to enable / disable MSS clamping, that might be related to this subject too. Just test it by enabling if you have DSL line.

still having the issue

My brother just got this issue when we downloaded the game yesterday. But his computer is slow, so it might be that.
But I thaught of one thing, IP6 is always troublesome. Can that be a reason? It would explain why it works for some somewhere and not why isp setting may fix it
Have anyone tried if that is a good workaround?

https://ipv6-test.com/

This is happening to me also, only when i play 4 vs 4, at 20 minutes it kicks me out with the issue all mention here.

I can plan well 2 vs 2 or 1 vs 1 without any issue but this must be fixed asap and besides that nothing prevent the devs to make a reconnection logic as it also will hugely mitigate this issue itself. For example i am kicked out and 30 seconds later mi ethernet device revives and i re open aoe2de again and automatically i rejoin the game. Of course i may have lose a team figth or have a barrack less in the game but i actually can response back!. 1 minute of downtime of me in the game isnt going to make me lose the game at all!!!.
Also regarding the reconnection feature most of us that love this game with passion since we were kids will completely tolerate that!, it will make the game playable at minimum and thats all we need!.

Please put all your resources to make the reconnection feature!, it will mitigate instantly all this as its 6 month with this huge issue for almost 30% of the people who buy it!

BTW: I am drunk

kinda… today i droped 2 times in a row … my mtu-stuff is at 1450 i double checked.

One at 6 min other at 9 min

image

Edit1:

Tried change MTU to 1400 (trial and error like an idiot) dropped (3 times in a row)

Edit2:

Also droped at 1500

I’m done. No more Age until MS fix their "“well written code”"

1 Like

Good morning gentlemen,
I have been testing various methods to find out what is the generating factor for this problem, from changing the IPv4 to changing the MTU, I have already published my data for solving the problem above, I have tried the steps mentioned by colleagues but they also did not work. I notice that in some moments the game works for 5 ~ 10 min, sometimes 15 ~ 30 min depending on how many people are in the lobby (3x3 or 4x4), however it always disconnects. Finally, I realize that I can only play perfectly with the use of VPN, so I see that the flaw is in something minimal, which can be fixed easily, but I still haven’t found where the problem is. I am available to provide new information to assist in this resolution.

At. Konder

2 Likes

Hi. Would it make a change if I use a free VPN like Hamachi or a paid VPN like Nord or any else?

free vpn for me didnt work for some reason, only paid one did it. i bought 1 month of nord vpn to test this fix and it works. sadly i cant and wont pay 12$ each month to play this broken game.

2 Likes

Paid VPN worked! Used ExpresVPN here in Argentina. I won´t pay $13 for a month either… I keep waiting for the devs to solve the issue.

1 Like

I’m also having the same issue in both my computers. However, in one it always disconnects after 5 min and the other a little bit more (from 10 to 30 min). Waiting for devs solution

1 Like

Same problem.

Game disconnects with 5 or 10 minutes of games.

2 Likes

How can this still be a thing? I only get disconnected every fifth game or so. And no it is not my hardware struggeling with AOEII:DE, I can play 4v4 Deathmatch no problem, but in a 3v3 normal match in minute 8 there is not that much going on, but thats the point in time we get the random, out of nowhere disconnect. The other 5 players now have to quit as well, or play an unbalanced game? So maybe you start thinking about fixing it, because this does not only affect those who complain, but also all player that are in a lobby with us.

Also funny thing to open a new thread for this issue, so for new people it looks like this is a new problem, while it is now already as old as the game on its own.

So you guys need information about my configuration, no other game has a problem with?
ISP: Deutsche Telekom AG
Region: Germany
Router: Speedport W 724V Typ B

I payed for a game that seems to be still in Beta…
Look at the Lobby browser (joining an already full game leads to “Unknown error” (why are they even shown??), more open lobbys on aoe2.net than in the in game browser??) or the profanity filter (much better when logging out of xbox) and most of all this issue, that is known for multiple months now.

What a shame…

3 Likes

I have a friend that uses a paid VPN and it is not working. Do you know if the paid VPN is really a solution or just a solution for your configuration?

NordVPN works for me but with servers so far away from my country, it’s laggy as H…

1 Like

Question for the devs: When the matchmaking starts or at least when you find a match, it opens up ports 27113 - 27115. I portforwarded those ports and had success, meaning I can play 1 game after opening DE but after that game I get the 5 min disconnection issue again so I have to re-open the game to be able to play again. I guess the question is, do you guys have a dedicated server for the matchmaking? That way I can use that IP for the port forward or how does it work? It would seem like after 1 successful game, it tries to connect to a new server and it is where the problem begins.

1 Like

I do not. Does he keep getting the exact same problem or has it changed in any way? What I can tell you is I have tried most of the other possible user fixes, except changing the router (because we are in strict lockdown here) and changing the TCP session timeout setting, and they haven´t worked for me. I am convinced by now that a universal user fix will not be found, as this is a game code problem. It´s like someone said before: the game is still in Beta phase.
I hope the devs solve this asap so we can all enjoy this wonderful game.

2 Likes

He keeps getting the same problem and he is a top dev in Brazil (on a top business firm). He told me that VPN won’t work as adressing a root cause, but might work for a while depending on individual circunstances.

1 Like

Which country do you choose for your VPN when the game is working?

Argentina. I am from Argentina too. I tried Brasil and the game would tell me it wasn’t able to connect with Steam.