[TRACKING] 36202: Disconnect within 5 Minutes of joining a Match

:warning: Please note that this thread has been created to focus exclusively on disconnects (i.e. returning to the game lobby) shortly after joining a multiplayer lobby or game—most notably after about 5 minutes of joining a game lobby or match. Please ONLY contribute to this thread if you are experiencing this particular issue. Off-topic posts will be moderated.

THIS DOES NOT INCLUDE:

  • Crashes: i.e. the game closing entirely
  • Disconnects for a specific reason
  • Any other issues with the game

IF YOU ARE EXPERIENCING ANOTHER GAME ISSUE, please take the time to search for similar threads or start a new thread if one does not exist.

THE ISSUE

Hello everyone! To focus on a fix for the people who are still encountering this particular issue, I will be opening a new thread with each new update until we are able to resolve it for a majority of those impacted. Please comment (below) if you are experiencing the following problem:

Within approximately 5-10 minutes of joining a lobby or multiplayer game, you are disconnected from the game with an error message that returns you to the game’s home screen.

TROUBLESHOOTING CHECKLIST

If you are encountering this issue, here are the steps you should try first:

  • If you are using a wifi connection, try direct-wiring into your modem.

  • Ensure you’ve updated your modem and router software/drivers.

  • If you are using a HUMAX router or modem, try setting it to Bridge Mode.

  • Ensure you have worked through the networking steps, here.

  • Verify that you’ve worked through these steps.

  • [If possible] see whether a VPN connection or phone tether serves as workaround for the issue

WHAT WE NEED…

If none of those steps work, here’s what you need to provide:

  • An image or video of the error message

  • A savegame or replay file of the game when it happened.

    • Host it in a Google Drive or OneDrive folder and share a link so we can pass it to the team.
  • Your Real Steam ID.

    • Open your Steam client and choose View , then click Settings .
    • Choose Interface and check the box that reads, "Display steam URL address when available."
    • Click OK.
    • Now click your Steam Profile Name and select View Profile .
    • Your SteamID will be listed in the URL at the top left as a long number at the end of the URL.
  • A copy of your dxdiag

This information will be passed to our Test team so they can continue to look for common factors between players.

FOUND A SOLUTION?

If you manage to find a solution, be sure to let us know here, as well, so we can integrate it into our troubleshooting. There are a ton of factors that can lead to this issue, and we are exploring every avenue in search of a solution for everyone.

Thanks for your help!

4 Likes

https://drive.google.com/file/d/1JQ8i-7NjrKLEgQVUuIQ78gRWaWjWuaFB/view - Nov 27, 2019

https://drive.google.com/file/d/1vf6nJ4Iqc6f8Z73Wda2ud9IDWE5aa57K/view - Jan 31, 2020

https://drive.google.com/file/d/1QZ3ISt2TIL3Etq1mHcxhRZzzNQ6aRnbB/view - March 31, 2020

DxDiag.txt (115.0 KB)

3 Likes

When troubleshooting an issue, it is helpful to distinguish old reports from the new—particularly following a major release. The old thread dated back several months and encompassed many different issues since the launch of the game, so it felt like a good time to renew the conversation, request new details from those still affected (or experiencing the issue for the first time), and steer the discussion back on-topic.

If you would like to work towards a solution, please feel free to read and contribute to the thread with the requested details. Off-topic discussion will be removed to ensure that we stay on track, as we’re working to do everything possible to learn about the problem at hand.

2 Likes

Two things:

  1. The Steam link does not include the Real Steam ID Number. Would you mind following the steps to provide that informaiton?
  2. Do you have a replay file of the latest match when you encountered the issue?

Thank you!

I followed all of the steps exactly. When no numbers showed up, I even hit the forums to see different ways of finding it.

Way back when, I must have created the custom URL. Changing the random numbers to my Steam name. So where the numbers should be, BILBO the WANDERER stands. That’s my impression at least.

The March 31st, 2020 log is my most recent attempt of playing. It was after installing the most recent patch/update.

The other two were each different major updates, (If my memory serves me correct, I think there were around three of them)

Thank you for the additional information. I’ve passed the files you sent along to the team. If you do manage to find your Steam ID or generate a replay file following a match when you disconnect, please let me know and I’ll be sure to include that information, as well. :+1:

MY SOLUTION TO THE PROBLEM:

Hello, my friend and I had the disconnection at five minutes and we did the following in order to try to solve the problem:

  • First we tried to tether his wifi connection through his cellphone, but this method failed. Therefore, we concluded that the problem was not related to his network adaptor. We then thought it might be the case that there was some problem with the router.
  • We called his ISP and we made some tests. The provider suggested that we should change our IP configurations from private IP to public IP. After doing this step, the game was fixed.

I hope this solution keeps working after the next update and that it can help other players.

1 Like

any cons from going private to public? I don’t know anything about networking. Thanks!

Networks are not really my forte, but I would like to take a stab on this. Since the problem occurs at a more or less fixed time of five minutes, this issue might be caused by a licence server that pings every so often trying to check the user’s licence. This request might have been done in a different protocol (UDP for instance) and it’s crashing, or not receiving a response, or even trying to access a port that is not allowed in a private IP configuration.

2 Likes

You should be okay, unless you deal with very sensitive data in your network.

Save File And DxDiag:
https://drive.google.com/open?id=1ZPxgJLa7VReZFZyub_QAf1Rp-8spd94a
Image of error:
Google Photos
SteamID:
76561197980679029

The software won’t let me upload or put more then two links in the post so I created a folder in google drive. Hope that works.

1 Like

Totally works! Thank you for the information. i have passed it along to the team!

A post was split to a new topic: Unable to Connect for Multiplayer

Why dont you guys just think about some reconnect feature ?
Its mind blowing there is no reconnect feature so stuff like this will happen.

2 Likes

I’ve managed to figure out this issue but I don’t have a solution. It seems like AOE’s servers for mp does not work well with people under CGNAT. I can play fine using a VPN I created from my friends’ house and of course he can also play without any disconnections. Now that his ISP has placed him under CGNAT, he’s unable to play without disconnection as well. I guess it’s how the multiplayer connections work? I can play all other steam games without any issue so it’s probably something Microsoft can fix to work with CGNAT? I hope they can create a fix for this as a lot of people love this game online or offline. Thanks for the hard work.

1 Like

Just posted something similar. Basically people placed by their ISP under CGNAT is out of luck, especially if ISP does not allow you to covert back to a public IP. Wait, that’s me. :frowning:

1 Like

Vou escrever em português. Meu problema foi solucionado ao trocar de MODEM. Meu ISP era a NET/CLARO (modem antigo) e ao alterar para o modem novo do mesmo ISP NET/CLARO; o problema foi solucionado.

Ou seja, quem tem NET/CLARO, solicita alteração para o modem - F@ST3486 NET DOCSIS 3.0
FABRICADO PELO LOTE 02/2020

2 Likes

Enviroment:
MB : Asus X470 PRO + AMD 2700x CPU
Display card: Nivida GTX 1080ti
DRAM: 16g DDR4 with 20g virtual memory on SSD
NAT: Mikrotik RBD52G05Hac with gigabyte ethernet port
ISP : China Telcom connect with fiber bandwith 500M
Version: Steam , Update 36202
----------------------------------------------------------------------------------------------
Disconnect after 5-10 minutes on LAN game make me and my friends frustration . I loved this game so much, so I had struggled to play the game for 2 weeks, most games disconnected in 10 minutes. Yesterday I decided to build a pseudo local net above my physical ethernet by using OpenVPN, because somebody reported that VPN will prevent the disconnect issues. Although the test of OpenVPN failed, but I opened Win10 builtin firewall to let ICMPv4 passthrough for the test.
After the test failed the VPN was removed then the magic happened I can play AoE2DE LAN game without disconnect issues from yesterday. I belive the disconnect issues was solved by open ICMPv4 protocal to all in local net . Thanks God! Maybe the problem is that not every router allow ICMPv4 to passthrough.

------repeat my procedure---------------------------------------------------------------------

  1. open port 3478, 5222 both UDP and TCP as offical suggestions
  2. open ICMPv4 protocal in Win10 firewall
  3. set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    => IPEnableRouter=1
  4. enable services Routing and Remote Access
  5. execute 1-4 on all machines that will run AoE2 DE then reboot
    item 2 3 4 that are all prepare works before running OpenVPN. But I didn’t activate OpenVPN, just run AoE2 DE, then the disconnect issues just disappeared . Acturally I don’t know why?
2 Likes

Hi!
I have a similar problem. I have been disconnected with the game with this error on the screen:

. Interent is OK during the game.

This can happen after 10 or 20 minutes of playing, but I have not been able to play for a week already (Confinment without aoe2 DE :pensive:)

These are some of the games I was dropped from:


I Hope there is a solution. Have a nice day!

Stay safe

Dave

1 Like