[TRACKING] 36202: Disconnect within 5 Minutes of joining a Match

For me the game would lag a bit then catch up really fast. But sometimes it wouldn’t be able to catch up so the game would just crash. This is how I would end up disconnecting early on into the game, or even later in the game as well.
The way I fixed it was I just switched to a wired connection, there really shouldn’t be that much of a difference between wired and wireless. My guess it just has to do with the fact its using completely different drivers for each connection. If I switch back to WiFi it will still have the same problem.

1 Like

Thanks for the info, those svchost errors are gone. Unfortunately it did not resolve the disconnecting issue.

I noticed that when I spectate ranked games, the Game ID displays. Could we as players have it displayed at the end of a match as well if you can use it to analyze specific matches where the disconnects happen?

Would there also be a way to implement an error log that displays connection status throughout the match? Battleserver.exe does not seem to do much.

The port-forwarding solution was for AOE: DE. Is it the same as AOEII: DE?

I also noticed that the problem is not opponent-dependent. I disconnected from a ranked 1vs1 game today with a player I played a complete ranked 1vs1 match against yesterday.

That shouldnt matter, no game server hosting server would ever rely on ICMP/Ping requests towards their end user.

Im more interested about you mentioning that you removed the VPN. Does that mean that you removed the TAPv9 driver?

Again, while it might be some factor I am not aware of myself, consdiering that we as players cant host our own games and must go via centralized servers, NATing, firewalling, CGNATing and port forwarding should NOT impact our ability to play the game.

This sounds way more likely to be related to this issue. Again why it takes such a long time to respond is wierd… If you have the logs still, can you just double check against all odds if it is a client or a server listening?

Do you play with or without Enhanced Graphics Pack enabled?

That is a good idea indeed

The color coding of the clock next to the player works like that afaik. It can change from green to yellow to red.

Probably not and usually also not needed with NAT punch through server connected multiplayer games anyway. The good thing about that is the fact that ports are randomly chosen by client on outgoing connection to the server. The bad thing is that if the stream dies or the keep-alive fails or session is reset because whatever reason it breaks.

I double checked all my network situations, and my odd solution that using not been activated OpenVPN .
I found that my internet is connected through PPPoE , so the maximum MTU should be 1492 , but all Win10 PCs under this network their MTU is all ethernet standard 1500, that will be a problem when the traffic jammed with MS or Steam servers and the accumlated TCP packets length is large than 1452.
Although OpenVPN tunnel had not been activated but the background services was running, and the TAPv9 driver was there. In OpenVPN configrations I setted “mssfix 1450” . Which means after handshake no TCP packet length will large than 1450 that just prevent the MTU mismatch problem.
To test the assumption I removed all OpenVPN related drivers and disable all I have done before. Than test =>the disconnection happened again.
Just setting ROS router’s IP Firewall Mangle Advanced=> TCP Flags=> syn to let MSS = 1450 . It works, no more disconnection!
So I belive if you are using PPPoE to connect internet then set TCP MSS to 1450 is the key to solve the disconnect issues.


Previous OpenVPN configration here


I changed the MTU value on my PC and looks like it solved the problem.
Thank you

1 Like

I would like to try this fix. But can someone please tell me what MTU is :smiley: and how i change it ?

1 Like

Could you please someone make a step-by-step of this MTU user-end solution thing ?
It seems to me you used a third-party program to setup the firewall

1 Like

Ok. Tested the USER-END-MTU-THING-SOLUTION (not a actual solution btw)
And it WORKED!!

Here a step-by-step how to do it:


Press Windows + R and type:




Right click on the cmd Command Prompt then right click again on it and click “Run as administrator”


STEP3 (optional):

to know your MTU-■■■■-stuff-thingy type:

netsh interface ipv4 show subinterfaces

your MTU is the “Ethernet” one


To change MTU-stuff-stuff-thingy to 1450 type:

netsh interface ipv4 set subinterface "Ethernet" mtu=1450  store=persistent

Once again. User-end-solution. Is not a solution.

Solution is MS fixing their code.

Credits to @LordAlex1031 that find out everything.


Unfortunately, this does not resolve my 5 min. disconnect issue :frowning: . My routers MTU is 1500 and it’s the proper MTU size as I have checked using ping www.google.com -f -l “MTUsize”. Hopefully I can find one soon that’ll fix it but thanks for this. One less troubleshooting for me to figure out.


I have changed MTU on my PC according to the step by step guide, but it does not work for me :frowning:

changing mtu does not fix it for me, it still disconnects after the typical 5 minutes

It did not fix it for me either…still disconnects. :disappointed:

1 Like

On Thursday I called my ISP and asked them to be put me on a static IP address. I’ve been meaning to do this for a while for work purposes, instead of using Dynamic DNS (although it does cost me €5 per month). Now my IP is solely dedicated to me.

After doing this on Thursday I haven’t had a single disconnect - around 8 multiplayer games in now. It used to disconnect almost every time. I’m still cautious as I’ve had good periods before, but never this long without a disconnect. Fingers crossed the CGNAT issue was my problem and it’s fixed for me (albeit at a cost).


Old fashioned PPOE is mainly used with VPN and DSL land lines. So it could very well be that the MTU solution only works for those situations. Some routers have also the option to enable / disable MSS clamping, that might be related to this subject too. Just test it by enabling if you have DSL line.

still having the issue

My brother just got this issue when we downloaded the game yesterday. But his computer is slow, so it might be that.
But I thaught of one thing, IP6 is always troublesome. Can that be a reason? It would explain why it works for some somewhere and not why isp setting may fix it
Have anyone tried if that is a good workaround?


This is happening to me also, only when i play 4 vs 4, at 20 minutes it kicks me out with the issue all mention here.

I can plan well 2 vs 2 or 1 vs 1 without any issue but this must be fixed asap and besides that nothing prevent the devs to make a reconnection logic as it also will hugely mitigate this issue itself. For example i am kicked out and 30 seconds later mi ethernet device revives and i re open aoe2de again and automatically i rejoin the game. Of course i may have lose a team figth or have a barrack less in the game but i actually can response back!. 1 minute of downtime of me in the game isnt going to make me lose the game at all!!!.
Also regarding the reconnection feature most of us that love this game with passion since we were kids will completely tolerate that!, it will make the game playable at minimum and thats all we need!.

Please put all your resources to make the reconnection feature!, it will mitigate instantly all this as its 6 month with this huge issue for almost 30% of the people who buy it!

BTW: I am drunk

kinda… today i droped 2 times in a row … my mtu-stuff is at 1450 i double checked.

One at 6 min other at 9 min



Tried change MTU to 1400 (trial and error like an idiot) dropped (3 times in a row)


Also droped at 1500

I’m done. No more Age until MS fix their ““well written code””

1 Like

Good morning gentlemen,
I have been testing various methods to find out what is the generating factor for this problem, from changing the IPv4 to changing the MTU, I have already published my data for solving the problem above, I have tried the steps mentioned by colleagues but they also did not work. I notice that in some moments the game works for 5 ~ 10 min, sometimes 15 ~ 30 min depending on how many people are in the lobby (3x3 or 4x4), however it always disconnects. Finally, I realize that I can only play perfectly with the use of VPN, so I see that the flaw is in something minimal, which can be fixed easily, but I still haven’t found where the problem is. I am available to provide new information to assist in this resolution.

At. Konder