[TRACKING] 36202: Disconnect within 5 Minutes of joining a Match

The problem is that some routers have its own firewalls, configurations and so on. Tp Links ones are just ■■■■!, i had to reconfigurate it, open ports and so on because most of them was black listed.

This game reuses great part of legacy code which is not prepared for todays hardware, i have seen it and it is really a mess, it seems noobs are programming. But it is legacy code and much more improvements can be done, i mean that part of the game must be re done again from scratch. I think devs are just re doing it if they are serious, about 30% of players have this issue and 20% of them solve it with vpn or just like me reconfiguring the router totally but new players and those 10% will leave this game and make another 50% of potencial next players dont even try this game at all.

So in conclusion we are loosing community, better match making to the end of the day and more quick games at loobys.

If i had 15 years i will try to re do the code by myself but i dont want legal issues and i have a family.

Please fix this game and the dev efforts must be 120% in this particular issue!.
When you play with 0 problems like me, a game after work to relax after a hard day of engeneering and coding life it is much better.


@MarioHosmar for greater support those who are trying to configure their routers, what steps have you taken?
For example, I have a TP link that I installed today just to try to solve this problem, but I still don’t know what the correct settings are.


Sadly it really depends on router and if it had the options to do so. MTU and port fordwarding, tcp session timeout(which i do not have the option to change), also DMZ your current ip. Everything that is potencially prevented to communicate with servers that the router is able to reconfigure, vpn works in most cases because it surpasses all that configurations from the router in most cases, this was not an issue at all 15 years ago as router was much more insecure and developed.

Try all those options that worked for lots of us, but again you depend on what is able to be configured on your router side, this must be fixed by devs. It is really unaceptable, we bother doing all this things because of so much passion for the game.


I will paste configs here for tp-link later(i am now beign ■■■■■■ in the ■■■ by my work), fortunatelly they are not much of them. I was not able to change tcp session timeout(it seems my isp is good enough to not need this) and MTU was with the optimal value out of the box. Also i did not need to create a fixed public ip, sadly it depends on so many things, router, isp but we have nothing to do but configure it all and try.

@UnwornCarrot934 if you have a new router, like you said, TP-LINK, follow the steps:

  1. Access your modem from your ISP and find a function called BRIDGE and enable. Most of modems from ISP should have this option;
  2. After you save the configuration with BRIDGE, your modem from ISP will reboot and stop to routing;
  3. Now Plug a cable between TP-Link and your modem ISP;
  4. In a few minutes your TP- LInk router should get a IP and distribute to other devices connected on TP-Link. No need aditional configurations on router from TP-Link.
  5. Test your internet and test the game.

PS: If you not get success in get IP on tp-link after change to bridge on modem ISP. You can reset the modem from ISP to get back the standard configuration.

1 Like

Ever since server problems arose at the weekend where everyone got kicked out I’m not disconnecting every game between 5-10mins. I went for a week without a single disconnection before this.

1 Like

Thanks for the info! So the solution, to buy a new router (When other games and streaming and internet is working well), can be more expensive than the game itself…this is nonsense. It looks like an apple product :grin:

1 Like

TP-LINK TL-WDR4300 settings:

With those changes i went from playing 5 minutes 4 vs 4 games to ones that lasted more than two hours without issue, i make this changes 4 days ago and i think i have played since then almost like 7 or 8 4 vs 4 games perfectly.

Tcp session can not be modified in this router and MTU was fine also by default.
Dmz config i do not think is neccesary but it worth a shot, for this it is better to have a fixed ip in order not to change it every day in the config.

Hope this helps

1 Like

@MarioHosmar Good evening!
I am trying to configure my main modem, which is also a router.

The equipment data follows again:
** Router and Modem: ** ONU GPON AN5506-04-FA
ISP: Brisanet
País: Brazil

I already opened doors 3478 and 5222, I put the MTU in 1480, but I didn’t understand how this part of the DMZ works.
All of these procedures work temporarily (1 or 2 games last up to 50 minutes, and the next ones fall back in 5 ~ 10 minutes).

I reinforce that I am able to play only with the use of VPN, which makes me see that the problem is only in some configuration detail.


Yup tried that, but doesn’t work… I think for now I’ll stick with the Mobile Data solution, hoping it won’t get too costly :wink:

Desconexiones poco después de unirse a un juego multijugador, especialmente después de aproximadamente 5 minutos de unirse a un lobby o partido del juego.



Dejo los datos solicitados.
Espero su respuesta. Gracias

1 Like

Its bad for me and for the people that I try to play. Always one less player after 5 min game! So sad to see that nothing has changed!
Edit: why did u delete my previous post? Because I said it was frustrating?


Everything worked fine until 2 weeks ago.
I did not change any router settings. Now i get the Error every time!

Best Regards

Hi, i might have a new solution.

I had the problem, that i recieved a disonnect after 5-6 minutes in every multiplayer session.

I worked trough all the steps, like port forwarding, updating the router and all drivers, etc. - but without any success. The error didnt disappear.

My final solution was to not to start the game via steam. I read about this solution in some of the linked articles btw.
I went to the install folder (…SteamLibrary\steamapps\common\AoE2DE) and startet the AoE2DE_s.exe with administrator permission. It asked me for the network permission after that for the first time, unless i startet it with steam more than 20 times.

So i finally had my first game now without any disconnect and it last about more then 20 minutes.

Excuse my bad english. Have a nice day.


Using VPN works for me only when I queue solo in ranked games (and it is very laggy). When a Steam friend joins my party, the game crashes the second we get into the match. Thus, I could not play ranked games with friends.

I’ve only managed to solve all the disconnection problems permanently by setting my ISP’s modem/router to bridge mode, but you need a second router just to distribute the WiFi signal (which I have). I’m having zero disconnects now and I can play with anyone, so i call it a win.

I tried that before you suggest it here and I set “run as administrator” to the battleserver too. It worked in 3 matches, but then it dropped again. So, thats not a solution and i started to play using VNP and its “ok”.

On a previous comment I talked about this: when I tried to connect to a VPN server outside my country (Arg) the game would give me that same error: unable to connect with Steam. I just connect to a server from here through the VPN, and all works fine. I hope this works for you too.

So far it really only works with the use of VPN. Which VPN are you using? are they free?


No. Free VPN for some reason don’t work. Well, they’re free for some reason too, right? I am using ExpressVPN and read about someone who got it working with NordVPN

April is ticking away and i hope that the devs have found a fix. if not my vpn subscription ends soon and im not paying again…

hopefully we wont get another summer color celebration while this is still an issue.