[TRACKING] 36906: Disconnect within 5 Minutes of joining a Match

:warning: Please note that this thread has been created to focus exclusively on disconnects (i.e. returning to the game lobby) shortly after joining a multiplayer lobby or game—most notably after about 5 minutes of joining a game lobby or match. Please ONLY contribute to this thread if you are experiencing this particular issue. Off-topic posts will be moderated.


  • Crashes: i.e. the game closing entirely
  • Disconnects for a specific reason
  • Any other issues with the game

IF YOU ARE EXPERIENCING ANOTHER GAME ISSUE, please take the time to search for similar threads or start a new thread if one does not exist.



Within approximately 5-10 minutes of joining a lobby or multiplayer game, you are disconnected from the game with an error message that returns you to the game’s home screen.

During the month of May, we’ll be implementing fixes for the connection issues which have been causing players to disconnect early on in their multiplayer matches. Until then, I’ve opened this thread to capture new and ongoing reports of the issue since the latest update (36906)—including any workarounds, diagnostic information, or other details that I can pass to the team for review.


If you are encountering this issue, here are the steps you should try first:

  1. If you are using a wifi connection, try direct-wiring into your modem.

  2. Ensure you’ve updated your modem and router software/drivers.

  3. If you are using a HUMAX router or modem, try setting it to Bridge Mode.

  4. Ensure you have worked through the networking steps, here.

  5. Verify that you’ve worked through these steps.


If none of those steps work, here’s what you need to provide:

  • An IMAGE or VIDEO of the error message

  • A SAVE GAME or REPLAY file of the game when it happened.

    • Host it in a Google Drive or OneDrive folder and share a link so we can pass it to the team.

    • Open your Steam client and choose View , then click Settings .
    • Choose Interface and check the box that reads, "Display steam URL address when available."
    • Click OK.
    • Now click your Steam Profile Name and select View Profile .
    • Your SteamID will be listed in the URL at the top left as a long number at the end of the URL.
  • A copy of your DXDIAG file.

This information will be passed to our Test team so they can continue to look for common factors between players.


If you manage to find a solution, be sure to let us know here, as well, so we can integrate it into our troubleshooting. There are a ton of factors that can lead to this issue, and we are exploring every avenue in search of a solution for everyone.

Thanks for your help!


Hi @GMEvangelos. Already updated to the new patch and the problem stills happening. Also already tried all steps you asked (including playing direct-wiring with a 100mb good quality internet).

I’ll try every day in May and if the problem get fixed I let you know.

Thanks for your efforts.


@GMEvangelos Hi, so no change for me. Out of 3 games that I did play I got 2 disconnects.

My disconnect rate is ~20% - as said in the thread for 36202.

You can find the replays of the 2 disconnects in the savegame-36906 folder of the following link:

This situation is really testing my friends nerves.
Looking forward to the May update, though … :confused:

Did play 5 games today of which I had 3 disconnects - I have added the third replay to the above mentioned folder.



I’m also experiencing this error, where in basically every game I get disconnected after 5 minutes (sometimes after around 10 minutes) of online gameplay.

A lot of my friends are dropping in the same way.

I have tried most of the solutions presented on this forum, but the only one that worked (sort of) was using a VPN. However, when using this tool, I can’t access the multiplayer area of the game (a friend has to invite me to the lobby so I can play online, wich means I can’t play unless someone I know is also online).

When I get disconnected, is only from the game, the internet is working just fine. Most of the time I’m on a Discord call and it is not interrupted in any way.

Maybe the disconnection only lasts for a microsecond, enough so the game kicks me out. A feature that allows me to rejoin the game, or a bigger window of time before the game decides I’m not online anymore shoud fix the problem, but clearly I’m no expert.

Please don’t give up on fixing this problem, the amount of people having this issue is much bigger than it may appear.


-the image of the error have been posted before by other users
-Profile: https://steamcommunity.com/profiles/76561198
-Server: south american (brazil)


Problem is still lasting. My disconnect rate is 100% if i play without VPN.
Btw. What is really weird is that when i launch the game without VPN, go to multiplayer and join a game as spectator - i can see the whole game until the very end. AFTER the game ends and i leave the statistics i can see that i am already disconnected - so i need to restart AoE. But it is really weird i am not kicked out during spectating


Hey guys!
I may have found a solution to me. I was disconnecting 100% of times before the upgrade and right after it. Only VPN was working. Then, i added an exception on my windows firewall (both inbound and outbound rules) to BattleServer.exe and AoE2DE_s.exe.
Since then, i’ve played 6 matchs in a roll and not even 1 disconnetction.

PS: i am not sure, but i guess i already had the inbound rules to both. But then, the outbound rule may have made the difference.
Sorry about my poor english.

1 Like


First the infos, also sorry, my english is pretty bad:

DxDiag: https://drive.google.com/open?id=1EnNugA-wvD0ddca4RgfY3qfwacud15dX
-Profile: https://steamcommunity.com/id/jmarcelo2805/
-Server: south american (Brazil)
-ISP Contato Internet EIRELI (PPPoE service)

  • Modem Tplink Archer C60 V2.0

So the game always disconnected after 5 min, (put 55 min treaty) between 50 and 48 min the game stooped working. I changed some configurations on my router and the game is now apparently working (further testing necessary).

The Changes:
-I was running only IPV4 on my PPPoE network, so i configured IPv6 also (ISP recommendation). the games still disconnect after 5min.

  • I enabled IPv6 tunneling in 6in4 mode.

Since the changes i have played 3 or 4 matches and its working fine.


Hi. Would you mind pls explain to us (who dont understand these things) what enabled IPv6 tunneling in 6in4mode does, and how to do it ? :smiley: thx

Dont get me wrong, i am not a network specialist, this is what a understood: Basically in some cases IPV6 connection get prioritized over ipv4 , so assure that your connection with your ISP is set to both IPV6 and Ipv4, on my case i use fiber and a PPPoE connection, so a can make this configuration(I.E Set Ipv6 and 4 at the same time), on other methods of connection i dont know if it is possible. And tunneling 6in4 is a method for transmitting IPV6 packets in a IPV4 network. Please correct me if i am wrong!

Edit: So the general ideia is to get connected with the server via the IPV6 standard. I was getting disconnected 100% of the time before, I need to play more to assure that this fix is working.

But where can i find these changes ? And how did you enabled that tunneling ?

People need to stop spreading myths about port forwarding and IPv6.

This is 100% not related, as the server connections are made over IPv4 flawlessly, and Microsoft is running their own severs. There is no inbound traffic on AoE2 DE when you play multiplayer.

I think the community manager should put a list of things confirmed to NOT be realted to this issue, so that everybody saves time.

1 Like

Find it in my router ipv6 configs

Sorry, just sharing what worked for me, berofe the changes the game crashed every time, after the changes the game is working, so I think it is a strait forward conclusion, but I understand that this may no solve the problems for everyone, just hope i helped some one.


After the update, it is possible to play for 2 days (5 games) without disconnecting, but today, simply with nothing, start to fall again between 5 to 10 minutes.

Follows below everything requested:

My ID Steam Real:


Follows savegame in Google Drive disconnect:
Demo: https://drive.google.com/open?id=1SqIkJ9TaeDJ5c7nHJ6bkr3t47EClMvx9

  • Information about the TCP / UDP ports already open (Port 3478 and 5222 in the Modem and farewall)
  • Reinforcement that disconnects them is taking place between 5 and 7 minutes for no reason, therefore, i can only progress the game in multiplayer mode with the use of VPN.

The equipment data follows again:
Router and Modem: ONU GPON AN5506-04-FA
ISP: Brisanet
Country: Brazil

  • Konder

After the update, I cannot play on linux with proton anymore. Does anyone have the same issue ?
Before it worked perfectly well and now every game ends in an async error after 10s
I tried with another computer, a different linux distrib, and i get the same problem, either on wifi or with an ethernet cable
My friends (all on ubuntu) have also the same problem.
The only thing we have in common is the use of linux. We were able to play before with steam proton.

Has anyone experienced a similar issue ?

Hi @GMEvangelos… I said I’d keep in touch. Now I can play almost normally, just got disconnected 20% times of trying… But I noted that after 5 minutes, when I dont get disconnected, somebody who is playing that match gets… Maybe it’s a problema with BrazilSouth server…

Anyway, now I can play! I don’t know if you guys did something but I have no longer this issue! :slight_smile:

I disconnected from online games a few times but, I noticed that I don’t need to play online to disconnect. I can play an offline standard game then check 5 min later (quitting the game because there is no indication) and main menu shows that I’m disconnected from the multiplayer service. Trying to reconnect fails.

Tbh, I can survive without multi but I have to be connected to get the event’s achievments. So, as much as it is fun to research Chain mail 5 times, I won’t be against to actually keep the icon :sob: :sob: :joy: :joy:

I forwarded in my router the recommended ports, disabled Avast (don’t have access to firewall as it is a premium feature), then add the folder in exceptions, launch the game without steam (though it always prompts that it does try to use steam anyway) but it didn’t help. Only once, with Avast off I managed to stay connected (got the 256x cheat :relieved:) but couldn’t reproduce since.

The problem started after previous patch (March/spring one). It may be a coincidence but it’s shortly after I signed in first time with my Microsoft account (skype account, if it’s any different).

steam ID: 76561198831106040
dxdiag: https://drive.google.com/open?id=19mAZyExg5t0uAAfB1g44Z_VzNTJXc7ew
Router: Kabelbox CH7485e
ISP: Pÿur
Country: Germany

Thanks for your awesome hard job!

1 Like

Hi, I’m having this issue since the last update (the final days of April), is really annoying to be disconnected in the minute 5 or 10 of the game, I’m connected via ethernet and also opened the indicated ports in my firewall, but the issue persists, please help me to solve this. I really love this game but at the moment is impossible to play, also my rank has dropped so much (even when I’m being disconnected my ELO goes down).


1 Like

I am experiencing this issue in all of my online games, every game without fail has disconnected within 5-10 mins. Very frustrating way to get kicked repeatedly.

Really need a fix to this, game is unplayable currently.