Trade monopoly victory active in treaty mode

:arrow_forward: GAME INFORMATION

  • BUILD #: 11148
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

In treaty mode against NPC - rules states trade monopoly victory not achievable, yet the option is always there, and its frequently activated by allies and opponents. Been playing in the “unknown” map

2 v 2

:arrow_forward: FREQUENCY OF ISSUE

  • 100% of the time / matches I play (ALWAYS)

(when it is activated)

:arrow_forward: REPRODUCTION STEPS

Here’s the steps to reproduce the issue:

  1. Start a treaty-game (no matter the length of the treaty)
  2. Wait till the treaty is over and build more than 50% of the trade-posts
  3. The victory condition can be used to win the game.

:arrow_forward: EXPECTED RESULT

no trade monopoly victory

:arrow_forward: ACTUAL RESULT

trade monopoly victory

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE (.aoe2record) of the match where you encountered the issue.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.

1 Like

Same issue for me with every map I’ve played.
Hence it seems to be a general non-map-related issue.

Trade monopoly victory should be completely deactivated for all treaty games or at least be implemented as an option to choose/set.

It is so frustrating to play e.g. a 40 min treaty and the NPC winning after 20 min as their starting point is very close to native trade buildings and NPC activating the trade monopol victory.

Needs really urgent fixing and I cannot really understand why this is still not fixed although mentioned by a lot of people several times since release as well as in beta.

1 Like

Thank you for the report! It looks like we have a task and a fix on the way for this issue; watch for it in an upcoming build and let us know if—after it appears in the notes—you continue to see the problem!

Thanks again!