Unable to install AoE Definitive Edition


Not sure why but my installation is failing as I am not able to download the game properly. Download goes from 0% to 100% within few seconds, which I believe is not possible given only 50 MBPS speed. I have tried below methods but still nothing works.

  1. Singin out and Signin back in Windows store
  2. Using wsreset
  3. Using Throubleshooter on Windows store
  4. Uninstalling and Reinstalling Windows store using PowerShell Admin
  5. Unsintalling and Reinstalling Xbox App
  6. Removing all the Temporary Files
  7. Stopping Windows Update, Change Software Distribution folder and restarting Windows update

Will appreciate if someone can suggest other possible solutions.

Hi @DarnedPlate2018, Do you have the latest May 2019 Update, Windows 10 version 1903, installed? The game requires this version of Windows 10. Also does your system meet or exceed all of the minimum system requirements here including storage space?

I am not sure about it. How do I ensure that? I purchase the game in Aug 2018 and have the old version installed. But recently received a prompt for free upgrade to allow cross play. However, upgrade is not getting installed.

@DarnedPlate2018 You can check your version of Windows by clicking on the Start button, typing “winver” without quotes and pressing the Enter key. The window which pops up will tell you the version of Windows 10 installed on your PC.

More info about the upgrade to the new crossplay client is here: Upgrading to the latest Age of Empires: Definitive Edition (Windows Store)

I thought you were asking for version of the game. My windows version is Windows 10 version 1903. The information present in URL ( Upgrading to the latest Age of Empires: Definitive Edition (Windows Store)) is for regular download. However, in my case, clearly this is not working and I have already written what all I have to help resolve the same and still the issue exists. As there is no phone support line, do not know if I will be able to resolve the issue ever.

Have you tried creating another administrator account and signing into the Microsoft Store app to download the game?

Same issue. Download is still failing even on the new admin account.

Are you able to download the game on a different internet connection?

I have tried my home broadband and phone connection, in both cases it fails.

Just to check, are you installing this version of the game: https://www.microsoft.com/en-us/p/age-of-empires-definitive-edition/9njwtjsvgvlj?activetab=pivot:overviewtab ?