Unable to play online since launch


I have not been able to play this game for days, but I have tried many things to make it work (disable firewalls / anti-virus, open ports, …) but nothing changes.

The worst thing is that I even tried on all the PCs in the house and on each of them, the problem is the same.

The solo game works perfectly. But as soon as I click on “multi-player” loading already takes 1 to 2 minutes and once in the search for party, latencies servers also 1 minute to be seen. When I want to create a game, once again I have a loading time of 2 minutes to finish on the error message “Timed out”.

Since i spend more than 2 hours trying to fix this game, i’m unable to get a refund from Steam…

Has anyone a way to fix that because I really want to enjoy that game again?

1 Like

No idea what could be causing this issue sorry, could be a lot of things; since you tried in different pcs, then should be a network problem right? You can still refund the game for any legit reason past the 2h mark.

Unfortunately they refused my refund request despite the explanations of not having access to the multiplayer part of the game.

It must be a network problem, but AOE is the only game that does that. My internet is still very good with an average of 15ms in ping and 100mbps…

I really hope to found a solution because in my group of friends I am the only one with this problem.

Maybe a compatibility problem with my modem model?

Which modem model do you use?

The one provided by “Orange” my internet provider in Belgium. The model is the Siligence TCG300.

It’s fairly recent docsis 3.0 model. Are your computers cabled or wireless connected? Also, do you by any chance use another router in between?

I use CPL but I have already tried to connect it directly by cable to the modem without success and no, I don’t have another router in between.

1 Like

Thank you for adding this info. I’ve read somewhere that the firewall configuration of those Orange TCG300 modems is disabled by default (after factory reset). Could you check if it’s enabled in your case? It could very well be that it’s functionality blocks your online gaming experience because of blocking all ICMP request e.g…

Do you also play other games which do work well without problems?

The firewall is off and yes I play a lot of other games like CoD MW, LoL, Apex, CS:GO, … and AOE II : DE is the only one with that problem…

You said that you already portforwarded to the recommendated ports, right? Care to test if they are really open?

Caution sharing any prints from the site above, it reveals your IP and can expose you online!

UPnP is also enabled?

Although it doesn’t need it as it is server based.

If you launch Xbox Companion-console and test the Xbox network connection what results do you get there?

I gave access to all UDP / TCP ports to AOE II: DE. I don’t know what ports AOE II DE uses…
I also enable the DMZ host on my modem without success.

UPnP is disabled and everything is fine on the XBOX companion network test (NAT : Moderate - Connectivity : Connected - Latency : 48ms - Packet loss : 1%)

1 Like

Packet loss of 1% is not good!
Also latency is rather high for broadband connection.
I would request your ISP to perform a coaxial cable test.

My latency is 10 ms and 0% packet loss.

I was downloading while doing the test, mb. I’m at 23ms and 0% now

Strange. Just tested while running speedtest.net and got 15 ms and 0%. Anyway are there other special settings enabled on that modem like parental control, do you use NAT at the moment for port redirection? Which ports did you forward?

Afaik there are no special requirements regarding port forwarding for AOE II DE.

There are ports to forward for AOE I DE though.

As far as I know the game uses ports 3478 and 5222 (TCP/UDP), try fowarding them.

A 1% packet loss is surely not ideal, but I wouldn’t say that is something to worry, to be honest. And latencys can of course vary due to some conditions, I also find a 40 ms pretty acceptable.

I disagree. On my second monitor I’m watching a TV stream from my provider while testing NAT and running a speedtest.

Also please show me one link of where the team or developers state that they indeed use Xbox Live network for MP part of AOE II DE?

I think there is something with his connection and that could very well be related to modem cable problems. High latency is not a problem, packet loss is.

So here i’ve opened both 5222 and 3478 but, when i’m testing with openportchecktool, it says that both are still closed… Maybe i’m doing something wrong?

I made 4 new inbound rules (2 UDP and 2 TCP) and i also did the same on my modem. Is it done right?
(sorry for the firewall SC in french)

There are some routers that, even with the interface available for it, do not support portfowarding. This is fairly common on models given by the internet provider company. Search about port fowarding specifically to your model.

You don’t need 2 separate rules for each, a single TCP&UDP rule will do it.