Unable to Publish Mods in Game, Perpetual Publishing Screen

:arrow_forward: GAME INFORMATION

  • GAME BUILD #: 101.101.59165.0 8211018
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10 Pro

:arrow_forward: ISSUE EXPERIENCED

I am a random map scripter responsible for maintaining a few map-packs in the form of mods. Most of these map packs are used for competitions and it is critical that there is a single place participants can go to download the maps. A few days ago, I noticed that there were duplicates of mods I had created appearing in the “My Mods” tab. To mitigate confusion over which was the correct one, I backed up my files and unpublished ALL my mods, and uninstalled the game. I then reinstalled the game, and attempted to republish my mods one at a time. I can’t even publish one. Whenever I go to publish a mod, I fill in all the correct information, but the game never actually publishes the mod, it just sits there spinning forever. I even let it run overnight, and it still would never publish. As far as I know, I no longer have the ability to publish a mod in-game. I can still publish mods through the website.

:arrow_forward: FREQUENCY OF ISSUE

100% of the time (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

  1. Be me.
  2. Place the correct files in the local mod folder in the game directory.
  3. Restart the game, verify that the appropriate folder now appears under “My Mods” tab.
  4. Hit “Publish”
  5. Fill in appropriate information.
  6. Wait forever for nothing to happen.

:arrow_forward: EXPECTED RESULT

Mod would be published, no duplicate titles appear in “My Mods” tab. Published mod would contain the appropriate files that were transferred from the local mod folder.

:arrow_forward: IMAGE

Attached some screenshots of the process. First is just the infinite loading screen

Second is what it looks like when I close the game after 15 minutes with ctrl+alt+del and restart to look at “My Mods”:

Finally, I know that this isn’t working because when I check my subscribed folder, there is nothing in there:

Thank you in advance for any support you can give to this issue!

HI @ThorsChariot200 !

Do you still have this issue? Veryfing files in Steam (AoE, properties, Local files) do not fix the problem?

Can you share with us your Enhanced Logs?

Thanks!

I tried updating my mod several times via the mods webpage, and I had a similar problem. It just doesn’t update. The screen gets redirected to the mod page, the date of “last update” changes, but the changelog, description and file remain unchanged.

EDIT: it worked today.

1 Like

Hey @IkoKnight8151, thank you for responding and sorry for the delay – lost power for a few days and was unable to followup.

Now, I have a perpetual “loading mods” issue. I cannot try and update my mods if their list does not finish loading:

I downloaded the detailed log patch, and although I don’t fully understand them, I hope the information will be useful.
2022.04.18-10.06.46.txt (11.2 KB)
2022.04.18-10.18.52.txt (15.6 KB)
2022.04.18-10.23.25.txt (18.5 KB)
2022.04.18-10.53.35.txt (9.0 KB)
2022.04.18-11.27.58.txt (16.3 KB)
2022.04.21-13.28.41.txt (10.7 KB)
2022.04.21-13.57.37.txt (10.0 KB)
2022.04.21-19.42.53.txt (10.3 KB)
2022.04.22-09.03.54.txt (11.4 KB)
Age2SessionData.txt (136 Bytes)

**Note, only the final log or two are downloaded with the patch you recommended, since I did not know about it on the 18th and needed to establish a baseline of where I was at this morning before downloading the patch today.

Please let me know what I can do to help you figure out what is going on. Folks are hounding me to release the mod containing at least one map so they can practice for the competition. Thank you! :slight_smile:

TechChariot

1 Like

Does anyone have any thoughts on this?

Thanks @ThorsChariot200 , I update our ticket with your files ^^