Upgrades in Chinese war academy disappear

:arrow_forward: GAME INFORMATION

  • BUILD #: 100.12.3552.0
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

There are two bugs I’m reporting:

  1. In age 4, Upgrades in the Chinese war academy will be shifted down a row, and the last row will simply disappear. This bug has been reported so many times but it’s such an urgent bug need to be fixed so I’m reporting it again. This effectively makes the Chinese civ not viable in many games.

    This bug has been reported since beta and it’s still NOT FIXED.

  2. Units still get stuck in tribes. I have one game where my factory wagon stuck in a trade post :frowning:

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • 50% of the time / matches I play (FREQUENTLY)

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

First bug:

  1. Play as Chinese
  2. Upgrade to Age 4
  3. Send some cards and upgrade the castle attack

Second bug:

  1. move units across native tribes.

:arrow_forward: EXPECTED RESULT

  1. War academy should have 8 upgrades.

  2. Units should be able to move out of tribes

:arrow_forward: ACTUAL RESULT

  1. War academy only have 4 upgrades.

  2. Units stuck at tribes cannot move.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.


Thank you for the report! I had seen this problem mentioned, but didn’t have a specific case (for the upgrade issue). Both are being tracked for investigation by the team! :+1:

it is related to Confucius Gif and upgrade a castle’s attack/HP. Unfortunately in order to upgrade the units we cannot upgrade the Castle until we upgrade every unit of the War Academy

This issue only happens when you upgrade anything from the Hill Castle. If you do not upgrade anything in the Hill Castle the last row of the upgrades does not shift in the War Academy.

Really? since the game was out I never saw the bottom row upgrades. At first I thought they simplified the tech tree (e.g. I thought that the iron flail upgrade applyid to both iron flail and meteor hammer), but I was wrong.

Too bad because as I said elsewhere, the chinese units is what makes China interesting to me haha.

This issue is currently being tracked, thank you for the report.

This problem still exists

This hasn’t been fixed !!