User Privilege Error

Game Version: age of empires 2 definitive

  • Platform Microsoft Store


I have given aoe2 all privileges I can, both in my Microsoft account privacy settings and app settings but whenever I launch the game I receive a pop up that states there is a User Privilege Error.

This means that I am unable to access the multiplayer or mods options from the main menu.

I have tried uninstalling and reinstalling the application, I have also tried revoking permissions and accepting them again once the pop up appears. I have also tried selecting allow in every privacy permission to rule that out. I have also tried launching both the Xbox BETA app and aoe2 as administrator.

Reproduction Steps:

  1. Simply launch the game.


I have precisely the same problem.

Hi, to anyone reading this. I have managed to resolve the issue. I’m not sure which it was but I went to my Microsoft account privacy settings and allowed all of them. I had tried this before but it didn’t work. This time though I waited 30/60 minutes and then tried aoe 2 and this time it worked!

So the key seems to be waiting after allowing all the privileges. I don’t love the idea of allowing all privileges but for now at least I can allow them one by one until I find the issue. The need to wait 30 minutes though means it could take a while.

Same issue for days! So infuriating …ughh!!
What’s worse is that the error message is completely uselss! I have absolutely no clue why and what is wrong! So disappointed…

Hey folks,

One reason this pop-up may occur is due to the game launching in “Offline” mode as it could not reach the multiplayer services. As a first step, please check that you are connected to the internet before the game launches.

For Microsoft Store users, this might also occur on your first launch of the game if it did not fully sign you in to Xbox Live services. Please try completing the sign-in to Xbox Live from the top-right of the main menu, then close the game, and relaunch. Let us know if this resolves the issue for you.

I cannot even play the game becuase of this error and the message is so vague even contacting xbox support directly and changing the privacy settings i could see did nothing so is there a specific setting or page you went on please?

Hi, it was this section:

I allowed everything on there and waited thirty minutes and eventually the error went away.

Hey Folks,

As we have been troubleshooting this issue, we have put together a support article over on the AOE2:DE Support Page:

Please try out the steps listed on that article to see if they resolve the issue for you.

Still nothing helped. Will the Microsoft to do something properly?

@SpanCafe4763334 - Since the above linked support article has not resolved this issue for you, can you please provide us with more details about your set-up so that we can continue to investigate? Can you please let us know:

  • The build # you are on
  • The platform you are playing on (MS Store or Steam)
  • The firewall & anti-virus program(s) you are running

Hi there,
I found the setting which seems crucial regarding the shown error. In retrospect, it’s logical. But the error message is not.

You need to set “You can see and upload community creations” in privacy settings to “everyone”. I assume it’s related to the mods and the associated multiplayer settings.

Please, specify the error message asap. “User Privilege Error!” is far from meaningful. Had a 40 minutes talk with Microsoft Support, they had no idead how to help me. Checked half my system with support, didn’t work out the problem. I was about to give up the game still I started to test every privacy setting after “Nexus26”'s hint (thanks!).

1 Like

Hallo again,
I decided to do Belarc overview of my PC. Before that I had tried to lunch game. AND … it works. I didn’t have changed anything. BUT … Thanks to all of you for sharing of your experiences and support.

Hi again: finally, I had to install xbox app. Since that moment the game has been working.

I tried all of the things in this forum and and more from other forums. Still not working.

I have been having the same User Privilege Error appear every time I try to play the game but it can’t sync my data with the cloud I tried changing the privacy settings and it had no effect on my copy of the game and only thing that’s changed since I bought the game is restarting my Xbox live membership.

When I log into the game, I get the following error:

User Privilege Error!
Sorry, your account settings restrict you from certain features of the game. Please check your account settings on for more information.

Due to that error, I can’t play multiplayer games.
I’m running Windows 10 and I’ve installed the game via the Microsoft Store.

I already tried several methods, which were described in other, closed threads:

  • Setting all Privacy Settings to Allow/ Enable
  • Signing into my Xbox Account in the game (top right corner; I’m shown there as “online”)
  • Installing and logging into the Xbox App
  • Running the benchmark test for multiplayer games

You know you have it rough when your computer starts telling you to check your privilege.

1 Like

Age of Empires 2 - Definitive Edition
Microsoft Store
Windows 10
Gamertag: Died Rich90


I get the User Privilege Error!

I tried all steps described in this link:

Nothing helped. I checked my xbox-network connection. It is alright.

I have no clue what the problem is. I tried to allow all options in the xbox profile. Not even that helped.

I only bought the game to play it (yesterday for the first time :face_with_symbols_over_mouth:) with friends in multiplayer and now it won’t work.

I hope you can help me.

Died Rich90

Try to see if there’s anything that helps in this thread.


Thanks, that helped!
Kurim mentioned the missing setting: “You can see and upload community creations” in privacy settings to “everyone”
I had this set to “friends” .
Then you have to wait 40 minutes until the servers synchronise.
That had been the problem! I tried it before, but not an hour down the road…

Thanks for showing this thread.
Died Rich90