What's new in Age of Empires: Definitive Edition? - Age of Empires


#21

it says im running on a different version. what gives?


#22

Like seriously I payed for this game and yet I can’t even play it, it just crashes after the launcher. And it shouldn’t matter if I’m a windows insider. I should still be able to play it.


#23

Quando tento iniciar o jogo ele me traz automaticamente para este site, ou seja n ]ão consigo jogar


#24

as soon as I open the application and select Single Player or Multi Player it just sends me here


#25

Gates for The Wall would be Nice, instead of making an open large entrance surrounded of Towers for defence… hehe!


#26

Be nice of I could pay the game instead of reading messages


#27

when will we be able to actually play the game? I wish it just came out on disc like the old days so you can put it in and play it with not a problem in the world :slight_smile:


#28

The fonts are unreadable in the game. Looks fine on the start up screen but cannot do anything or read any of the menus. Tried many resolutions and graphic options. Games is basically unusable until I can change the font. The transparent color shows all the text as black. This MUST get fixed quickly or I want my money back.


#29

I am getting a Black Screen only with sound…background music…and no game no visuals…


#30

okay so I was one who pre-ordered AOE so I have reinstalled it and optimised my laptop to run the game… put it in gaming mode etc. Now atleaset the menus work and I can play around with all the pre game settings but as soon as I hit the start game button it crashes and goes to the Microsoft store where I bought the game from -.- so sick of it ive literally wasted my whole day to try and get it to work and I still am unable to start a game :frowning: very disappointed…


#31

I am also having trouble with the font, can’t see it, and the game is running slow and choppy. Very excited, however, to finally have it and I’m sure all the bugs will get worked out.


#32

Friend or foe color not all green blue - yellow for teammate and of coure red for enemy

Match making system Rating… ELO

I know is not possible but i think old msn gaming zone was far away better then this xboxlive. BTW add a chat and a list of players online in game … add more info about game room ( setting before enter ) was appreciated.

Please dont implement more in automatin of the game, this is aoe 1 ror remastered not aoe2 …

Chat in game more visible

Only 2 max population number - 200 and 250.


#33

Game isn´t starting, come to this page here after pressing Singleplayer etc.


#34

path-finding for the game must be improved as my units tend to stick to other units and are unable to maximize use of the space they have and i noticed scout horses dont attack enemy but tend to sit and watch so please fix this also some random fps drop for 1 second my specs are way above the recommended with a gtx 1060 also i noticed that the AI tends to focus more on resources rather than military making it very easy for a human player to rush the AI at the start


#35

Granted I’m not an expert on all the various iterations of AOE, the only one I’ve ever played is AOE2 Conquerors Expansion pack (which I’ve played about a million times), but some of these “new” features already existed (in AOE2 at least) - rally points, “villager” rally points, select idle villagers/military, “walkable farms”, etc. There are several features from AOE2 I’m missing in “Definitive”, like sending villagers to build a granary or storage point right next to a resource and have the villagers automatically start collecting that resource after they’ve built the storage point instead of just standing there like idiots. Sorry, gripe gripe, just not blown away - thought it would be like AOE2 but better. And why are the colors on the map so drab (compared to AOE2)? It’s depressing. I’ll see how I feel in a week or so…


#36

Taking back what I said earlier about villagers not automatically gathering resources after building a storage point - I must have noticed that while trying out “Classic” mode, but it’s working in the main “Definitive” mode. I’m noticing little bugs here and there but the game is growing on me… :slight_smile:


#37

How I can change resolution in game? I can’t found menu with resolutions in settings menu. Thank you in advance!


#38

Everything looks fine, but these “path-finding” GOD DAMN, i got a few grey hairs during gameplay. Everything stay and get block by " SPACE ", i mean there r a lot of space between 2 units but nothing can get through and stay and do nothing, These r in fight NO WAY !. It neeeeed to get change ! please do it, i did really a lot of advertisement here and there, but its just unplayable right now !


#39

how do you turn off the voice narrator, Every time i go over something it tells me what it is and how to use it,How Do You Turn It Off,any help would be great


#40

(Please wait another moment, We are not quite done syncing whit Xbox live )