When I tried to Update it, the game disappeared entirely

I clicked update in the Microsoft Store and the game disappeared. It shows up in the “Ready to Install” category along with the Enhanced Graphics Pack, but neither of them can install/update. I wanted to uninstall and reinstall the game, but it is no longer in my file explorer either. I played it all night last night, so it has to be the update. What should I do?

1 Like

Hi, welcome here. Just open MS store and click ... and then on Downloads and updates. In that screen click on Get / Download updates. It should trigger the update mechanism.

It doesn’t. There appears a Get Update box which I press. But after I do, it says “All your trusted apps and games from Microsoft Store have the latest updates”. I return to My Library to launch AoE2 and it has an Install box next to it. I click the box and circular dots appear as if it is installing. But that has been going on for over an hour and no progress bar has appeared. If I leave the page, the Download arrow will appear next to the game again.

If you search for the game in MS store and open the game in MS store do you see a download arrow in the top bar of the MS store app?

If so click that and then click the download arrow in the queue to trigger download manually.

That’s what I’ve been doing. It does not download.

Hmm, that’s strange.
Is it by any chance stuck in the download queue?
Are there other Windows update available, please check it through settings.

It updated automatically for me this time but there were some Xbox TCUI and Xbox service updates too available afterwards. I always check manually too at monthly update time.

Other thing you could try is to sign out from MS store and then check for other updates there, cold reboot computer and router and then try it again.

There actually were a few updates that needed to be done, and I attempted the cold boot after the updates were completed, but I still have the same problem. Even the desktop icon for AoE2 has disappeared. I can’t even delete/uninstall in an attempt to reinstall it because I can’t find it on my cpu. And even though the Install button is available in the MS Store, it does not install or download.

1 Like

I think in this case you could try to reset MS store first. You can do this different ways like through the MS store app settings. There you can end the MS store app from memory but you could also use task manager for this (taskmgr.exe).

Then launch CMD as administrator and type:
wsreset and press enter, now restart your device again or type shutdown /r /t 0 and press enter to restart it by command.

1 Like

It worked! I did reset the MS store before you mentioned it, but I didn’t restart the comp afterwards. After I reset and restarted, it finally worked. Thank you!

1 Like

I did all the steps and it doesnt work,

, I was playing yesterday… I don’t know what is happening.

Did you end (kill) the MS store app first?

You can do this through app settings of the MS store app or using Task Manager (taskmgr.exe). After terminating MS store app try the wsreset and reboot commands.

Also check for Windows updates that still need to be installed and sign out temporarily from MS store and check manually for other updates there. You might even have to reboot your router (just unplug power for 30 seconds).

  1. End MS store with task manager, DONE!
  2. wsreset and reboot commands, DONE!
  3. Check windows update and installed all, DONE!
  4. Reboot router, DONE!
  5. Reboot pc, DONE!
  6. Install another game from MS store, DONE!
  7. Try to install AOE 2 definitive edition, still not working.

When I click “install” and then I choose deestination of installation and click again install, still not working and appears the same button of “install”, not working anything.!

Nothing its working!

Same problem here! I wasn’t able to run the game today. It said “game is offline”. I’ve tried to install it again, but the Install button in MS does nothing!

I have already did all sort of debug steps i’ve seen (reset MS, updates, restarts, etc.)

Any help?

Same problem here also. i was playing the game for 1 month and yesterday it said “game is offline” and i tried to download game again at MS, but no response, i tried to update at MS still no response. i reset the MS, reboot the PC, reboot the rooter, and tried again still same problem.
Please Help.

@Man024 @afranciscosa @ClannishRobin17
I would suggest to sign out from MS store app and sign in again. Search for ‘Age of Empires II: Definitive Edition’ in MS store app and open it in MS store app. Please post pack a screen capture (using Alt + PrtSc and Ctrl-V in your reply). If you see a little down arrow in the top bar of MS store click that and post back a screen capture of that screen.

E.g.

Already loged out and logged in.

Here it goes the image (besides not allowing me to install, also doesnt allow to download / uptade)

What happens if you click that little down arrow?
You could also click on Retomar tudo (retrieve all).
Please post back screen capture again.

If I press the down arrow nothing happens.

After retrieve all, it gets like this:

Looks like it’s still stuck on something in your case.

What happens if you click ‘Obter actualizações’?

I pressed “Obter atualizações” (get updates) and i got the image i sent in the print screen.

Pressing the arrow down and “retomar tudo” (resume all) does nothing…