[Almost] Every game since July 2021 Update has crashed

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 101.101.50292.0 6958215
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED


Every single game I have played since the update earlier today has crashed. Sometimes the crash is early in the game, sometimes it is late in the game. I am 3 for 3 thought with games crashing. Prior to this update, I rarely had crashes (Maybe 1 every few hundred games). I have played 1 ranked 1v1 random map, and 2 unranked lobby games. I tried one with my small tress mod enabled, and 2 without it enabled. No other mods. Computer: Windows 10, 32 GB RAM, i7-8750 CPU @ 2.20GHz, NVIDIA GeForce GTX 1060.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 90% of the time / matches I play (ALMOST ALWAYS)

Edited because I tried a few more games. 100% of ranked 1v1 crashed, 5 out of 7 unranked multiplayer crashed. 2 unranked multiplayer did NOT crash though.

:arrow_forward: REPRODUCTION STEPS

:point_down: List CLEAR and DETAILED STEPS we can take to reproduce the issue ourselves… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Play a game (any multiplayer type, any lobby)
  2. Wait for game to crash

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
The game should not crash

:arrow_forward: IMAGE

:point_down: ALWAYS attach a PICTURE (.jpg, .png, .gif) or VIDEO (.mp4, YouTube link) that highlights the problem.

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: Attach a SAVE GAME (.aoe2spgame) or GAME RECORDING (.aoe2record) of the match where you encountered the issue. Link it below if using an external file service.


I have this same issue. Since the update installed today my game crashes 100% of the time (4 in a row). I am playing single player against the computer.


In the new patch notes you can read this:

  • If your game is crashing, there’s a new type of log file that was introduced in the last patch, and it looks like this (example): AoE2DESteam-46906-2021.04.06-15.46.57.mdmp
  • The file can be found in this directory: C:\Users[YOUR WINDOWS USERNAME]\Games\Age of Empires 2 DE\logs

It also stated that it would help the developers’ work on fixing this issue hugely if you could post this file somewhere.

This form says “Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, txt, aoe2spgame, aoe2record, age3yrec, age3ysav).”

Where can it be uploaded?

SP Replay v101.101.50292.0 @2021.07.07 060055.aoe2record (8.6 MB)

Single player crash. I honestly haven’t experienced a lot of crashes before, but it’s surprising that right after the patch, I got one. Hope it will be the last.

1 Like

Just put a “.jpg” behind it and upload here…

Welcome to MP problems in SP 11 I have played the conquererors edition 15 years ago. 0 crashes on an, even for the time, ■■■■■■ PC for several years. Now DE crashes on my 16 GB RAM, 16 core CPU PC…
Would love to have a worse looking, but more stable game

1 Like


Cannot upload the log file, I get an error telling me uploads are not allowed.

I played 2 more games, 1 DID NOT crash for the first time ever, and then the following game DID crash again. Getting so sick of these updates, haha.

1 Like

They completely killed every single mod out there
They must hate the modding community with passion
Even tho forgotten empires started as modders
I really dont understand it

1 Like

AoE2DESteam-50292-2021.07.07-11.44.45.mdmp.txt (314.5 KB)

SP Replay v101.101.50292.0 @2021.07.07 111253.aoe2record (10.6 MB)

Yet another singleplayer crash just after the game ended as Sicilians and building Donjons. It’s slowly getting ridiculous.

@oooFreaKooo2214 : The only reason is Microsoft Store support and the fact that they want us to sell DLCs still.


I have the same issue. For me, the game is not playable anymore, because of the frequent CTDs.

Same issue here. Since the patch, I crash mid game with no error report. It happened during all my games.

I feel bad for one of my opponents - my game crashed for me, but it appears it kept running for them for some time, and they probably had to kill every single building and unit to end the game in a ranked queue.

Same here. From last patch the game crashes frequently. It’s no error message, just the game close and send me to desk.


Since update, my saved games from yesterday crash before it can be loaded. If I try to redo the scenario, it crashes a few minutes into the game

1 Like

Even tried uninstalling and reinstalling - didnt help

All my games but one have crashed today ):

Same here, played 3 games, 2 crashed to desktop


Same here. Getting constantly back to desktop after a couple of minutes.

1 Like

Same, every single campaing game i played it crashed

Everything keeps crashing, I wanna play, man, this is so frustrating