AoE II DE not starting up

Within the steam app i have attempted to run the aoe program several times. The icon with the three kings pops up and then it just stops. No error, no info, and no information of a crash report. I have no antivirus since i just recently factory reset. I got rid of my VPN, the firewall is minimal and i did attempt to turn that off and on to just make sure. I have uninstalled and reinstalled close to 8 times. One of them being to whole steam app… (Deleted all games.) But all that still has not worked. This is very upsetting and frustrating. Anyone have any idea on how to resolve this issue. I want to play! I want armies! battles! CARNAGE! Thanks for any assistance


I have the same problem. The icon with the three kings pops up and then it just stops. No error, no info, and no information of a crash report.

Im having the same problem, just bought the game on steam, the three kings pop up, and then it stays like that forever, the game wont launch at all, nor will it crash, just stay like that forever.

Edit, after many tries,it started working, dont know why.

Not for me, the three kings pops up, stays for about 8-11 seconds and then just closes. Nothing more or less.

Same problem here. Any solution?

Hi everyone! It would be really helpful to get a little more information to narrow down what is happening for each of you. Can you please post the information below:

  1. Build:
  2. Platform: Steam or Microsoft Store
  3. Operating System:
  4. Dxdiag
  5. Crash/game logs


Hi, I have the same problem, when starting the image of the 3 kings appears and then disappears, it does nothing more:
Platform: Microsoft Store
Operating System: Windows 10 1909


A post was split to a new topic: AoE DE not starting up

1: Current
2: Platfrom: Steam
3: Operating system Windows 10 1903
4: DxDiag.txt
5: No Crash/Game logs

  1. Build: 101.101.36202.0
  2. Platform : Microsoft Store
  3. Operating System: W10 1909
  4. No Crash or game logs

i found this info and worked for me

I don´t see any solution from AoE. ¿They just read us or what?

1 Like

For me it takes around 5 minutes to start the game agtercthe 3 Kings thing has been on the screen. This has began sometime around the last patch but I also susnribed to mods around this time. Disabling all mods didn’t help thought (haven’t tried unsuscribing)

It jused to start in a handvoll a seconds before. (release until last patch)

12 days ago asked for all this information and never followed up. now it’s been 3 weeks for this post and also no follow up or even attempted fixes by devs. I still really would like to play AOE but it seems like they are not caring. I seen updates to DE so i know someone is still putting updates through.

I have the same problem. The solution for me it’s to uninstall ans reinstall.
But at the update the wont launch.

I have the same problem.

I was able to fix it. I use the Spanish language (I suppose it applies to other languages).
My problem was that it didn’t start the game with the graphics package.
The solution was to change the language of windows 10 to English (United States) start the game and start !! So within the game I change to my language (Spanish)
Every time I want to play I change the language to English and that’s it

Hi there! I have the same problem; i reported a bug here: My bug

Maybe you can add you reply to my bug report if you have the same problem, so the devs could give it more priority

  • Build: 101.101.36906.0
  • Platform: Microsoft Store
  • Operating System: Windows 10 Version 10.0.18363 Build 18363

No graphic pack installed
OS language: English
Keyboard layout: Italian
No logs produced

Installed and reinstalled several times, it continues to crash

The game worked fine untill the latest upgrade on ms store. After that, the game just won’t start. Appears splash screen, and then the black screen. I tried to restart pc, repair and reset application, reinstall from scratch, nothing worked.

I follow the troubleshooting reported in theTechnical Issues section:

  • graphic drivers are updated
  • I have the latest Microsoft Visual C++ Redistributables
  • I ran the Windows 10 Store App Troubleshooter, didn’t help
  • I disconnected additional monitors
  • I uninstalled and reinstalled the game

The process AoE2DE is just marked like ‘Not responding’ in Task Manager

Faulting package full name: Microsoft.MSPhoenix_101.101.36906.0_x64__8wekyb3d8bbwe

I tried also to

  • download a game from the store, pause it, and then launch aoe2de
  • put my default keyboard language = english

oh! and also

  • Click Start
  • Search for and Open Services
  • Scroll down to Windows PushToInstall Service
  • Right click and select Properties
  • Change Startup Type to Automatic
  • Then Click Start if this service is not started
  • If it is already running click Stop then click Start for the Windows PushToInstall Service
  • Let it start then click Ok and close services
  • Try launch Age again

Game continue to crashes when launching, despite it worked like a charm until update 36906

Hi everyone! If you are playing through the Microsoft Store and having issues after the recent update, please double check that the game is still whitelisted in your antivirus program. We have found that since a new folder is created for each update, the game may not be whitelisted even if you have added it before.

If you have the Enhanced Graphics Pack installed and are playing on a computer with a display language other than English, please try uninstalling the Enhanced Graphics Pack. This is a known issue that the developers are researching.

If neither of these helps, please start a new post since multiple issues have been added to this one.

I finally worked out how i fixed it.

By running the game on administrator mode, it stays stuck on the three king pop up, after arround 5-8 mins it crashes and restarts, after that the game runs normally