Windows Display Language and the Enhanced Graphics Pack prevents AoE2 from starting

As requested by GMEvangelos in this topic I split this issue into a new thread.

Game Version:

  • Build Basegame: 101.101.34793.0
  • Build DLC Grafics: 101.101.34055.0

Issue:

After installing and enabling the Enhanced Graphics Pack on a System with the Windows Display Language Deutsch (Deutschland) (other languages like French, Korean, Dutch, Polish are affected, too), the game no longer starts.
The splash screen appears for about 1-2 seconds, but then disappears. At the same time, the process of the game also stops.
I have three log files:

You will find the error message in the 3rd log.

[...]
Initializing UI System
Initializing Additional Options
Initializing Localization Manager
Exception type 0xc0000005 occurred at 00007ff68a4b9a1f
Writing out log

The ingame Language has no affect. I tested different Language Settings in Windows but the only option affecting the startup problems is the Windows Display Language.
I don’t have an Anti-Virus solution installed, only the Windows Defender, which was disabled for testing, too - with no affect.

Reproduction Steps:

  1. Change Windows Display Language to Deutsch (Deutschland).
  2. Install the current Version of the Enhanced Graphics Pack from the Microsoft Store
  3. Start the game
  4. Make sure the Option to enable this DLC is set
  5. Stop the Game
  6. Start the game
  7. Game does not start any more

It could be perhaps relevant, that I have installed Windows with a local user but linked it later to a microsoft account.

Workaround 1:

Change the Windows Display Language:

  1. Search for “lang” and open Language Settings (in German “Spracheinstellungen”)
  2. Change the Windows-Displaylanguage (Windows-Anzeigesprache) to English (United States)
  3. Log off and on again
  4. Start the Game

Workaround 2:

Reinstall the Game:

  1. Find the App in the Start Menu and right-click it
  2. Select App-Settings
  3. Reset the app (Repair is not sufficient)
  4. Install the Enhanced Graphics Pack again from the Microsoft Store (At least it is not downloaded again)

Workaround 3:

In Order not to always reinstall the DLC and not to change the Windows Display Language you can do this:

  1. Start the game
  2. Go to Options->Graphics and enable the DLC
  3. Play
  4. After playing disable the DLC in the Options
  5. Stop the Game

Platform:

Windows Store

Windows 10:

  • Version 1909
  • Build 18363.628

Hardware:

  • Processor: Intel i9-9900KS
  • Grafics: NVIDIA GeForce RTX 2080 Ti
  • Mainboard: MSI Z390 Godlike
  • Memory: Corsair Vengeance LPX 64GB (4x16GB) DDR4 3200 MHz
  • Harddrive: 3x 1000GB Samsung 970 Evo Plus M.2 NVMe as RAID 5 using Intel Rapid-Storage with Stripe Size 16KB
  • DxDiag File (renamed to *.txt): DxDiag.xml.txt (133,2 KB)

I have the same behaviour on 2 totally different machines (my company Lenovo T580 Laptop and an older PC), too.

Other:

I saw many complaints of users who have the same issue in the German page of the Enhanced Graphics Pack in Microsoft Store.

9 Likes

Thank you for the immensely detailed report! I’ve compiled the information you provided and passed it along in a ticket for investigation by the team. I will let you know if there is anything else you can provide to aid in their work towards a solution.

Thanks again for taking the time to post! :+1:

4 Likes

Just wanted to say that I have this exact same issue. I had windows language set to Slovak. Setting it to English worked as a temporary solution. If you need something, I will be happy to provide it.

1 Like

Today there were some updates available - but after the installation the issue still persists.
Versions now:

  • Build Basegame: 101.101.36202.0
  • Build DLC Grafics: 101.101.36059.0

Error Message in Log now:

(...)
Initializing Localization Manager
Exception type 0xc0000005 occurred at 00007ff6181c20bf
Writing out log
1 Like

I have the same problem, Windows 10 Pro Czech (1909), Latest games version … After switching win to english language the game runs normally… The same bug was there in the early beta AOE II. DE

2 Likes

I have the exact same issue with latest build of the game and the enhanced graphic pack.
When windows display language is not English (in my case it’s Hebrew), the game won’t start.
The window with the 3 faces appears for few seconds, then disappears without any message or error.

Amy solution for this annoying bug?

2 Likes

I ended up fixing this on my computer. The problem for me [I think] had been caused by an update to or applied by Visual Studio 2019. Long story short the fix was:

  1. I went to the Apps & Features part in the Windows 10 settings, sorted by Install Date and uninstalled the most recent “Microsoft Visual C++ 2015-2019 Redistributable (x64)”.
  2. Opened the game’s steam folder, ran “vc_redist.x64.exe”, Uninstall. Ran it again, Install.
  3. Went to Microsoft official download page for latest C++ distro update and installed that.
    The latest supported Visual C++ downloads
    (scroll down on the page, you want “x64: vc_redist.x64.exe”)

Now the game runs fine.

Now, a couple of odd things in case the devs find this post…

  • Steam version
  • i7 6700K, RTX2080ti, 32GB memory
  • Game ran fine on 4-11-2020, problem was noticed 4-15-2020
  • English (USA) Win10 Pro 64

Symptoms:

  • Start game via Steam, steam indicates game started, then steam indicates no game running ~2-5 seconds later.
  • Run game via exe, appears in task manager for ~2-5 sec, then disappears. No new log appears in Games\Age of Empires 2 DE\logs.
  • Set exe compatibility settings to Run as Administrator. Run game via Steam. Error message “VCRUNTIME140_1.dll missing” and crash, which told me it was C++ distro problem. (I’m not sure why right-click “Run as Administrator” wouldn’t produce this error message, but compatibility or Steam running it as admin does)
  • I’m assuming VS2019 did it because it updated today. I suppose it could have been windows update or some NuGet package that updated this week.

My only real comment here that I really think it’s not acceptable that the game refuses to output a log when this happens and that the error message for whatever reason seems to be suppressed. I could have solved this in 30 mins, not 2 hours and a reinstall later. :nerd_face:

This is actually a different issue and I think this already covered in the Support & FAQ Page.

Hello @BlueBlur22, i also think it’s a different issue than @Pihaar1995 was having, but maybe just for the sake of completeness: can you check your log files in the C:\User… folder for AoE2DE logs, at what point did the game crash for you? Like, what was the last lines before “Writing out log…”, like in OP the last steps were:
Initializing Localization Manager
Exception type 0xc0000005 occurred at 00007ff68a4b9a1f
Writing out log

Thanks
Glad you got it running tho :wink: VC++ redist didn’t change anything for my problem

I have the same trouble.

Today there was a update for the Basegame available - Issue still persists.
Versions now:

  • Build Basegame: 101.101.36906.0
  • Build DLC Grafics: 101.101.36059.0

But now the error code slightly differes:

(...)
Initializing Localization Manager
Exception type 0xc0000005 occurred at 00007ff6708753af
Writing out log

@GMEvangelos Any chance that this issue can be added to the known bug list?

I downloaded the update today, but the bug with different languages still persists. Still can’t run with advanced graphics pack

Hey @Pihaar1995 and @NextMilda2000! I will get this escalated to the team! Just to verify:

  • Can you please remind me of the platform on which you are playing the game (Steam, Win Store)?
  • Have you verified the integrity of the Enhanced Graphics Pack / reinstalled it at any point?
  • Are you able to play without the DLC for now?

Let me know and I’ll get this updated again, and thank you both!

Hi

platform Win Store. I performed several reinstallations of both the game and DLC. The game with setings DLC off, works fine. It does not start with DLC set to on.

1 Like

Hi @GMEvangelos,

-> Microsoft Store

-> Yes, but only after a repair, there is 1 successfull start, all following attempts will fail.

-> Yes, this is possible. There are some workarounds to even use the DLC (See initial post)

1 Like

@Pihaar1995, @NextMilda2000: Would you two mind sending me the following file:

  • The minidump file that is generated when the title encounters a crash. This file is located in the Local Install Directory for the game and is called "AoE2DE_s.mdmp"
  • A copy of your Dxdiag
  • The language of your game/DLC

If you can upload these files to a One Drive or Google Drive, we can get them passed along to our Test team so they can see what might be causing the issue.

Thank you for following up!

File AoE2DE_s.mdmp not found on my computer (c:\Program Files\WindowsApps\Microsoft.MSPhoenix_101.101.36906.0_x64__8wekyb3d8bbwe)

https://drive.google.com/open?id=1KLbnBDU6-SHmzYWd5DQpzHwVFdYr0kg3

1 Like

Hmm. Perhaps you can find something else for me:

  • Are you able to find the specific crash (after playing with the DLC) in your Windows Event Viewer?

If you are able to find the information there, please download a report and send it my way so I can get it passed along to the team! =)

Thank you!

Hi @GMEvangelos,

I have to confirm that, what NextMilda2000 already found out:
The minidump is not getting created.
There is also not a single event in the Eventviewer.
My DxDiag.txt (138,7 KB)

My Windows Display Language is German. The ingame Language is German too, but I crashes, too, when it is English.

I saw in the logs these two lines:

Constant Logging is OFF
Verbose Logging is OFF

Is it possible to turn this on? Perhaps this can help a little bit more.

Today I installed AOEIIDE on my laptop, and it behaves the same as on a desktop PC. The first start with DLC is OK, the next start crashes after displaying the initial image without recording an error. Primary language Czech, game language English. After switching WIN10 to English, the game runs normally. I uploaded DXdiag to the previous ones from the PC.