AoE2:DE Kills Network Adaptor

Game Version:

  • Build: 101.101.32708.0 0
  • Platform: MS Store

Issue:

When using AoE2:DE, the network adaptor in windows is disconnected after a few minutes of gameplay (sometimes even happens in the lobby).

When in game, the game freezes and then a message “You have been disconnected from network. Check your connection and try again.” is displayed in the game.

Checking back in Windows, the network adaptor is disabled/disconnected and never reconnects until the machine is rebooted.

Reproduction Steps:

  1. Play AoE2:DE for about 5 - 10 minutes.
  2. When the game freezes, return to Windows and view network adaptors
  3. You will notice that your network adaptor is disconnected and keeps trying to identify your network

THIS CANNOT BE REPRODUCED IN ANY OTHER GAME

I was able to capture this entire thing happening on video, see here: https://youtu.be/B7UvymPvtY0

9 Likes

Hi, can you try this?

Go to Device Manager, network adapters and find the ethernet one.

- right click for properties - advanced

Disable Energy efficient ethernet (and or green energy) and Wake on magic packet. (edit: also power saving mode)

source: https://www.dell.com/community/Inspiron/Ethernet-wired-connection-keeps-disconnecting/m-p/6218797#M41064

Will test it out now

image

image

I’m having the same issue, I made a post on it as well with some info from the event viewer. I did the same thing you asked and it didn’t fix it.

1 Like

It makes absolute sense that the game is killing the network adapter and this is the root cause of the problem, since when I play using my cellphone 4g connection I never have this issue.

Yep, exactly this. I noticed that it appears you and I have the same NIC. Check my post history for my bug post, you can see the event log entry that involves the NIC resetting. Something about the MS Store version of the game locks the NIC up and the driver forces a restart. The steam version does not have this problem.

yo i got the same, when i play it with my smartphone as hotspot i can play. what ethernetchip u got i got a Realtek® 8111GR on a Asus Z87-K Board what are ur specs?

I’ve got an ASUS ROG Formula VIII with Intel I219-V onboard Ethernet.

Just tried to have a go on the game today after the update (101.101.33059.0 0) and got booted when setting up the lobby.

Returned to Windows and noticed the up time has been reset on my network card again.

Untitled

Few seconds later… it’s stuck in a loop where I have to restart the machine again to get my connection back up.

If there’s no interest from a developer or someone from Microsoft on this thread over the next few days, I’m going to have to start looking into refunds as this game is currently NOT FIT FOR PURPOSE.

3 Likes

Guys, I found a fix(works for me at least)

All you need is: A cellphone, a usb cable to connect that cellphone to your PC and a wifi router…

Just disable your regular Ethernet adapter and use your cellphone as a hotspot via tethering, you dont need to use a 4g connection or whatever, you can use your regular ISP connection. Just remember, you need to connect your cellphone via cable to the PC, to bypass your ethernet adapter.

Has worked wonders for me in the last days, 0 disconnects on multiple games.

1 Like

Thanks Chacineiro,

I wouldn’t call that a fix though, that’s very much a work-around, having to use an entirely different network just to play the game!

Almost 2 weeks and the game is still unplayable :grimacing:

My statement is the same. If Microsoft doesn’t show any interest here I’m going to send a complaint to steam for a refund, no matter how low the cost of the game was.

I love the game, but not in its entirety when matchmaking isn’t even playable. I’ve had 6 games in row where one guy disconnected and the rest of his team resigned in response. It’s so sad :lying_face:

2 Likes

Switching to the steam version fixed it for me. Haven’t had a problem since.

A post was split to a new topic: Frequent Multiplayer Game Crashes

May I ask you fellow folks with this disconnect issue, do you have any of the following installed?

  • Franz
  • MSI Afterburner
  • RivaTuner Statistics Server
  • Razer Synapse
  • Razer Cortex

I’ve been doing some playing around as I’ve also been getting disconnects in the Halo Windows Store version, so it seems to be limited to WS games…

With all the Razer stuff turned off, it seems to have stopped the issue in Halo for me, however not had the chance to test AoE just yet.

Same problem for me.
I also noticed today, while launching a multiplayer game in Halo Reach, the ethernet adapter reset aswell. What is going on with the Xbox App games? I have no problem in any other games on Steam, Battlenet, Origin and so on o.O

Yeah, I have Reach too.

I’ve not had connection issues with it, however if I don’t exit all Razer apps, it stutters like crazy.

Posting here as well:

Hi everyone. I was just able to complete our first multiplayer game since launch (we tried about 15 times with failure every time). Here is what I did:

I have an Intel 1219-V NIC. I went to device manager, right-clicked, and updated the driver. I did that on both computers on our LAN. After that, our three player multiplayer game played about 1.5 hours to completion. Not sure if this will work with anyone else but it did for us.

Microsoft/Others any help for me?

Multiplayer PvAI games, I lose connection, network adapter loses internet connection (not sure if the adpater itself is being disabled/reset). It’s worth noting that when this happens, TeamSpeak also loses connection. I have to goto wifi connections, disconnect from network, then reconnect. Then it’s good, other than whatever game I was playing has since booted me. I receive similar error messages in AOE 2 DE as do the folks in this thread. “You have been disconnected from network. Check your connection and try again.”

Happens to me routinely, when playing online with friends. During a lan at my house, it happened also to a friend of mine (but not when he’s at his house). Leads me to think it could be related to my ISP, if the problem is network related. Or if it’s hardware related, would explain why it’s essentially only my laptop having issues.

Step 1: How can I isolate whether it’s hardware issues on my machine, software issues in the game, or network issues?

Question 2: If we host a multiplayer game on “Local LAN” is that avoiding servers altogether? We’ve tried that option as well and still have the same issues.

Specs are below.

Happens regularly on AOE II DE. I bought AOE II DE via Steam. Happened once or twice to me on CS Source, as well.

  • Drivers say they are up to date
  • Reset my internet router
  • Try to quickly save the game when I feel it crashing. Sometimes we can reload without issue, but someitmes upon reload the AI is messed up and allows its villagers to idle the remainder of the game

Windows 10 Pro laptop
8gb ram
Intel core iS-7200 CPU @ 2.50GHz
64 bit
image

1 Like