Editing key strings won't work

:arrow_forward: GAME INFORMATION

  • Build: sorry, I dont know how to see it and google isnt very helpful, the game exe says: 101.101.39515.0
  • Platform: Steam
  • Operating System: Windows 10
  • Gamertag: Stitch3s712
    I’m trying to make a mod in which I need to edit unit names, their descriptions, etc. In Advanced Genie Editor everything seemed to work fine after saving the key strings modded file. Names and cescriptions of the units were there. But when I started the game, and launched a match with my mod active, the strings didn’t work. The stats I changed of the units changed, but not the strings.

Here’s how to reproduce the issue:

  1. In User/Games/Age of Empires 2 DE/(some long number)/mods/local create a folder with the name of the mod you want to make (in this case something like test, idk), in that folder create a folder called resources, in that “en”, in that “strings”, and in that “key-value”. then, in “resources” create another path like this: _common/dat
  2. go to your AoE2 DE Steam folder (I think you should know how to do that), go to resources/en/strings/key-value. there are 2 text files there. you copy the one called “key-value-modded-strings-utf8.txt” into the key-value folder of the test mod folder you created before. then you go back to the steam game directory and go to resources/_common/dat. there you will find a file called “empires2_x2_p1.dat”. you copy that into the dat folder you created in your test mod folder.
  3. in the text file you just copied you create a new line like this:
    5083 “I dont know how to breathe”, then save the text file
  4. open advanced genie editor
  5. where it says “language x1 file location”, on the right of that you click “browse”, go to the folder where the text file is, click it once to select it, and click “open”
  6. where it says “compressed data set”, on the right of it click “browse”, go to the folder where the empires.dat file is, click on it once to select it and click open
  7. now click “open” on the advanced genie editor window.
  8. in advanced genie editor, in units search “archer”
  9. where it says “language file name” (above one of the green boxes with the number 5083 in it), under the green box it should now say “I dont know how to breathe”
  10. just close advanced genie editor and open the game
  11. start a single player match with the mod you created enabled
  12. create an archer and you should see that his name hasn’t changed

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a SCREENSHOT, VIDEO, DXDIAG .TXT FILE, or CRASH/GAME LOGS (if relevant).

Don’t edit with Windows notepad, it might change your encode into UTF-8-BOM, which can’t be loaded by DE. Try to edit with some other text editors, such as notepad++, vscode, ultraedit.

In addition, avoid opening the [Write language files *] option, otherwise AGE might output some unexpected results.
image

According to this reply data and text mod need to be separate. I have also seen some mod authors keep text mod separate.

2 Likes

yep they need to be separated, with it’s own folder path as a separate UI mod

3 Likes

Why cant they make it work non separate
Devs pls make modding enjoyable again as it was in HD

3 Likes

so how do I mark this as solved? is it marked as solved because i reacted to one reply as “Solution”? do i delete this topic? that would be stupid because others could search for a solution and not find my topic anymore so they need to create another thread.