Failed updating mod Error: Missing required fields

Hi,
I tried updating a mod through the in-game mod manager but got the message:
“Failed updating mod Error: Missing required fields”
and couldn’t find what causes that error.

Has anyone any experience with this and can give me information on what I am doing wrong?

Thank you very much in advance.

I am getting the same error, no clue what’s causing it

Try to submit your mod through official website Mods Create - Age of Empires

I am trying to update a mod, not create a new one

@DodoNotDoDo do you know what might be causing this issue?

If you can tell me the approximate date and time of a failed attempt I can check our logs to see if there’s further details.

You can upload, edit and delete your mod through this website [Main Menui → Mod->My Mod ->Edit] if the in-game mod manager is not working.

I tried to update right now, 17:13 GMT +2 or CET, mod name Improved Extended Tooltips. author Harooooo1. Mod id is 14335.

I had to enable extra logging, can you try one more time.

Okay I just tried it again

Got it, thanks. I think you’ve hit a bug that we just discovered where the game isn’t sending all the info it’s supposed to on an edit. Can you try changing the image for your mod? Even just renaming it and adding it back in so it thinks it’s a new one. I think that should work around the issue.

I was thinking it might be related to that. You see I deleted the thumbnail image from the local mod to save space, and also because I thought I dont need it anymore since I wasn’t planning to change it further. (in the past was able to update even without having thumbnail)

I’m gonna try it now by adding the pic again

Now i tried updating with adding a picture and got an entirely different error

image

Fun, looks like it failed further down our publishing pipeline. Try once more, if it fails again I’ll contact the other team where it’s failing.

1 Like

Tried. Again same issue of download url not available.

Ok, thanks for trying. I’ll check in with the other team and get back to you.

Looks like it may have been a temporary issue. I was able to re-publish and it went through. So in theory it should work for you now. If still not, I’ll get them to dig deeper.

It worked now. Thanks a lot!

1 Like

Glad that worked. I know they’re working on fixing the bug too so hopefully it won’t be an issue after the next update.