FRAME TIME BUG, micro lag, performance issue, video stutter

Post here, if the bug persists with the recent update 50292 build 101.101.50292. 6958215
edit: I still have it!

1 Like

If would also be helpful, if an Nvidia user can post some screenshots of their frametimes in post imp.
I am considering to switch to Nvidia, but need to know if I get rid of this lag. It makes me mad 24.


1 Like

Here you go:

1 Like

Does anyone of the developers in this forums want to acknowledge or deny the existence of this bug?
@DirefulLily9407 @ChristheCo @IkoKnight8151

Or am I seeing things?

1 Like

In this particular case I don’t want to pick on them, because it’s possibly really hard to find the issue which causes this bug.

@DeJake5261 do you have AMD graphics and also suffer from this bug?

1 Like

Yes I’ve fought these exact same issues for years, it’s terrible how devs overlook huge bugs on popular, mainstream hardware and software.

Responded to your v-sync post too, great job spreading the word! Your posts have been essential in helping me get to the bottom of this madness that the devs have left us.

Hi everyone,
for proper investigation, can you tell me if you have enabled vsync in settings and if it happens also after you restart a match?

vsync is disabled in game settings and driver.

What part is not understandable?
It also does not return to normal frame times if restarting a match.
Once the bad frame times occur, the only way I found to get to normal frame times again, is the change of display mode.
I guess the change of display mode will reinitialize/re call some of the rendering, which causes the trouble.

Hey everyone
Thanks for the report we are now tracking the issue and looking into what can be done.
Have a nice day!

1 Like

@ChristheCo did someone try to replicate the bug?

I have great news:
I reinstalled Win10 on 2 of my AMD graphics machines and the bug seems to be gone.
The Windows build was the one from the MediaCreationTool21H1.

Updating drivers/OS didn’t do anything previously, only reinstalling the OS.
Also I installed common additional software like Firefox and Discord already.
I fear that the bug will come back, so I will use a dedicated OS for Age of Empires 2 DE only.

Game build is 7486483
Win10 build is 19043
AMD build is 21.10.1
MSVCs builds are 9.0.30729.6161 x86+x64, 12.0.30501.0 x86+x64, 14.28.29913.0 x64, 14.10.25008.0 x84
DirectX is default from the Win build

1 Like

I have this issue majorly on my desktop with an AMD Radeon RX 6800. No issues on my nvidia laptop. I’ve tried just about everything you can try.

1 Like

It occurs regardless of Vsync, although it can help smooth it depending on the type of monitor used.

And yes if the issue occurs, it will stay regardless of restarting a match, or the PC.

That is good, but I agree that issues would likely return on a multi-purpose PC. Unfortunately keeping a sperate OS to be able to play the game without frame issues isn’t a worthwhile workaround for most

This issue continued for me on my Radeon RX580 until I bought and installed a NVIDIA graphics card. This is the only fix I found that worked.

The fixes UnfamousScout has discussed did work, but were temporary, for example would revert back to original problem after a PC restart.


I found a workaround for AMD Adrenaline users

Go to display in Adrenaline settings

Disable VPR (on by default settings)
(variable refresh rate technology)

Turning off VPR has solved my frame issue in single player and the 2v2 I just tested

  • also -

I got a response about this from SouFire at DeJake | AoEZone - The international Age Of Empires community

“RDNA cards work at very low frequencies if the game isn’t capable of stressing the gpu enough, aoe2 and most dx9 games run poorly on those cards with not a single fix from amd, the work around consist in disabling ULPS using msi afterburning and setting a manual frequency curve on amd’s software so the frequency starts above 1500 mhz, also in game you need to unlock the frame rate to try to stress more the gpu, but it only works in 1x1 and 2x2, on tgs the cpu bottlenecks it badly running low at 45fps so the stutter goes back due low stress on the gpu, you can try those 3 options to see if things get better. Sadly for aoe2 nvidia is just a better option.”


Disabling VRR/Freesync didn’t work, even after disabling it from my monitor.

Also, I’ve seen that setting a minimum frequency in the tuning tab only works when you are in the menu. As soon as you enter a game, the clock goes down to 300-500mhz, as if the gpu were going to sleep.

The workaround I found is enabling the metrics overlay, which greatly reduces stuttering, but doesn’t fix them completely, you can also make it almost invisible so it doesn’t take screen space

Running the performance test the game comes with I get 5-10% of GPU Usage and around 45 fps at 1080p. CPU is also barely used

What I am running:
Ryzen 5 3600
RX6600 with Adrenalin 22.11.2 drivers
Windows 10 Pro 64bit 21H2 19044.2486

1 Like

hello guys, I had the same problems and tested everything out, really everything until I found out that rolling back to amd adrenalin 22.5.1 fixed my issues and not only that you need to set your min frequency (MHz) in the amd software to the right as much as you can, in my case after I apply it it changes automatically to 2500, dont forget to apply! all my lags stutter whatever are gone, I had massive stutters in all games it was unplayable, destiny 2 was the worst experience ever :smiley:
some people say you need at least have it over 1500 MHz, I just let it completely to the right. Also you can disabling HPET just try it on and off what works better for you. if you want donwload msi afterburner and go to the settings and scroll down until you see amd compatibility properties and check disable ULPS, just try it and see what works best for you on or off. disable svm in the bios, try it off/on. in the bios you can also try to put your pcie 1 where you graphic card is set from auto to gen3/4 you need to try again what works best for you, set your xmp profile in your bios for your ddr4 module to gain the maximum performance out of your ddr4 module and update your bios to the latest, buy a displayport cable from a good brand!, dont use cheap ones! enable/disable hardware-accelerated gpu scheduling in windows, enable/disable sam in the bios and enable/disable fTPM/tmp/secureboot, update your monitor firmware if available, again try what works best for you on/off, but for me the roll back to 22.5.1 and the min frequency change was my savior. you also can try amd pro drivers or modded drivers like the amernimezone! I didnt tried it yet but I will, also when your game is crashing dont forget to set the min frequency again and apply it! it sets to default when amd adrenalin/game is crashing


my system: amd 5600 with the box cooler // radeon rx asrock phantom gaming 6800 // msi b550 gaming plus // 16gb ddr4 3600 patriot viper // psu coolermaster 700 watt power supply // Western Digital WD_BLACK SN850X NVMe SSD 1TB M.2 2280 // Samsung 860 Evo 500GB 2.5 - SSD

1 Like


You both use recent and common graphic cards 24.
Can you possibly make a screenshot with RivaTuner Statistics Server, so that there is proof that it’s still an issue!?
I luckily don’t have this anymore after I reinstalled Windows for the 2nd time. I have RX470.

1 Like

Hello guys, I tested the asrock 6800 phantom gaming by my friend, he had the same problems as I had. Funny is that he connected his amd asrock card 6900xt back in and had the same issues as me! Before he hasnt had any problems with his card. He did everything like windows fresh install and so on, nothing helped until he updated the newest amd driver and the newest amd chipset driver and after that he hadnt the stutters anymore, so he sad it was because of the amd driver/amd chipset driver. Funny is before that he had the amd driver and chipset driver but I assume you need completly deinstall all amd drivers/chipset drivers before you put a new amd card in your computer and install fresh all drivers again. I already sent the card back, so I couldnt test it. I wanted the new amd drivers to play witcher next gen and other games thats why I buyed the same card to test again if I have the same problem again, but not from asrock, now its powercolor and I had the same issues! Than I looked for amd chipset drivers in my computer and they showed me that I have them. I wanted to deinstall them and install them again, after I clicked in windows on deinstall amd chipset driver, amd chipset window appeared and said that I dont have any amd chipset drivers installed?! I know I installed them many times and deinstalled them so I dont know what happened there! I downloaded the amd chipset driver to see if they are really on my computer and bäm! I had a message that I dont have amd chipset driver installed and now they install me the amd chipset driver. After that I restarted my computer and bäm! everything works. Hope that helps, because I couldnt believe that this problem could be so common because cmon you pay alot of money for a card that should work at least without stutter the whole time. Its sad that I cant test it again with the asrock, but im sure the card would go perfect or maybe I really had faulty card here or faulty drivers what I believe, because now it works and by my friend too. So no need for a screenshot of rivatuner right? :smiley:


1 Like