FRAME TIME BUG, micro lag, performance issue, video stutter

I found a workaround for AMD Adrenaline users

Go to display in Adrenaline settings

Disable VPR (on by default settings)
(variable refresh rate technology)

Turning off VPR has solved my frame issue in single player and the 2v2 I just tested

  • also -

I got a response about this from SouFire at DeJake | AoEZone - The international Age Of Empires community

“RDNA cards work at very low frequencies if the game isn’t capable of stressing the gpu enough, aoe2 and most dx9 games run poorly on those cards with not a single fix from amd, the work around consist in disabling ULPS using msi afterburning and setting a manual frequency curve on amd’s software so the frequency starts above 1500 mhz, also in game you need to unlock the frame rate to try to stress more the gpu, but it only works in 1x1 and 2x2, on tgs the cpu bottlenecks it badly running low at 45fps so the stutter goes back due low stress on the gpu, you can try those 3 options to see if things get better. Sadly for aoe2 nvidia is just a better option.”


Disabling VRR/Freesync didn’t work, even after disabling it from my monitor.

Also, I’ve seen that setting a minimum frequency in the tuning tab only works when you are in the menu. As soon as you enter a game, the clock goes down to 300-500mhz, as if the gpu were going to sleep.

The workaround I found is enabling the metrics overlay, which greatly reduces stuttering, but doesn’t fix them completely, you can also make it almost invisible so it doesn’t take screen space

Running the performance test the game comes with I get 5-10% of GPU Usage and around 45 fps at 1080p. CPU is also barely used

What I am running:
Ryzen 5 3600
RX6600 with Adrenalin 22.11.2 drivers
Windows 10 Pro 64bit 21H2 19044.2486

1 Like

hello guys, I had the same problems and tested everything out, really everything until I found out that rolling back to amd adrenalin 22.5.1 fixed my issues and not only that you need to set your min frequency (MHz) in the amd software to the right as much as you can, in my case after I apply it it changes automatically to 2500, dont forget to apply! all my lags stutter whatever are gone, I had massive stutters in all games it was unplayable, destiny 2 was the worst experience ever :smiley:
some people say you need at least have it over 1500 MHz, I just let it completely to the right. Also you can disabling HPET just try it on and off what works better for you. if you want donwload msi afterburner and go to the settings and scroll down until you see amd compatibility properties and check disable ULPS, just try it and see what works best for you on or off. disable svm in the bios, try it off/on. in the bios you can also try to put your pcie 1 where you graphic card is set from auto to gen3/4 you need to try again what works best for you, set your xmp profile in your bios for your ddr4 module to gain the maximum performance out of your ddr4 module and update your bios to the latest, buy a displayport cable from a good brand!, dont use cheap ones! enable/disable hardware-accelerated gpu scheduling in windows, enable/disable sam in the bios and enable/disable fTPM/tmp/secureboot, update your monitor firmware if available, again try what works best for you on/off, but for me the roll back to 22.5.1 and the min frequency change was my savior. you also can try amd pro drivers or modded drivers like the amernimezone! I didnt tried it yet but I will, also when your game is crashing dont forget to set the min frequency again and apply it! it sets to default when amd adrenalin/game is crashing


my system: amd 5600 with the box cooler // radeon rx asrock phantom gaming 6800 // msi b550 gaming plus // 16gb ddr4 3600 patriot viper // psu coolermaster 700 watt power supply // Western Digital WD_BLACK SN850X NVMe SSD 1TB M.2 2280 // Samsung 860 Evo 500GB 2.5 - SSD

1 Like


You both use recent and common graphic cards 24.
Can you possibly make a screenshot with RivaTuner Statistics Server, so that there is proof that it’s still an issue!?
I luckily don’t have this anymore after I reinstalled Windows for the 2nd time. I have RX470.

1 Like

Hello guys, I tested the asrock 6800 phantom gaming by my friend, he had the same problems as I had. Funny is that he connected his amd asrock card 6900xt back in and had the same issues as me! Before he hasnt had any problems with his card. He did everything like windows fresh install and so on, nothing helped until he updated the newest amd driver and the newest amd chipset driver and after that he hadnt the stutters anymore, so he sad it was because of the amd driver/amd chipset driver. Funny is before that he had the amd driver and chipset driver but I assume you need completly deinstall all amd drivers/chipset drivers before you put a new amd card in your computer and install fresh all drivers again. I already sent the card back, so I couldnt test it. I wanted the new amd drivers to play witcher next gen and other games thats why I buyed the same card to test again if I have the same problem again, but not from asrock, now its powercolor and I had the same issues! Than I looked for amd chipset drivers in my computer and they showed me that I have them. I wanted to deinstall them and install them again, after I clicked in windows on deinstall amd chipset driver, amd chipset window appeared and said that I dont have any amd chipset drivers installed?! I know I installed them many times and deinstalled them so I dont know what happened there! I downloaded the amd chipset driver to see if they are really on my computer and bäm! I had a message that I dont have amd chipset driver installed and now they install me the amd chipset driver. After that I restarted my computer and bäm! everything works. Hope that helps, because I couldnt believe that this problem could be so common because cmon you pay alot of money for a card that should work at least without stutter the whole time. Its sad that I cant test it again with the asrock, but im sure the card would go perfect or maybe I really had faulty card here or faulty drivers what I believe, because now it works and by my friend too. So no need for a screenshot of rivatuner right? :smiley:


1 Like