Game crashing in Castle Age

:arrow_forward: GAME INFORMATION

:point_down: These details are CRITICAL; DO NOT skip them or your issue may not be reviewed.

  • GAME BUILD #: 66692
  • GAME PLATFORM: Steam
  • OPERATING SYSTEM: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:point_down: DESCRIBE THE ISSUE IN DETAIL (below). LIMIT TO ONE BUG PER THREAD.
For my past 6 games the game slows, freezes, and then crashes in late feudal age or shortly after reaching castle age. This has been happening since Thursday afternoon. I have tried reinstalling the game, disabling my mods, reducing the graphics settings, and redoing the performance test but the issue continues to persist.

:arrow_forward: FREQUENCY OF ISSUE

:point_down: How often does the issue occur? CHOSE ONE; DELETE THE REST!

  • 100% of the time / matches I play (ALWAYS)

:arrow_forward: REPRODUCTION STEPS

:point_down:Around the 13-18 minute mark the game slows to a crawl, freezes, and then crashes. This has happened on several different maps (arena, hidout, migration, 4-lakes) and now happens in EVERY game I play. *

Here’s the steps to reproduce the issue:

  1. Make around 25-30 units

:arrow_forward: EXPECTED RESULT

:point_down: What was SUPPOSED to happen if the bug you encountered were not present?
game is not supposed to slow/freeze/crash

:arrow_forward: IMAGE

:point_down: I cannot attach a photo as once the game freezes I can’t do anything until after the game crashes.*

:arrow_forward: GAME FILES (SAVE / RECORDING)

:point_down: this is my most recent game but you can look at any of my last 5 games.
AgeIIDE_Replay_178425422.aoe2record (1.0 MB)
*

Have the exact same problem, no error code, nothing, the game just closes itself. Ever since the last update I haven’t been able to play 2 games in a row

Hey guys,

I have exactly the same issue!

And I also found out why. Open your task manager during your game and you will see how your gpu memory will constantly running fuller and fuller till its completely full (see picture)
gpu-memory
. THEN it slows down and crashes (exactly as you also described it).

I’m in contact with the support, but right now its more like “did you try reinstall your game? - did you check your internet connection?”

I tried another thing with truning V-Synch off, but also didnt help. When I found a solution I let you know, but in my oppinion it must have to do something with the last update, because my game ran smoothly for half a year and now I having the same issue starting exactly at the same time as the guy who opened this thread.

The same thing is happing with my computer and the memory. And it has nothing to do with the internet as it also happens when I play the AI offline… the memory usage keeps increasing until the game dies. sometimes I get a “memory write” error from my system, other times it just dies w/o any error, but it ALWAYS dies.

1 Like

Thank you for testing everything through. Hopefully this will get communicated to the devs soon.

Hey @SodaPopinski9

Thanks for the report! I have made a ticket on this issue.

Is this issue happening only in multiplayer, or also in single player?

In order to get to the root of this asap, could you guys send to us the minidumps (.mdmp) that correspond to the day where this happened? Those could be found here:

“C:\Users\USER\Games\Age of Empires 2 DE\logs”

and have this format

“AoE2DESteam-58115-2022.01.19-15.05.33.mdmp”

just checked the folder and I dont heven have those files.

Just main.txt in the folders

Soda said also, that this happens vs the AI as well (so I assume we could say that is single player?)

This is happening in both multiplayer and single player. I only have 2 mdmp files which I am attaching.
AoE2DESteam-66692-2022.09.02-16.23.40.mdmp (416.5 KB)
AoE2DESteam-66692-2022.09.03-13.43.42.mdmp (405.7 KB)

1 Like

Game still crashing while playing single player (skirmish).

I think it will till there is an update coming out.
That’s why I stopped playing and waiting for a news regarding this topic … a pitty… really.

Thanks for the files! These were added to our tickets system for further investigation :slight_smile:

Just checked and the game is still crashing just as it was 2 weeks ago.

thx for checking.

I thought so as well … .because there was no update coming out … what a shame

Hi @SodaPopinski9
Could you send your latest logs? These files are on the same folder as the mdumps: C:\Users\USER\Games\Age of Empires 2 DE\logs

We are still investigating this issue.

Here you go.
SlowLog_2022.09.23-0000.15.txt (562 Bytes)

SP Replay v101.102.1156.0 #(66692) @2022.09.23 001517.aoe2record (2.2 MB)
2022.09.22-12.28.41.txt (10.5 KB)

let me know if there’s anything else you need.

2 Likes

@SodaPopinski9 thanks for the files! :slight_smile: