Game Freezes/Dropped Connection at Random Intervals During multiplayer Play

:arrow_forward: GAME INFORMATION

  • Build: Update 39284
  • Platform: Steam
  • Operating System: Windows 10

:arrow_forward: ISSUE

:question: Describe the problem in detail (below). Please limit to one issue per thread.

During Multiplayer matches, the game seems to be running fine then everything on screen stops. Music is still functional as are the menu options. Game play never returns back so have to quit that current match. During such a freeze if you hit pause after a bit it will return with "Lost connection to the server… Attempting reconnection. Of course the game never reconnects.

:arrow_forward: REPRODUCTION STEPS

:question: List the steps to reproduce the issue… Be descriptive!

Here’s how to reproduce the issue:

  1. Load up Multiplayer and play game.
  2. Happens intermittently, but almost on a every other game pattern.

In the Log Files, there is the following reports everytime the game freeze happens, obviously with different timestamps corresponding to the times it happens.
[rlink - error] 2020/07/22 08:18:42.720 (UTC) Session::SendData PeerID 1 is marked for death, skipping send

[rlink - error] 2020/07/22 08:18:42.721 (UTC) Session::SendData PeerID 1 is marked for death, skipping send

[rlink - error] 2020/07/22 08:20:22.334 (UTC) Unknown presenceID entered

[rlink - error] 2020/07/22 08:20:23.772 (UTC) Session::SendQueuedMessagesToRelay local peer is missing, not sending


I just played 3 games with a friend 2vs2. The first one what you describe happened to my friend. The second one was “fine” (not to mention the simple freeze thing). In the last one it happened to me, so… :worried:


The funny thing is the freeze/disconnects are random. Somtimes it happens 5 mins into the game, sometimes 40mins into the game. Its very annoying especially after being in a long fun game to just have it end due to this bug.


Happened to me yesterday. once time happened to me, and the other to my allied.

I’m pretty sure this is the same problem that happened in the previous patch. HOW IS THIS NOT FIXED YET DEVS?

Do problems like this happen in other multiplayer games? Does a large population of the community suffer from server issues like this? This does not happen in servers that are green for me, only yellow to red servers, and it is random. Like how in anyone’s right mind can this be OKAY? I can’t enjoy this freaking game because of terrible issues like this. Half the servers become a gamble of russian roulette where I don’t even know if I will be able to play the game or not. I literally just had the game lose connection and THAT’S WHY I AM HERE. I am so frustrated with this game and the developers for not making this a priority fix. Great job! the only thing you’ve updated since the last patch is to tell us the reason why our games are freezing is because of “lost connection to the server” But the issue is still here and it happens way too frequently for people to enjoy this game. Fix your effing game for effs sake.

If you’re in the process of fixing it then TELL US ABOUT IT acknowledge the ■■■■ problem and let us know you’re trying to figure out what is causing it. I saw no mention in the patch notes of any mention of this freezing bug. So how the ■■■■ do we even know that you guys are acknowledging that this is an issue?


Age of Empires II: DE Known Issues

The issue I am experiencing unfortunately has not been fixed by the hotfix today. I am still getting the issue where game just stops (it does not crash just gameplay ceases). I can still access menu and resign out of the game but I get the Lost connection to server message i showed above if i try to pause after awhile. Funny enough if the freeze happens and i resign immediately, if i try to search for multiplayer lobbies nothing returns back besides just Searching for games, as ive lost all connection to the game servers.

When the issue occurs, I still have internet connection as everything else is still working (such as discord, spotify, etc.). Just to make sure its not a connection issues, double checked to make sure proper ports have been forwarded, tried it through DMZ, and with firewalls off, to no avail.

It was functional until the patch on the 20th, thats when the issues occurred. I have it on Steam, i have uninstalled reinstalled, file verification and nothing has helped.

In my log files I noticed this error that started on the 20th (day of patch).
Setting up comm handler
[rlink - error] 2020/07/29 08:41:10.079 (UTC) PEM_read_bio_X509 failed…
the cacert.pem is in the certificates folder.
If any dev or anyone else can help me resolve this it be a big help

Logs: (The first log shows before patch when everything was functional)

This is the exact same issue me and my friends are experiencing, we play at least 10 (3v3 or 4v4) ranked games a week, every second game one of us drops connection after screen freezers, this needs to be fixed urgently, a lot of people are getting turned off the game, this game use to be for us the best multiplayer game ever, but now every game we are just waiting for one of us to drop because it happens so often, if this continues we are going to be forced to stop playing, and play a game that actually works, please please please fix this

I would be interested (as well as the devs more than likely if they are following this) if others having this issue are having similiar errors in their Log files as well. If we are having the same issues have similar errors then maybe we can help put the devs on the right path to fix this problem. Ive played AoE and Aoe2 for decades and love the game, hate that cant even have a few decent multiplayer games without people d/cing because of errors outside of their control.

For those wondering where their logs are they are Users\%UserProfile%\Games\Age of Empires 2 DE\Logs. Each log is given in a format of date-time.txt(time format is UTC so for central its a 5 hours difference)

1 Like

Hi All,

I believe this is due to a broken interface to wifi specific network drivers:

Me and my friend has been experiencing this in Australia when playing in Brazilian servers.
We’ve tried everything mentioned.

The only thing that has worked is EITHER:

  • Using a LAN cable
  • USB tethering through a phone (this tricks windows into thinking its a LAN connection)

Has anyone had disconnects using LAN?

Here are some logs with before and after using LAN (they both look equally bad)


I am on LAN and i have had issues still. Also ive seen the error you are talking about where connection is fully cut, and I don’t think that is the issue but i could be wrong. One thing I did notice though in your logs is the one thing I am seeing in common so far and that
Setting up comm handler
[rlink - error] 2020/08/01 08:07:30.582 (UTC) PEM_read_bio_X509 failed…
Which is meaning its failing to check our cacerts.pem in certifications. Because of this I wonder if there is some kinda authority check we are failing mid game n we are just kicked out of the server temporarliy since we are being kicked back as UnknownPresenceID . You can tell when in the logs you have been kicked out because it is always followed by this:
Sync is being logged
[rlink - error] 2020/08/01 09:55:48.300 (UTC) Unknown presenceID entered

[rlink - error] 2020/08/01 09:58:10.660 (UTC) Session::ProcessPeerMessages, Peer 2 already marked for death

[rlink - error] 2020/08/01 09:58:10.915 (UTC) Rejected PlayerReadyRequest, state is not MS_Setup

[rlink - error] 2020/08/01 09:58:11.196 (UTC) Rejected PlayerReadyRequest, state is not MS_Setup

[rlink - error] 2020/08/01 09:58:21.160 (UTC) Session::ProcessPeerMessages, Peer 3 already marked for death

[rlink - error] 2020/08/01 09:58:21.357 (UTC) Rejected PlayerReadyRequest, state is not MS_Setup

[rlink - error] 2020/08/01 09:58:21.437 (UTC) Rejecting packet type 0 that claims to come from ourself

[rlink - error] 2020/08/01 09:58:25.690 (UTC) SetVisible called while !IsConnected
If you have any logs Before the 20th i be curious to see if you still had said issues @StockierVoice71 or anyone else who has been having our problem

Thats a bummer :frowning: Thanks for the reply. Previous logs didnt have anything like that. I think the logging is new to the recent patches. (And no problems before 20th for me, but for my friend he has had this for months)

Edit* I think your assertion re PEM cert is wrong. Had plenty games with the same error and still was able to finish a game.

EDIT edit edit…
Here’s the difference between 20th and 21st:

I wonder if the devs has started to log more fidelity or is it something truly new post 20th…

I could be wrong here on the Pem thing but its the only real difference i see. My friend who also has this game and isnt havent any issues does not have the error but that could just be a coincidence.

The Unknown PresenceID is a constant error but thats not when it d/cs. the big one is always when i says Peer2 is marked for death. then the Player ready requests. The reason i think is the checks are periodic because like you, sometimes i can get a game or 2 in without issues and the checks land in between games.

Have you experience times when you are searching for a lobby inbetween games and it is stuck on Searching games for awhile. Reason this is the Errors i bolded above are happening or simliar errors.

I know alot of this is basically guess work on the pem thing being a possible cause, but the more information i guess the better for the devs and others who are having simliar issues to hopefully pin down this issue.

Hey Stockier, me and friends in same boat in Australia. I also came to same conclusion, tethering my phone via USB so far has solved it (I dont have a LAN cable long enough to test that option).

Only happens on Brazil server. I’d like to know everyone in this thread if they are experiencing this on Brazil server?

I have another network card too, using that, the game runs fine, even though it’s an older card and only 2.4Ghz…the card which causes the issue is brand new and not cheap…

@TIMMASH, @NightRaven5809, Thanks for the replies

Lets hope the devs can find the bugs.

Going by the timestamps, the errors you are referring to happens during matchmaking, then clears during game (for me anyways…)

Hi, all. First of all, this bug is super annoying. It is ruining the experience of playing multiplayer with my friends. The description of the issue is the same here, the UI freezes, I cannot move units, select anything, just the song keeps playing.

I am based in Europe and my 2 friends are based in Brazil.
Sometimes the server assigned is UK and sometimes is Brazil. When the server is UK, the crash happens to one of my brazilian friends. When the server is Brazil, the crash happens to me.

PS: Normally this doesn’t happen in 2v2, only 3v3
PS2: Happens on Ranked Team Random Maps and Lobby too
PS3: There is no log dump or windows event entry when this bug happens.

I’m having the same problem, I live in Colombia, so I guess it happens when I play on Brazil servers, I don’t know how to check the servers I´ve been playing on anyway, but is really annoying, 2 of my last 5 games today just crashed, after checking the logs I found them pretty similar of what others have posted here, pls devs fix that problem, is really sad and frustrating losing so many games because of that

My game freezes the most when playing DM ranked. Then it is absolutely horrible for me. Otherwise I get random freezes while waiting inside unranked lobby, just before a ranked match will start, randomly during normal RM ranked/unranked matches. The game freezes, but after 10-20 seconds it resumes with operation - typically I don’t DC.
The bug is super annoying, and I don’t have any network issues when I play War Thunder for example. I do play over WiFi, haven’t tried yet with cable. Its happenning to me after the last 2 updates and after the last one in July its really bad. Enough for me to decide to stop playing it until there is a new update hopefully fixing the issue :confused:

To state for the devs information, the servers I have been using have only been USWest and having the errors. @GMEvangelos Besides the stuff alot of us have placed on here, is there anything else we can provide to help the team fix this issue?

Not sure if its the same issue, but recently my game starts lagging, chugging along, whatever you want to call it. Sometimes it will freeze for up to 5 seconds and quickly speed up to catch up. It’s been like this for at least 5 days but really didnt notice it before. Haven’t changed anything on my pc.

I’ve noticed sometimes the yellow clock will flip on for a half second here and there, but 99.9% of the time it’s blue.