How to mod in-game strings?

Hey guys, how does one go about modding the in-game text?

I bought this game from Steam, and found a file called “key-value-modded-strings-utf8.txt”.
I tried copying some lines from “key-value-strings-ut8.txt” (Including the number at the start of the line), but it didn’t do anything.
Also, whenever I try to change a string inside the Genie Editor, it crashes… But if I change the string in “key-value-modded-strings-ut8.txt” it properly updates the string in the Genie Editor…

I’ve also read somewhere else that you can’t do a text mod inside a data mod. Is that correct?

1 Like

It may not be done exactly the same way on DE as on HD, but I think it should be pretty similar if not identical given how DE data mods work. Use https://steamcommunity.com/profiles/76561198261931107/myworkshopfiles/ the two LLC mod files as a guide, copying the file paths and formatting of the text mod and reverse engineer it. Thats how I learnt how to do it.
And yes, on HD at least you cant combine the two because one needs to be toggled on/off on launch and one is in the game settings. DE might be different (would be great if it was).
Finally, I suggest you start small, change one tiny thing and see if it works to check your file paths and formatting is right, then do your bulk changes.

Thanks,

I managed to get it to work last night. Whenever you toggle it on or off, I didn’t realize you had to restart the game in order for it to take effect lol.

Yup this is the name of the file you will be looking to mod your text strings in. You will need to make a mod folder first to put the text file in and it has to follow the same file path format as the game (i.e. /resources/en/strings/key-value/). Once you do that you can open the file to change existing strings or add new ones (Not recommended for beginners) using key-value-strings-utf8.txt as a reference.

This is because AGE was designed to work with the .dll language file type, but HD doesn’t use language.dll files. Instead they use the .txt files as mentioned above hence the crashing. Don’t worry too much about this one, as long as your key-value text files are linked to AGE right and you’re editing the modded-strings file it should be working fine.

Nope it’s still the same. Data mods and Text mods still need to stay separate (Hence why I had to make a data and a text mod separately)

How did you make it work? I’ve been making a data mod and now, creating the string mod separatly, it does not work properly, taking into account I created new units / techs. Can you give more insight on how you made it work? Thx

I didn’t make new units / techs, so I’m not sure there

At least for mine, once I enabled it in my mods list I had to restart the game for it to work. I also changed its priority (The text mod) to be right below the data mod.

I didn’t do anything else, and it is working for me and my friends. Make sure you have the folder structure correct though.

[MOD FOLDER]/resources/[LANGUAGE CODE]/strings/key-value/key-value-modded-strings-utf8.txt

(For example, since I only changed the English phrases for now, [MOD FOLDER]/resources/en/strings/key-value/key-value-modded-strings-utf8.txt)

You can view my text mod here if that would help: https://www.ageofempires.com/mods/details/1995

Might want to fix the link to your main mod in your text mod description.
Says https://www.ageofempires.com/1994/
Should say https://www.ageofempires.com/mods/details/1994/

Yeah, I’ve tried. Whenever I try to change it it says it failed, and then about 10% of the time it’ll actually go when it fails. Then it shows that I’ve updated it like 5 times even though none of them went through till the 1 time it did…

Just a little buggy right now

Oh, wow, fair enough, I have the same trouble, thought it was just my mod having that problem.
Sorry was kinda off topic.
I’ve submitted a bug report for the mod page not updating.

That’s okay that it’s off topic lol

Thanks for submitting a bug, hopefully it’s fixed soon. You can see the changelog on my mod for how many times I tried to updated it before it finally went through. When I check the Dev Tools on chrome, at first I noticed that something was being blocked, so I turned off my adblock. Then there was another log in the console about some resource returning null… which I’m guessing is what is causing it to fail to update.

this is what i’ve been trying already but it does not work, even when i just have a single string in there to change “Pikeman” to something else. I’ve confirmed the path and filename a ton of times already but everytime I open the game, the mod is not there, only if I go to “My Mods” and Import local mods. Same thing happens everytime I start the game, so I guess its not working properly?

(
using Age of Empires 2 DE[STEAMACCID]\mods\local\AOE2_GDE_strings\resources\en\strings\key-value\key-value-modded-strings-utf8.txt and inside the file:
26408 “some text here for the pikeman”
)

Define [MOD FOLDER]
There is a right one and a wrong one, and possibly a 3rd wrong one if you have both steam and xboxlive versions. The right one is in your c:\users folder.

Do you mean not listed under the “installed Mods” tab?

After you import local mods, do you go to the “Subscribed” tab and enable your mod? If not, try that.

Make sure after you enable it on the “Subscribed” tab that you restart the game.

Sorry for the confusion.
What happens is, after import local mods, the mod shows up in the installed mods tab, and even if enabled, it does not work. However, everytime I restart the game, it is NOT in the installed mods tab, making me import it again to make it show up. I did notice something different now, see image (still not working)


This happened just now when I started the game, it appeared but has a “!” possibly indicating something wrong is going on, but its the first time I saw this, before it just didn’t show up.

Hi there! I’ve been having problems with modded strings. Can anyone think of a reason why no text mod seems to work for me in AoE 2 DE? I’ve created some myself, and I have suscribed to at least five created by other people (including yours) and none seem to modify text in any way. Data mods and any other kind of mods work perfectly though.

Thanks!

I’m also struggling to make it work. I’ve tried using a mod folder and it’s not being recognised when i click import mods.