Unable to update MOD description images

Game Version:

  • Build (website)
  • Platform (Steam)

Issue:

I am trying to add an image to my Mod
https://www.ageofempires.com/mods/details/1987/
I get no errors when updating it, but the image never shows up.
It is a png file, I have also tried jpg. I have tried other images.

Also, it is impossible to edit a Mods main-image/thumbnail/_preview-icon.jpg/png
I’ve tried everything, in-game, website, different mods, only way to update it is make a new Mod.

Reproduction Steps:

  1. Upload a mod with 894 files and is over 200MB
  2. Add a description with over 900 lines of text
  3. Try to add an image
    (not sure if #1 and #2 are relevant)
2 Likes

Yeah, preview image stops working when you update - you can see that is happened to the small trees mod. Supposedly you can get it back by updating the mod on the website instead of ingame. Have not personally tried that though.

Nope, website does not change preview image. No errors, but no results.

Well something changed, the default preview image has disappeared from my mod.
As a result, now i can’t even edit the text for my mod because
a) an image is required
b) I can’t add an image. “Error submitting mod! Please verify your data and try again.”

2 Likes

Another change, my preview image has been restored, though I can only see it when editing, not when viewing regularly. But at least I can update my text now.
Still cannot add an image.

Aaaand it’s broken again. Preview image is gone again, so, since an image is required, and an image cannot be uploaded, the text cannot be changed.
This needs fixed.

@DodoNotDoDo Are you aware of this issue?

From my testing on the web site, things seem to be working as expected. A couple things to note:

  1. What ever image is first in the list of your images will be used as the thumbnail. I’ve tested and adding a new image, moving it to first position does update the thumbnail as expected.
  2. You likely won’t see the thumbnail change reflected immediately. We use caching, so the new thumbnail won’t show until either the cache has expired or you access the mod list via a previously uncached search result.

That said, I do see where when you tried to update your 894 Classic Taunts Pack mod, there was an error authenticating with XBL that caused the update to fail. I’ll check to see if we can return a more specific response and I’ve added extra logging to see if this is an issue somewhere in our pipeline or an issue with XBL itself.

Thanks for continuing to report the issues and apologies for the troubles getting your mods updated!

Really, I will try to find the posts I’ve seen about that feature not working. I have never been able to get it to. And I haven’t heard of anyone being able to. I have seen posts saying you can only change the preview by deleting your mod and starting over, and only if you upload it in game with the image on it’s first publish, updates will not change it. I’ll find some links. Several separate days I tried probably 8 different ways to try to update that image. Moving it up never actually commits. Editing it after you move it up shows it didn’t actually move up.
Last night the preview image disappeard and reappeared at least 4 times when I was only trying to edit the text. I just tried to upload an image, again, no errors, even gave it a couple minutes for whatever, refresh, no new image, edit, no new image. just trying to add this image so there’s nothing weird about it I don’t think.

In game may be different, this is just via the web site. I successfully updated yesterday so I know it works. If it’s not working for you, it would be helpful to know more specifics. Like what mod, what image, any other changes. Might help narrow down what’s causing the problem.

1 Like

Here are 6 screenshots in order of my actions. I did this at 10:45 EST, just now.

By 5 and 6 you can see nothing changed. I’ve been able to add images before to my other mods. Never been able to change the preview image after first publish. This Mod tho or this week I cannot even add an image.

Perfect, thanks for trying again. Got better logging this time. Turns out there’s a limit on the backend system for description length. Yours is apparently over the 10,000 character limit. If you can shorten that up, it should update for you. I’ll get our page updated to better report the limit as well for anyone else running into this.

1 Like

Thank you!
I was afraid of that, but it was like 6 items down on my troubleshooting theories.
Too bad though, that leaves me 11 characters each to describe 894 taunts.
Well, I’m clearly over the limit and it doesn’t cut off… wait, i recall trying once to remove my description, submit, add image, submit, and nothing, I’ll try again though.
But, I wonder since it doesn’t cut off if i can clear the description, add the image, then re-add the description. I’ll let you know.

Shortened the description
5 tries, still not able to upload an image.
One time it showed an error, something like, “unable to update, please verify data”, sorry I didn’t copy it. But, I changed nothing, just hit submit again, and it appeared to go through, but nothing actually changed.
Subsequent tries yielded nothing as well
Also questioning my sanity because I cannot see anyone else mentioning this issue, but my memory says I did see a few.

Ok it worked just now for the first time. Either you fixed something or it took time (15 minutes?) after i shortened the description

Can you try again now? I did see where the image update failed. I think it’s because when it was failing from the description length, you ended up with a couple partial records that were then causing problems with the image upload. I’ve cleared those so it should hopefully update now.

For your long description, you might try using like category headers to shorten up the text, so like:

Homer
1 taunt
2 taunt
3 taunt

Vs listing out Homer for each one. Same for the other repeat ones.

1 Like

Thank you so much!
Leave it to me find the limits, push them, and break the system.
I will avoid that limit then for sure.

1 Like

The main image/thumbnail updated too by moving it up, so this is no longer an issue if it ever was, I appear to have lost my mind somewhere in these forums. Really appreciate your help.

Appreciate you sticking with it. Helps us fix bugs / find potential pitfalls to avoid others having issues in the future.

1 Like

I will have to check if this also fixed my ability to update the files in the mod.


Updating will remove all old files and add the new files right? or will it leave the old files and just add the new ones on top of them.