How to move/mod the Tooltip (Help Box)

I know how to move the resources panel or mini map panel by modding certain json file
But I cannot find the json file that controlling the Tooltip (Help Box) panel
Anyone know about it?

In the options, disable it or adjust the size do not meet my need unfortunately

1 Like

Did you find a way to do it? i just need to move it a few pixels up, but i can’t find where the coordinates shows up on the json files

2 FeelsBadMan
This is very crucial about UI modding

■■■■ it’s the only thing that keeps bothering me, it interferes with my resource bar…if i found the way to move it i will let you know, thanks anyways

My solution was put it lower, you can refer to my mods:
https://www.ageofempires.com/mods/details/15220/
https://www.ageofempires.com/mods/details/15245/
but the 2nd one mod the command panel (bottom left) .png to make it not overlap

1 Like

Thanks so much, i wil try to do it that way

I once asked this in Promi’s twitch stream. He didn’t know, so he asked one of the other developers. The answer was: there is no way to move the tooltip panel at the moment.

I “solved” the problem by just replacing all the useless tooltips with “”. If the string is empty, no black panel is displayed.

1 Like

@SeverusMagnus Hi, how did you manage to do this? Is there something else I need to do other than copying the strings to the right document and deleting “…”?

Resources > Language > Strings > Key-Value

It’s probably explained in the right document but it goes over my head, I don’t have any modding experience.

As far as I know, “key-value-modded-strings-utf8.txt” is not working as intended at the moment. I just edited the values in “key-value-strings-utf8.txt”. But remember to create a backup of your work when you are done, because everytime the game is patched, this file will be overwritten!

1 Like

Thanks for your fast reply.

I have tried this yesterday multiple times, but each time I change anything about “key-value-strings-utf8.txt” the game crashes during the intro (or when I try to skip it).

Only thing I can say is that maybe it’s because I’m on windows 7.

Edit: Tried it on my win10 laptop, it does work there. Pfffff

That’s strange. I have Windows 7 as well, so this shouldn’t be the problem… Have you tried, if some mods like “improved tooltips” work for you?

1 Like

I subscribed to the “Improved Extended Tooltips” mod, put it on highest priority, restarted the game. I think you’re right pointing out that tooltip mods don’t work for me.

Tooltips extended not working

For example the knight tooltip remains the same.

Edit: Tried to install this mod on my win 10 laptop, it doesn’t work. It tried many times.

Edit: Same with “Logical Tooltips (Fast Turbo)”. On both computers it doesn’t work even after restarting game and pc.

Conclusions

  • Editing “key-value-strings-utf8.txt” works on my win 10 laptop but not on my win 7 laptop (Not sure if tied to operating system).
  • “Improved Extended Tooltips” & “Logical Tooltips (Fast Turbo)” mods don’t work on both laptops.

You could try to create a local mod with only the key-value-modded-strings-utf8.txt in it (and of course info.json). I’m not sure though, if that would make any difference to a subscribed mod like “Improved Extended Tooltips”.

1 Like

Turns out I needed to enable “Extended Tooltips” in settings for these mods to work :sweat_smile:

This did not fix my main problem.
I tried editing “key-value-strings-utf8.txt” on HD. Same result, the game doesn’t load.
I tried yesterday on a friends laptop with DE, there it worked without issues.

I’m quite nooby. I try to follow Ozhara’s old guide https://steamcommunity.com/sharedfiles/filedetails/?l=dutch&id=190070326

It took me some time to find the mods folder, since it is on my C drive while DE is on on D.
“C:\Users\name\Games\Age of Empires 2 DE\mods”

I managed to create a local mod, it appears in the in-game mod list.

However it does not actually override the altered tooltips ingame.
I simply copied “key-value-strings-utf8.txt” and removed “…” of certain strings.

Perhaps my folder structure is not correct. I’m not sure where my mistake lies.

Try using “key-value-modded-strings-utf8.txt” in your local mod folder instead of “key-value-strings-utf8.txt”, and add only the strings, that you want to change.

1 Like

Thank you. This is what it looks like now.

Unfortunately it still doesn’t work. I restarted my pc to be sure.

That looks alright. I have tested it myself, and it works for me. I have also downloaded Improved Extended Tooltips, and it seems there are no other files modded than key-value-modded-strings-utf8.txt.

One last thing you could try is copying the Improved Extended Tooltips into your “local” folder. If it works in the subscribed folder, but doesn’t work in the local, this might be a bug that you should report here in the forum. But if it does work, you can just change the file to disable the tooltips instead of extending them.

1 Like

I copied improved extended tooltips into my local mod, this works in game.
(I removed all other tooltip mods from my list)

However when I make a change to the file…

it doesn’t work anymore and reverts to DE’s default tooltips???

This doesn’t make much sense, like it doesn’t want me to change anything about this file. I’ll let it sit for a few days to think about before making a bug report.

Edit: Tried to do the same on my other laptop. Same result. The improved extended tooltips file works in my local mod, but when I make a change it reverts to the default DE tooltips.

This sounds like the game cannot read your edited files. It could be a problem with your text editing software. Make sure that it uses “utf-8 without BOM” coding or try a different software. I myself use notepad++.

1 Like

Yes that’s it! So kind of you to help me through the process. The mod is finished, now available in the mod manager. Thank you.

1 Like