Huge lag when panning camera

The game is running fine when camera is idle. But as soon as the camera pans the games FPS cuts in half


Im having the exact same issue.

I have a 3080
I7 8700k
Windows 11

I made sure nvidia drivers are up to date. I tried both borderless and full screen setting.

Heres a video:

The video doesnt capture it, but the way to temporarily fix it is to alt tab or press the windows key but the issue will just start again as soon as you try moving the camera around.

1 Like

This is a huge issue with the frame pacing. The Devs need to solve this asap.
I assume you guys have decent pcs and your FPS is well over 60.
Cap your FPS to 60 in game and this will resolve for the time being.

I can’t play with such choppy panning it’s hurting my eyes. The camera angle rectangle on minimap is always showing to be moving smooth like butter so the fps is constantly 60, but the in-game terrain appears to be scrolling at 10 fps whenever I pan the map. Slowing down panning speed to 25% makes it more obvious.

Few smooth scrolling frames, jump. Few smooth scrolling frames, jump. etc…

Ryzen 3900x
32 GB Ram
1080 Ti
Windows 10
4k resolution
Latest GPU drivers

Okay after some closer observation it appears obvious what is going on. You guys have an unbelievably silly bug. As I scroll the terrain, all of the trees are changing to different versions of model/orientation/type, including trees in center of the current view. Same thing for plants and other decors located on the ground. Objects are constantly changing model/texture/orientation as I scroll the terrain. Same objects that aren’t leaving the screen have changed more than 3-4 times as I pan an entire screen width/height.

It seems you have an algorithm of determining what kind of model get loaded depending on the location that the element is placed to automate variety, but for some reason that model is changing when the camera gets panned. Testing under highest quality settings and 4k resolution.

Slightly and quickly alternating pressing left right to pan the camera in small increments produces no choppiness, because the pan distance is too small to introduce model changes.

Maybe this is supposed to be LOD adjustment as the camera moves closer/away from the objects in question, but this is causing a huge issue that otherwise isn’t there if it just remained constant.

1 Like

As far as i know they know about this and this will be addresses. In digitalfoundry video it was mentioned.


They didn’t necessarily say much about addressing it, it sounded more like brushing it off as a non-issue, saying it was unavoidable, meanwhile no other RTS has this issue

1 Like

Thanks for the info. Well, they’ll have more incentive to address it knowing that people are taking notice the more it gets brought up. A basic core engine issue like this that has got to affect everyone more or less remaining unaddressed is a pretty obvious middle finger and frankly bad optics.

1 Like

For me, the only resolution was to put the Graphics settings to the absolute lowest.
It’s a shame because otherwise, the game runs just fine with 100-120 FPS until I pan the camera.
I know I don’t have the latest/greatest PC but it looks like it should be running fine.

16 GB
1060 3G
latest drivers

This is very true, my trees change orientation all the time when scrolling. Even happens in the cutscenes though. I wish there was a way to just force the high Res trees/ foliage regardless of distance as I would rather take the performance hit than see this annoying popping.
Devs please add the option to increase Lod distance

1 Like

Thanks for this tip, after I set the FPS to 60 it works fine but its a shame this bug exists as the game cant take advantage of my hardware.

I’m also having this issue and commenting just to contribute to the post getting noticed. While with powerful hardware you can lock your fps to 60 and avoid it by just overpowering it constantly, this just halves your hardware potential - Digital Foundry video is perfect demonstrating this as someone else said.

Atm playing at higher framerates (120-144-240hz) is basically impossible with proper frame pacing and consistensy, so forget having a smooth gameplay experience. For people that has now considered low-mid tier hardware like a gtx 970 (supposedlty recommended for medium settings btw), when you pan the camera you drop to the 30fps mark and while staying still you can easily have a smooth >60fps experience.

Adding to that, I don’t think high level competitive gameplay can be reached with such inconsistent performance, at least for lower tier hardware.


Couldn’t agree more. Glad the frame cap has helped while we wait for a fix

1 Like



Frame rate cap doesn’t prevent the issue, just makes it less noticeable if you throw away half your frames at all times instead of just when moving. If I put my settings up higher I get consistent 70 fps while the camera is still, but 35-40 when it is moving. If I limit to 60 fps, then I get 63 when the camera is still and 35-40 when it is moving. Not really an improvement. I have to lower my quality to get to 120+ fps when still, so that even when I move the camera I can keep steady at 60+. Then the issue will be masked if I set a 60 fps limit. But then I have to play with a low resolution, low framerate, low quality experience even though I could be playing at higher settings with good quality and decent framerate if not for this issue.

Here’s what my framerate graph looks like on decent settings and 60 fps limit (for some reason locks to 63 according to the game bar overlay). You can see I’m still dipping way down if I don’t lower my graphics a lot:

This is made even worse by the fact that there is another bug that makes all healthbars disappear if you set your gameplay resolution scale to anything other than 100%. So now I have to lower my entire screen resolution to get decent framerates which makes the UI ugly as well, and makes all my other windows get messed up every time I alt+tab.

1 Like

Well sh… I just created a new topic and didn’t see this one. I have frames limited via Nvidia’s Control Panel, not the in-game limiter. I’ll try switching that and see if that makes any difference.

it depends how powerful your GPU is, if 60 fps leaves about 40% utilisation free then panning doesnt cause the terrible frame times.
60 fps leaves the 40% headroom on my rig to completely eliminate this horrible issue. my workaround wont work for every system and is exactly that, a work around. They need to fix this as its an issue for everyone atm.

You need about 40% headroom for panning to be smooth. as a test cap at 30fps. although it wont look as smooth because … its 30fps it will stop all the juddering and skipping you get from the frame time issue.

Yeah, I suspected ~20% was not enough, but even if I go down in render scaling to 50 or less, I still get drops from 60fps. There’s something wrong with how the game engine handles panning right now because what should get taxed the most is the CPU as it should be the one recalculating what’s in the scene.

I think right now the engine has some issues with CPU under-utilization.

Don’t think it helps that the second you pan all the tree models start swapping :sweat_smile: