Huge lags after the new patch

It is fixed. Thank you!

1 Like

Still not fixed for me. Only getting like 3fps. Even in the start menu.

2 Likes

Seems like it’s a problem of your computer and not of the new patch, it works for most of the people.

1 Like

Thats your issue then, its working well for everyone else

Guys maybe don’t make blanket assumptions about “everyone” when there is lots of people still reporting issues.

Also it’s not my issue if the game works fluently on 36906 but not on the latest two. It’s clearly something broken in the update.

1 Like

The issue of this thread seems to be solved to me.

This issue, which also generates lag, is still not be fixed. So as long as i dont play those team games on the Brazilian server, it is fine for me.

Maybe this is also true for others that still experience lag.

The sluttering issue from the last week update is fixed. Work perfectly fine now

Not fixed for me. Last 3 games all crashed. First was a campaign (Into China) that crashed after 1 hour in game time, second one was a unranked UGC game, which lagged as ■■■■ for everyone and finally crashed after for me after ~20 mins, last game was a ranked TG that crashed after 10 minutes.
Blaming my PC would be easy, but sadly the game worked on previous versions, so that argument does not work, i guess?

Before hotfix I almost did not play, so maybe my experience is not completely correct, but Hotfix seems to have made it even worse (for me, not for rveryone as it looks)

1 Like

the game still bug even after the hotfix

This thread is about freezing every x amount of time. Crashes are different and you should report those together with system files if you want them them to know what happened.

The lagging in team games you talked about is likely someone with a potato pc thatc caused it. For another time, you can see it next to the names on the right bottom. When the icon is yellow or red someone is lagging the game because of a slow computer or internet

Can you describe what is bugging?

it lags in 1v1 too, some time i lose around 1 or 2 seconds of the game because the game is late on my opponent, so it’s accelerated to be in the same moment, but when it accelerates i can do any action. Sorry I’m not sure if my English is good enough to explain it well.

i was playing a lot before the hotpatch and it never happen before

I’m not sure if what you are describing is what is talked.about in this thread. I’ve played a hand full of team games since the hotfix and haven’t had any problems. If your issue isn’t like what it was before the patch, you might want to create a new bug report and explain what happens. (You can include a video which would make it a lot more clear)

Simply unplayable. Just another game which freezed and dropped because it couldnt connect to server midgame. Internet is fine (50mbps connection and no drops in ping).

I can confirm this is NOT true. had test some mock battles with a friend (both with good spec, 8 cores 4.5ghz, GPUs within last 2-3 years) in 1vs1 and at 120 vs 120 units army game lags like crazy. the worst part is, sometimes game return to normal after certain number of units die which is fine, but half the time it doesn’t return to normal and continue to lag even when all armies are dead with only 5 villagers and few buildings on each side for the 1vs1 we tested.

this is a serious problem here if game cannot recover it’ll lag even against AI randomly after sometimes 1-2 hrs of gaming. ridiculous.

1 Like

Hi,

after the new patch, I still have a huge lags. When I am starting the game, it writes to me:
“Age of Empires II: Definitive Edition minimum specification recommends at least 2GB of dedicated VRAM. This computer does not meet that requirement.” - My PC has a 6GB RAM.
The lags are terrible, I think that my FPS is about 3-5 frames per second - without joking. I have a good internet, before the new patch, I played the AOE 2 DE without any problems. In my opinion, there should be a rollback of this patch. This patch makes more harm than good.

Regards

Ondřej Gelnar

do you have iGPU? maybe somehow game is trying to use integrated graphics instead of dGPU for some reason.

Wasnt having any issues until the last patch, is there any word on when this will be hotfixed?

2 Likes

No, I dont have iGPU - I have a standard grafic card (NVIDIA GeForce GT640M LE with 1 GB own memory type DDR5 for processed data. I dont know, what I can do… Is there any chance to hotfix my problem?

Unfortunately still experiencing this issue more than ever… any help would be appreciated

1 Like