Indian campaign fully unlocked when completing "Pirates!" mission in first campaign

:arrow_forward: GAME INFORMATION

  • BUILD #: 100.12.1529.0
  • PLATFORM: Steam
  • OS: Windows 10

:arrow_forward: ISSUE EXPERIENCED

:question: DESCRIBE THE ISSUE IN DETAIL (below). Limit to ONE issue per thread.

When completing the “Pirates” mission, the next mission that starts is “Company Confrontation” in the Indian campaign. I now have the entire Indian campaign unlocked despite not playing it.

When I first attempted to complete “Pirates” the victory screen would not go away. The game was stuck in a soft freeze (audio still playing). I had to close the game in task manager. When I opened the game again and clicked continue from the main menu, the Indian campaign load screen showed, but the “Pirates” mission played. At this point it was WAD as far as I know, although the loading screen stuck out.

I completed the mission for a second time, at which point it went into “Company Confrontation”.

In addition to fixong “Pirates!”, there needs to be a way to reset individual campaign progress so I can relock the Indian campaign and keep my Blood Ice and Steel progress.

:arrow_forward: FREQUENCY OF ISSUE

:question: How often does the issue occur? CHOSE ONE; DELETE THE REST.

  • 50% of the time / matches I play (FREQUENTLY)

As far as I know, this could happen 100% of the time. I’m not going to spend another hour playing the same mission for a third time until this is confirmed fixed.

:arrow_forward: REPRODUCTION STEPS

:question: List the DETAILED STEPS we can take to reproduce the issue… Be descriptive!

Here’s the steps to reproduce the issue:

  1. Complete the “Pirates!” mission.

Alternatively:

  1. Play the “Pirates!” mission
  2. Force close the program when the victory notification comes up
  3. Click continue, and replay “Pirates!” to see if the next mission is “Company Confrontation”.

:arrow_forward: EXPECTED RESULT

:question: What was supposed to happen if the bug you encountered were not present?

The next mission in the Blood, Ice and Steel campaign would play. The Indian campaign would not have randomly unlocked completely.

:arrow_forward: ACTUAL RESULT

:question: What actually happened (what went wrong) because of the issue you’re reporting?

The incorrect mission “Company Confrontation” began after “Pirates!” and the full Indian campaign was unlocked despite not playing it.

:arrow_forward: GAME FILES

:question: Include a OneDrive or Google Drive link to a SAVE GAME or REPLAY FILE (.aoe2record) of the match where you encountered the issue.

I do not have a save from this mission.

:arrow_forward: IMAGE & ATTACHMENTS

:question: Attach a relevant PICTURE (.jpg, .png, .gif), VIDEO (.mp4, YouTube), DXDIAG FILE (.txt), or CRASH/GAME LOGS (.aoe2record, .txt) below.

Not much to see. Bood Ice and Steel and stuck on Pirates and the Indian Campaign is fully complete despite never playing it.

EDIT: I clicked on one of the Indian missions looking for a way to reset progress and saw this. The continue option for Blood Ice and Steel now leads to the first Indian mission. Seriously, if there is just a way to reset campaign progress so I can play this over the weekend…

4 Likes

It doesn’t seem to happen every time
I have finished the Pirates mission without problems, but maybe it only happens when it crashes!

I have the same problem, though for me the game does not soflock. For me it does happen everytime, soI’m currently unable to progress.

I can’t get past the mission “Pirates!”, from Act 1 of the base game story campaign, because when I complete it the game is convinced the next mission after that should be Company Confrontation, the last mission of the Act 3 from the Indian campaign.

I’ve even tried to complete the mission to see if the game would let me progress further, but after that it takes me to the credits screen and then back to the main menu. From there, if I hit Continue it takes me again to Company Confrontation, and now that I’ve completed it it also states in the campaign selection menu that I’ve completed 35% of the Asian Dynasties campaign (which I have not).

If I try to manually go into the Mission selection screen for the first act of the base game campaign, it shows the missions up to Pirates! unlocked, but not the next one after that, and again if I press the continue button on this screen it takes me to the last mission of Asian Dynasties.

1 Like

I managed to progress to the next mission In the interim I started and quit the first Indian campaign mission and also reinstalled the game. Not sure if either of these had any impact or was a fluke.

1 Like

I’ve found a workaround for continuing the campaign: use the cheat code “this ia too hard” to auto win and it will load the next scenario, but don’t play yet! For some reason doing this will reset your homecity to level 0, so you lose all your cards. To fix this, load the last scenario again and use the cheat “nova & orion” to win free xp (each time you hould be 2.5 levels aprox). Try to upgrade it to the level you had, and the cards you selected will be there. I don’t know if there is a faster way to do it but it worked for me. It should be fixed as soon as possible but until then, you could try it.

1 Like

Hi Maudfer,

It does many people seem to have such issues, you can try @EntombedCurve02 solution, but you could also try to validate the game files by doing this:

Step 1: Right-click Age of Empires III: Definitive Edition and select Properties.
image

Step 2: Go to the Local Files tab and Verify Integrity of Game Files.

If that doesn’t work, try to reinstall the game. I know that this sucks, especially if you don’t have fast internet. I hope I could help you and others.

Yours Truly,
MainAkkount

I have tried that method already but does not solve the problem :frowning:

For me, I think reinstalling solved the problem. It seems like a widespread and random enough problem that this does not work for everyone, and even if it does work it is less than optimal.

In addition to solving the ability to progress the campaign, is there a way to reset the Asian Dynasties campaign progress? Even reinstalling after deleting all installation folders maintains progress, so I’m guessing there is either a hidden folder somewhere or some cloud save process?

1 Like

Hi BrotherRay9277

I’m not sure if there is a way to fix the campaing progress, but I have experience with other games and they all keep those progress numbers in a config file, I’ll try and figure out where they are and I’ll share my progress and possible solution if I find one!

Yours Truly,
MainAkkount

Hi @BrotherRay9277, @Maudfer & @EntombedCurve02,

I come to you with great news, I may have found a way to reset your Asian Dynasties progress, however, it does require some work, but if you are up to it, just follow these steps:

Step 1: Open file explorer and go to this address: C:\Users\MainAcount\Games\Age of Empires 3 DE\76561198057049427\Users

Step 2: Open NewProfile with Notepad

Step 3: Press CTRL + F to open the Find function and search for Campaign

Step 4: Find the CampaignSelected, CampaignProgress & CampaignFarthest lines and change their numbers to 0. Make sure to remember their original numbers Write these down, cause we will need them later!

It will look like this:
image

Step 5: Boot the game to see if all your progress is removed(Your Blood, Ice and Steel will also be removed, but we will fix that afterwards):


And:

We’ll fix this down below:

Step 6: Close the game

Step 7: Go back to New Profile and the Campaign lines:

Step 8: Change the numbers back to their original values:
For me that is 4-8-8, but for you these might be different
image

Step 9: Boot the game again to check if it worked:


And:

Blood, Ice and Steel is fixed:

Conclusion:
Alright, don’t ask me how this works, but I only know that it does work.
Somehow resetting the entire progress, whilst later changing the values back to their original still forces the game to forget the progress in the Asian Dynasties Campaigns.

I hope you could follow my steps and they are giving you the same results!

Yours Truly,
MainAkkount

3 Likes

Thank you so much! Hopefully devs will see this and figure out a fix

1 Like

This looks promising. I can try it when I get home. Will this disable achievements or change checksum or something similar?

1 Like

So this worked for me RE the campaign progress, but then if I load my game and finish the map I get taken back to the same issue - 32% into the asian campaign

1 Like

Hi fniqxz,

Yeah, it wasn’t a fix for the bug itself, but it is the way to at least get rid of the unwanted progress, would someone figure out how to fix it permenantely!

I still have issues with this.
Can you please share which line I need to change because there are 4 same areas with the same content?

1 Like

Hi LumpierHaddock1,

Of course, I can share the lines:
image
These three lines should be changes to 0, remember to write down the original values, cause you need to revert the values back to those!

Hope I could help you! Remember this isn’t a fix for the Pirates mission bug, but only so you can get rid of the Asian Dynasties progress.

Yours Truly,
MainAkkount

Thanks!
However, I’ve found out that I cannot progress after the Pirates mission. And I don’t know what to do. It’s a shame really. If anyone has an answer please let me know.

1 Like

Hi LumpierHaddock1,

So, many people have also complained about losing all their progress when using the cheat: “this is too hard”, this cheat will win you the game instantly.

However I may have found a way to get around this, I’ll update you as soon as I found something.
I’ll make a tutorial, just like above! :smiley:

Yours Truly,
MainAkkount

Cheers!
Looking forward to it!

1 Like

Hi @LumpierHaddock1, @Moteados, @EntombedCurve02 & @BrotherRay9277

I’ve come to you with another tutorial, this one is hopefully going to fix the Pirates mission for you, without losing your Home City progress or any other progress.

A slight heads-up before we go to the tutorial, I currently do not experience this bug, so I haven’t been able to test if it worked. So when you guys try it, we will know if this is the current fix for the issue. So don’t get your hopes up, but I think it will work.

Step 1: Open explorer and navigate to: C:\Program Files (x86)\Steam\steamapps\common\AoE3DE\Game\Campaign\Blood Ice Steel

Step 2: Copy all these files to a save location for backup:


Example
image
Result:

You will need these later to restore the levels and home city.

Step 3: Boot Age of Empires 3:DE and start the Pirates! mission

Step 4: Press Enter on your keyboard to open the chat:

Step 5: Enter the cheat code This is too hard


Result:

As you can see for me it just moves to the next mission, however for you it may jump to one of the Asian Dynasty Acts.

Step 6: Close the game:(You’ll either have to sit through the intro cut scene, or forcefully close the game)

Step 7: Replace the files in the folder with the ones you backed up at Step 2


When it says: “Replace or Skip Files” you say Replace the files.
image

Step 8: You will probebly have to redo the earlier tutorial in order to get rid of the unwanted progress in the Asian Dynasties Acts.

Step 9: Hopefully enjoy the game without any problems again!

Conclusion:
I hope this fixes the issue, atm the moment it’s the best shot I have, if it doesn’t work I’ll look futher into it tomorrow.

Yours Truly,
MainAkkount

1 Like