Known Issue: Performance Issues with Low FPS

I have i5-8250U, MX150, 8 GB RAM and I don’t use UHD.
In benchmark I get 971 with Firefox/Chrome open and 986 when closed.
Much better for me than in beta where I got below 900.

My score in the benchmark is 1248, i7-6700k and GTX 1080. With UHD it crashes.

1 Like

They are tracking this.
So, I guess this is the end of the topic.

You are running the game on an entry level gaming laptop, there is no way you could run the UHD Pack playably in my opinion. I think it’s intended for resolutions higher than 1080p as well, even if hardware was not an issue.

Also, the recommended specs represent a decent set up for playing games these days, not the ideal specs. Recommended used to be ideal during the previous decade, but it appears most games can push hardware to the limits today and ideal specs are never mentioned anymore, cause that would have been high end and therefore a marketing disaster for developers. I personally hate this, since it’s causing so much confusion even now, but oh well.

So, 130 fps is actually decent and in line with their recommended settings. That being said, optimization in AoE2, although improved in the Definitive Edition, is still miles behind modern titles. I assume this must be the engine’s fault, since they’re still using the old engine, so there’s only so much they can do sadly :slightly_frowning_face:

Scoring 930 points with a Ryzen 2600 at 4.2 GHz and a 1080 Ti. Runs in the low teens for FPS WTF how did the game get released it was not ready its basically unusable in this state.

Same here, the game freezes for a bit and then in middle of a match, gets closed, without giving any error notice, just back to desktop, like trRoach, hope it gets fixed soon

1 Like

Ehm nope? The game updated just 2 days ago, and even before that there have been small patches on the 14th and the 16th as well. I wouldn’t complain since the game’s been out for just a week give or take.


I have a 1080p monitor, consider that.

And yeah, the hardware isn’t the best, but it’s not an entry-level gaming laptop.

It is, the engine is facing things bigger than it’s limitations.

But still, that shouldn’t be the reason to prevent any optimization (I don’t intend to say they are preventing it)

1 Like

Hey, i have a decent PC, but games runs at benchmarktest and Multiplayer 1v1 from beginning at around 30 FPS. My benchmark is at 1150.
I put all Graphics on low. I have 2k Monitor but i tried with 1920x1080 resolution and it didn’t help.

When starting a campagne, i have over 100FPS.

My PC:
Processor: AMD Ryzen 5 2600 Six-Core Processor (6 CPUs), ~3.4GHz
Memory: 16384MB RAM
Available OS Memory: 16332MB RAM
Page File: 4457MB used, 28259MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: Unknown
DxDiag Version: 10.00.18362.0387 64bit Unicode

Card name: NVIDIA GeForce RTX 2060
Manufacturer: NVIDIA
Chip type: GeForce RTX 2060
DAC type: Integrated RAMDAC
Device Type: Full Device (POST)
Device Key: Enum\PCI\VEN_10DE&DEV_1F08&SUBSYS_1F0810DE&REV_A1
Device Status: 0180200A
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 14146 MB
Dedicated Memory: 5980 MB
Shared Memory: 8166 MB
Current Mode: 2560 x 1440 (32 bit) (144Hz)
HDR Support: Not Supported
Display Topology: Internal
Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
Color Primaries: Red(0.639648,0.330078), Green(0.299805,0.599609), Blue(0.150391,0.059570), White Point(0.312500,0.329102)
Display Luminance: Min Luminance = 0.500000, Max Luminance = 270.000000, MaxFullFrameLuminance = 270.000000
Monitor Name: Generic PnP Monitor
Monitor Model: XG2703-GS
Monitor Id: VSCBA32
Native Mode: 2560 x 1440§ (59.951Hz)

Any Ideas? Or is is the game?

happening in ryzen 7 2600 / GTX 1060
Scoring 1100+ points and stuttering and freezing in multiplayer, (no network issues)

This latest patch I have been having stuttery performance, online and in single player, when last patch it was smooth as butter. Windows G performance monitor shows that I am getting around 90fps at the start of the game (which is the same as last patch) however it feels like only 20fps are being displayed. Scrolling the screen around this is especially notable.

1 Like

trying to run age 2 an it is very slow frame rate I’m not tech savvy like most but know I’m on a pc that runs any other games I play including age 1 empire earth 2 and 3 which has more in game units and stuff running with no issues at all … not complaining as running it off the xbox1 app system and only just released this way just letting you guys know there is issues look forward to the fixed game as was my first pc strategy game I played . thanks guys

PC meets requirements --> poor performance / unplayable

Even with the lowest settings, the performance is too weak. Normally the game would have to run well.

My system (from dxdiag):

Operating System: Windows 10 Pro 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
Language: English (Regional Setting: English)
System Manufacturer: MSI, System Model: MS-7798
Processor: Intel® Core™ i3-2120 CPU @ 3.30GHz (4 CPUs), ~3.3GHz
Memory: 8192MB RAM
DirectX Version: DirectX 12
DxDiag Version: 10.00.18362.0387 64bit Unicode
AMD Radeon HD 6950 with 2 GB GDDR5 VRAM

AoE HD with the newest patch (Update 33164)

My settings in AoE 2 DE: (lowest possible)

Benchmark result:

Things, I have tried:
*Windows 10 Game Mode on
*Added under Graphics Settings system AoE2DE_s.exe with High Performance (then Benchmark Score is ~795)
*Steam Launch Options added -USEALLAVAILABLECORES -high
*newest driver (AMD Catalyst 15.201.1151.1008-151104a-296217E)

I can write more information, if you want.

What is the reason why my performance is poor? I just wanted to play campaign or multiplayer…but the performance is not good enough.

1 Like

Same issue with Intel Core i7 2600k, 8GB RAM and AMD HD 6950 2GB graphic.

Maybe 2 FPS. Everything updated to the latest Version…

1 Like

Please try using MSI Afterburner (For Nvidia) and Radeon™ Overlay (For ATI) to check what is maxed out. Also you can check via Windows Task Manager the CPU and RAM usage. It’s known that the game uses a lot of RAM so 8GB might not be enough. The specified requirements, 4GB, are not realistic. In case you have a RAM issue try to allocate more virtual memory (page file).

Performance issues fixed by the Major Update are finally back since the latest update of 32mb ( low FPS and stuttering )
Around 50fps with V-sync enabled and disabled.
I am not the only one having the issue. I have a very good PC.
There are other people complaining on Steam AOE2 forums.
It’s litterally unplayable. I was happy that everything was fixed with the major update… :confused:


Exactly I have the same thing. Something broke with this small update 34223 The game is no longer smooth and it was fixed with the last big update. Then the game was smooth and now it is broken



1 Like

Same here.

Gained some FPS with 34055 and lost them with 34223.


I didn’t notice anything about stuttering in the known issues so I just wanted to post here that I’m still getting massive stuttering after the latest update despite high FPS.

Also, it seems that neither V-Sync nor G-Sync are working correctly. I get screen tearing and uneven frame pacing when I use either of them independently. Having them both enabled simultaneously (which is against best practices for G-Sync users) seems to mitigate the issue somewhat (but not completely resolve it).

Please see my more recent posts in another thread, starting here. I actually recorded my monitor with the 240 FPS camera on my iPhone X to demonstrate the issues with G-Sync and V-Sync.