List of unfixed bugs

Is there a chance to fix this bug? Have same problem with game installed through Xbox app on Windows 11.

Seems that achievement Can I be Frank with You doesn’t work.

Not sure if I’m doing this right, I signed up just to report this issue with the Gurjaras. It does not allow the elite Shrivashma unit to be upgraded.
If I start in post imperial, it’s there. But on XBox, it does NOT allow me to upgrade that unit. Kinda killing the use of the Civ I paid for on the DLC.

I recently encountered a problem with one of the new Inda Campaigns (Dravidians)
The first maps morale function is bugged. Supposed to add damage to units when using heroes. Mine makes all of their damage 1. Light cavalry reads 7-6 and the heroes are 19-18 and 15-14 after the first damage upgrade and stay that way into further upgrades.
Please redirect me to where to actually post bugs if this isn’t it.

This isn’t quite where to post it, normally people make a new thread for bugs they want to report. I wouldn’t bother though if I were you, the devs are well aware of this issue by now, it’s breaking any use of the modify attribute trigger, where instead of adding values, it’s setting them. In this scenario for example, it’s meant to add +1 attack. Instead, it’s setting the attack to 1 for everything, hence the attack values.

Yeah, this has been reported on this forum several times: here and here and here among many others; it’s also been noted on the Steam forums.

You know, I really wouldn’t mind having an update on if it’s going to be sorted soon, since it’s really cramping my playthrough; I check for a new patch almost daily.

Is anyone else having the issue listed with the Gurjaras? I’ve uninstalled and reinstalled a few times now.

im curious, whens the last time the dev look at this pinned thread?

1 Like

this list got nothing to do with devs, and tbh I am not even sure why they decided to have it pinned.

Can I get a yay for this not being fixed still?


What’s the point in having an official forum with a bug list if the devs ignore it?

They spend time changing the civs around, making more bugs, and still dont fix all the previous bugs, its a joke.

This latest update, If you ring the bell quick (as I always have) to force drop off, it literally idles your whole eco, its basically GG if you ring the bell, especially if you ring it to click imp…


Big Problem with [Age of Empires II: Definitive Edition - Update 81058]

Since the new Update 81058 was installed automatically by Steam the KI-Mode for original “CD-Version” isn’t working properly anymore.

When a KI-CD-Version-Opponent changes his diplomatical status to you the game freezes nearly everytime and cannot be restored properly.

As well, sometimes working menus of citizens start to switch automatically, so that you cannot build new buildings anymore because menus are jumping by themselves. (This is just happening sometimes, the diplomatic issue appears everytime)

I’m one of the early AOE-Fans since 1997 (Part I) and I always loved to play against CD-Version-KI. Now the game is not working as I want it to anymore.

Can I remove the 81058-Update somehow … ?

1 Like

yeah, my campaigns have just been crashing all together after a few minutes of gameplay, bout to ask for a refund

On the PC version, ungarrisoned villagers have been having some strange behaviors recently. A shepherd might just kill another herdable when you garrison and ungarrison them for faster food income. A hunter will be idle for a few seconds before shooting if you garrison them after bringing the boar next to your TC. A builder will not build a building if they stand on the foundation instead of just walking away before building.

There might be more, but these are the most common strange behaviors I’ve observed. I believe it’s some kind of bug and not “intended” feature.


Add this bug to the list please so it gets the devs attention:
User Interface, Lobby, Spectated Games:

Banned maps do not appear in team game

This is the most visible bug for anyone who plays ranked team games and it happens 100% of the time. It hasn’t been fixed for almost 2 years now.

Other problems and bugs:

  • Rematch button is useless because it waits for too long until all players vote yes and sometimes it doesn’t work properly even if all players vote yes. Instead change it so that it creates a new lobby and when a player click on rematch he joins it immediately.
  • Changing Hide civ option in lobby options without the need to recreate a new lobby.

Hotkey suggestions:

  • Add hotkey/Button to make spawned units spawn garrisoned inside their spawning building.
1 Like

So I have a bug with the UI on Xbox when using the mouse and keyboard, on XBOX.

When a villager is selected - and I point the cursor over one of the boxes to select build - OR
When a building is select - and I hover over technology to try activate it - OR
When a military building is selected - and I try to train units

The mouse clicks through the UI game interface buttons selecting whatever is behind the button like trees, units, building etc as well as the button itself.

It has caused multiple issues, and it depend what you have selected in the first case… for example if a worker is select and I click build a house, the worker will walk instantly towards the position on the map behind the build a house button on the Ui, it will also place the building and attempt to build it before you actually choose where you want to put it.

It trees or water are behind the UI button, it will prevent the villager from taking a random walk and from building when the bug kicks in.

A different example is when you have a building selected and you try click on a technology or train a unit by click on THE UI BUTTON . I can make it work by holding shift or using a hotkey (spacebar) to train units, but it depends where the UI button is positioned on the map and what’s actually selected, and if you can walk/build or set rally points their.

I have found with different buildings and units / villagers mainly - that you can preform multiple tasks at once when you mean only to do one of them, like you click to build and the villager walks instead. You click train unit or start technology and it sets a new rally point when you click the unit or technology.

Its clicking through the actually UI buttons on Xbox with the mouse and keyboard…

Originally I didn’t have this problem with the default settings, (being zoomed in a lo### ## only began occurring when I tried to fit everything into the screen properly, once I made all the icon smaller and the UI easier to see, it began clicking through and on buttons at the same time.

Additional information - I had this ‘‘other bug’’ yellow-box that seemed fixed on enemy buildings at one point (that moved and changed shape as I clicked) after playing with the pack and unpack hotkeys with Trebs or trying to garrison units with hotkeys insert and backspace whilst this bug was active… I was playing with shift too and trying to build walls and gate with a villager but I’m not sure what triggered it… was force firing the Trebs also… anyway actually now I think about it I played with the IU settings and the yellow box vanished… I think… however I did it before i reset everything and it never came back once I changed the set up to the one I’ve been sharing.

I set quick train commands to spacebar on most military buildings and town centres and also double combine the spacebar to be the first technology for each building (I decided to ditch technology hotkeys after this, it only really works with resource or tech buildings)

but I don’t need the tech shortcut because their is a work around the UI clicking through button bug IF you have building/unit shortcuts to even get that far in the game with it. I just hover over water or plan land and hold shift whilst clicking on technology, not ideal but it works.

If anyone else has the problem here’s what I do…

Q is HQ - selects all military buildings (and selects military buildings if you have a worker selected too) -

E is economical buildings

W is castle
R is Donjon (I know, but it looks like a mini castle, and its beside the big castle button and wall button - almost) so there is your perimeter - houses and gates are G and H just under the T for Towers.

T is Towers (and the next button beside T - Y is bombardment tower)
A is archery
S is stable
D is dock
Z is workshop
X is barracks
T is towers
R is the other castle looking building
TAB / Q is heavy or light wall (when builder is selected)

Note the castle - walls - fancy donjon (R) thing and other perimeter structures and tower are in the top row beside the castle button W whilst all the smaller military buildings are underneath.

Insert / Backspace for Garrison / Ungarrison - Zoom In & Out / Page up/down - Game Speed Up/Down

Fullstop button to Cancel (go back a UI page) & for the Stop what your doing command.

Plus & Minus button to Pack / Unpack

@ of Eden is BUILD farm, left and right buttons from the @ are Mine and Lumber jack,
you can use the SAME BUTTONS TO SELL THE CORRESPONDING RESOURCE if you put them in the right order when the MARKET is selected, so the buttons directly above @ buy the resource rather than sell or build it - the order is wood / food / stone.

R still works for repair since no building type is selected,

C for church/monastery V for university B for blacksmith

K L Knights / Lancers

Siege like units on Z, hand cannoneers ect

calvary / archer calvary / BATTLE elephants / archer elephants C V B N

Aggressive / Stand Ground / Defence - A S D - works over the buildings Archery A / Stable S / Dock D since the military unit is selected rather than the builder, buildings or the game itself (when you have nothing selected, it changes what the button does)

NO Attack - (for siege units mainly) with Z, Z which also SELECTS the siege building itself and IF a siege / Treb / or similar unit (like catapult or cannoneer IS SELECTED it can also built with Z ) - BASICALLY units and buildings that do explosive stuff on Z along with No ATTACK STANCE ON Z TOO . It works with all three of them because you have different things selected when you use Z. Spacebar is FORCEFIRE.

CNTR zero (0) to ungroup

F is farm - and button beside F for fish farm… ect

Home button for town centre - spacebar to quick train whatever you selected for that building hotkey fast unit (it works with shift too)… I like to put the lightest units or the elite units on space bar with each military building then use WASDZX for everything else that’s not already listed.

Alt space bar selects idle villagers

M for More Buildings (or hit W to go back a page, weird but it works sometimes)… QWE when playing with them will cycle between economical and military builds… not sure how but it works and its still cool / feels nice with the UI, but if that the doesn’t work, use M (more buildings) or (cancel - full stop)

You can also double build M so it selects all the active or idle military units when use on its own or combined with Shift/Alt OR Control

I like using shift to select and alt for alternative commands

I only use Control with Q which selects all military buildings OR CTRL M for all military units, and M for units on screen. M also works for more buildings. Or M too build the wonder (which can be switched with the castle on W, if preferred).

sorry for such a long post, but yes that what I’ve been force to use due to that bug, hope this helps (salute) o7

Turned out so all walls and big and small castle type buildings and towers end up on the top row (with the exception G as gate and the button next to G as bigger Gate) - I’d love a lock all gates function ?

@ on the second row with all other resource buildings left and right of it.

CVB church uni-versity and black smith is the tech buttons all on the bottom row…

P.S… where is the hotkey to lock all gates in this game ! , and thank so much for bringing it to Xbox!! <3 <3

P.S again, forgot to say M is also set to build the wonder (I look at it upside down), I could of used W, but that was on the castle. they can be switched around. M is also selecting all idle military units on screen on its own and able to combine with shift alt or control for selecting across the whole map too. I like using M and CNTR M - military units on screen / across MAP.

You may need to switch between DOUBLE/SINGLE CLICK MOUSE SETTINGS to set rally points properly… the set up allows you to use the zoomed out features for the UI and everything without you needing to worry about clicking on broken UI buttons, so much…

The only thing is you might want to put fanciers buildings on ALT… for example I put the simple building on just the letter, F for farm… then ALT for fish farm or G which is just beside F… it depends if there is two or three buildings that start on the same letter… but as long as you know which ones start on the same letters it easy to work out where they are when you separate them between fancy and simple / basic and complex… however or whatever… it does work that way but it could be tweaked still… but the idea of alterations on on ALT for the 3rd (fancy) building being on ALT, makes it easy to remember the simple builds are on simple keys and the alterations are on alt.

The market is on the ‘forward slash’ between shift and Z for quick trading access, and selecting all Trade Karts can be put on T, Towers are also on T but since builder isn’t selected when you push it, it will select the trade karts/routes instead of building towers when the villager is selected…

Something like that… they’ll be more ways too do it obviously but yeah those are some of the main problems you need to work round if you have the same bug. Anyway too much info now lol, good luck!

P.S one last time, the click will work, if you hold shift or hover over water, land or trees away from buildings or units (anything selectable or that a unit can walk too) - but it depends if you have a unit or building selected remember…

Gd luck again, sorry I keep come back and forward to this post - this sett up was compared and tested with friends for a few days too, we’ve manage to defeat HARD AI with it, and do everything we wanted too. After getting use to it, it was awesome.

P.S sometimes the civilians auto garrison in building too after building them, but that stopped after playing around, I’m not sure if it was a factions perk or something else but its fine now, I cant remember what team I was…
And the move scrollbar bug, I found that to be a lose wire and an upside-down control pad - you forget you have the Xbox control when you use keyboard and mouse for the first time. It sounds like a mess lol but I guarantee you after a few day and if you reword this on paper you’ll work it out and it’ll will fell smoother and smoother with practice… its a different experience and it may help highlights some new bug solutions… I hope it does anyway… good luck! :slight_smile:

The parts that would need PATCHED if used, the MORE BUILDINGS command would need to become PREVIOUS PAGE to use Q and E to cycle through buildings properly as it currently seems to only go one way. . CANCLE to stop what your doing, and too CANCLE the item in end of build queue, could be on the same key, like full stop. . R to remove rally-point (with buildings selected) & repair (with villagers selected) . M < > ? can be used for selecting single units or all of them (military or villagers), IF we make it so the full stop which is CANCEL & STOP WHAT YOUR DOING & SECTED NEXT IDLE VILLENGER (the dot on the keyboard) or > on the keyboard), doesn’t bypass the IU buttons, command to cancel the thing in a queue, which it does atm for no reason. All we’d need to do is tell the game not to cycle through unit whilst the UI panel is up, I think. . . .However it still works pretty awesomely even without these patches, I’m not going any further with it for now and if you want you can even put the first technology for your resource buildings on the space bar for quickness, but the 2nd 3rd and 4th technology slots will need a different key unless the slots slide into new positions numerically, (it wouldn’t work the same for training units), it would work but would need a whole new UI design that was very smart. Personally I like this one, but the advanced one sounds good just thinking about it too, good luck o7.

BACKSPACE ungarrison - unpack - unload all works on one button / key as well as INSERT for garrison, pack, load. Everything else listed bar them patch notes works. Home key is good for town centres, and the bell.

There is a lobby chat bug where people can only see your messages if they are on the same team as you IN THE LOBBY. This makes coordinating the inside of lobbies very confusing.

Range unit always moved to target when the target get killed, and they get killed by castle. Pls fixed it