List of unfixed bugs

I wouldn’t call this a bug per se, but for KHMER civ:

this is the kind of attention to detail that I’d like to see a little more of. and not just for superficial stuff like this, but also some of the core functionality so that we don’t have to wait for weeks between releases to fix bugs.

I should probably add that with a stream of new players coming in thanks to the release to mobile and console platforms, this kinda stuff is important, too.

Maybe it’s just because I’m so totally used to it, but what exactly are you pointing out? I don’t see any special attention to detail here, or a bug like fact.

If I’m not mistaken, Khmer doesn’t require buildings to age up (or unlock additional bulidings). The tool tip when you hover over the next age in the TC is the generic message which says you require buildings to age up (which is indeed true, for every? other civ).

1 Like

Yes, that’s all correct, what’s your point though?

Displaying this to a Khmer player is technically incorrect, isn’t it? Shouldn’t the Khmer TC tooltip not make mention of the two building requirement to age up?

1 Like

Maybe, but that would require an unnecessary technical overhaul.

You would need to rework the way tooltips are made

Not a bug, its a major feature. Unique tooltips for each civ are too much work and I doubt the dev team would prioritize that.

1 Like

Because the slide of my story in the custom campaign does not appear, this is a bug, because in Age Of Empires HD Edition 2013 it appears and in Age Of Empires 2 Definitive Edition the story slide of my custom campaign does not appear.I’m the brazilian

I don’t see any problem here. If you want proper custom campaign intro/outro slides, that’s not how you make them.

This is the screen that should appear. It will only appear in the Year 2013 Age Of Empires HD Edition.View Photo.

The same process that I did in Age Of Empires HD Edition of 2013, I did in Age Of Empires 2 Definitive Edition, the only difference is that in Age Of Empires 2 HD Edition of 2013 it works, already Age Of Empires 2 Definitive Edition doesn’t work or doesn’t have.

That’s because you’re just clicking “test”, you need to actually run it through a single player lobby.

So how can I do it?Can you teach me?

KDA related problem (in fact 50 kills scores +/-160 kills in the end game stats)

I played an arena game as byzantin and while watching the replay i realise that my KDA was 3 times bigger or something close to that.

Everytime one of mine cataphract kills one enemy’s tarkan my KDA score 3-4 kills.

Note: I had logistics when the bug happened. And every other upgrade for the cataphract.

Hmm can you send a rec? I am interested in reproducing it myself

Also do make a separate report for this if u can, so the devs can see

edit: i just tried to reproduce it with both unupgraded catas and also logistica ones, seemed to work fine, tho it wasnt really a massive battle.

I am a new user here and cant upload the replay.
Sorry about that, but I can sent u the link of the replay in
My nickname: “vilela do mato”
It is the last game in my profile. “Arena 4v4”

download the replay in this website and it should appear in the recorded games (make sure to put the file in the right place)

Not fixed in this patch!
Plz just care about campaign players

Not sure how to make a new post for this, so I’ll report a bug here. The “as numerous as the sands of the sea” achievement isn’t triggering for me. I played through once before I knew about the achievement (and thus made non-infantry units) and twice since making only infantry. After it not triggering the first time (making only pikemen and huscarls) I tried just making only huscarls in my next attempt but it still didn’t trigger.

Is there a chance to fix this bug? Have same problem with game installed through Xbox app on Windows 11.

Seems that achievement Can I be Frank with You doesn’t work.

Not sure if I’m doing this right, I signed up just to report this issue with the Gurjaras. It does not allow the elite Shrivashma unit to be upgraded.
If I start in post imperial, it’s there. But on XBox, it does NOT allow me to upgrade that unit. Kinda killing the use of the Civ I paid for on the DLC.