Map scrolling is choppy/sluggish & stuttering

Hi as title says, when i scroll/pan my map in game it’s very sluggish, i changed scroll speed to 5% to try to analyze it, and when i pan around the map it looks abit like the details are shaking, I had the same issue in the beta. Other than that my fps is fine and everything else. But this one thing really is bothersome and unpleasant. I’ve tried pretty much every settings and nothing makes any diffrence. Havn’t really heard anyone else have this exact problem. I really would love to get some help.

I get 1185 points on benchmark on all diffrent graphic settings. (I got 1070 in the beta). But theres no actual diffrence. Feels the exact same.

GTX 970 4gb
i7 6700
16gb ram
running on SSD.

EDIT: When we brought this up on the Age of Empires discord one of the staff said he thinks it’s a hardware issue and adviced us to try the optimization steps: - I’ve tried it and it doesn’t work for me.
I don’t think it is a hardware issue since theres so many that have this problem and we have a variety of diffrent specs. Kinda bothersome that they don’t even recognise this problem as a part on the games end, but rather ours.

EDIT #2: Everything works fine for me now, I didn’t do anything. I guess they did something. What about you guys?

EDIT #3: Since the release of a new patch today on 20 november map scroll stuttering is back.


Same here as well. It’s definitely more sluggish than what I remember in the beta (although I got kicked out of the beta 2 weeks before the official end date so I was not running the latest beta version).

1 Like

Same here. I’ve tried all manners of frame limiters (vsync, freesync, FRTC, Chill, RTSS) but none of it matters. Scrolling is extremely choppy while the FPS does not reflect it. Frame pacing issue with the game looks like.

Vega 64 strix
3930k 4.4ghz
32gb ram
nvme SSD


Glad to hear im not alone with this issue though, you have a pretty diffrent spec from mine and you still have the same problem.

Hopefully this thread can reach the dev’s attention. I beg for them to come up with a fix.

1 Like

Yep, same here. 1152 on the benchmark, yet choppy map movement persists regardless of which settings I change

1080 Ti

Edit: Read thru optimization guide, is all stuff I’d already done/tried


Same here. Game also appears stuttery even though the measured frame rate is 80+ fps.

1 Like

I was planning on buying the game today, but seeing all of this I am going to hold off for a while. Issues and bad performance in the beta is ok; that’s what a beta is for. It is however unacceptable and fully condemnable to have this in a released game.


I think you should wait yes.

Looks like everyone is having this issue. Maybe it’s the Steam version?


I’ve tried the optimization advice Age of Empries gave me to set Windows 10 settings to “high performance” for AOE2DE, did not help. I am experiencing very choppy map scroll as well as 2 other friends having the exact same issue.

i5 3GHz, 8gb ram, amd rx570 series 8gb vram.

1 Like

I also have the stuttering problem even though my fps is at 120 + at all times. The worst part of the stuttering mostly takes place when I scroll the map or zoom in or out. These performance issues are so bad that I am right now sticking with the old AoE 2 HD version.

please fix :frowning:

System specs:

GTX 1060 3GB
I5 8400


Only got 971 points in benchmark :frowning:

1 Like

The funny thing is that AoE 1 DE is smoothly in a decent machine, even with a less than decent graph, and this new release is not even possible with the recommended requirement or intermediate. :cry::cry:

1 Like

Same problem here! Even the beta had the stuttering till the end. My FPS are fine.
I tried everything and nothing helped.

Version: Steam


  • ASUS Strix GTX 1070 OC
  • Intel Core i7 8700k OC 4,8GHz
  • ASUS Maximus X Hero
  • 32GB G.Skill TridentZ DDR4 CL14
  • Creative SoundblasterX AE-5
  • 2TB Evo 860 SSD
  • 1TB Evo 970 NVME SSD

It doesn’t matter if i choose low graphics, enhanced graphics on or off and so on.
This should be fixed immediately. We’ve talked about these problems often enough in beta and you published it anyway. Please do something. I mean I really love the Definitive Edition!


On closer inspection I realized that the whole game suffers from stuttering. You can see it in the main menu too. Just look at the animations.

1 Like

Good call. It’s definitely a rooted software issue, no amount of powerful hardware will fix it. I’ve noticed it eats up 7-10 GB of RAM just by loading the tutorial. That’s also what’s causing the crashing for some people with low RAM or disabled page file.

Also I tried running real time priority and all different CPU affinities but nothing makes a difference for performance. With 1 core selected the sound starts to crack indicating buffer underrun, but then a second core doesn’t actually increase the total % utilization. It looks like an unoptimized mess that the devs assumed modern hardware would fix lazy code.Like a Bethesda game modded with infinite draw distance lol. Maybe windows 95 compatibility mode will help? :joy:


I tried:

  • Fullscreen optimization on/off
  • Vsync on/off
  • Nvidia Vsync
  • Nvidia Power Management
  • Administrator mode
  • Steam Overlay on/off
  • Lowering the graphics
  • Uninstalling the enhanced graphics pack

Nothing changed. Really. Nothing.
This stuttering is a pure software issue.


In the age of empires discord, one of the staff said its a hardware issue (our problem) and not the game. I don’t take that as an official statement, but since he is the staff and he said that doesn’t feel very good.

My FPS really drop when camera on trees, lol. Maybe trees is the problem.


I’ve heard about this tree issue before in the beta. But this is not a problem for me, trees or not, still stutters when map scroll.