MBA v1 June 17th updated

Multiple Buffs Mod v1 (Currently UHD is not supported)

https://www.ageofempires.com/mods/details/15373/

Buffs to all civilization with post-imperial upgrades, summoning heroes of the old etc. Total 34 Civs so far except Koreans, will update Koreans soon.


**INSTRUCTIONS**

Search and subscribe to one of the following mod, put it as highest priority then make sure you RESTART the game, then it will work properly.

DE Hotkeys: "MBA v1 Language DE" (https://www.ageofempires.com/mods/details/15948) or

Classic Keys: "MBA v1 Language Classic" (https://www.ageofempires.com/mods/details/15374/)

These mods enable icons/cost/tooltips of custom units and hot keys


Recommanded requirements:

- Conquest, Random Map or Regicide

- Dark age/Standard starting age

- Multiplayer of at least 4 or more

- Speed Casual and Above

- Population between 200 to 250, 300+ will work but less enjoyable.


Credits:

Tevious and his SLX studio

Graphics & icons go to internet

Return to Rome mod: multiple SLP graphics

Gallas for multiple SLPs/Icons

AOE:FE - Dragon SLP graphics

HeavyCruiser GoldenDeer: Base unit data

Rado: Flying transport SLP

ROR_Sir_William: Another dragon SLP

Rise of Civ: Bunch of SLP graphics

Navinkumarpk for providing AOE1 SLPs

Tevious and Seb for their support

Pally for helping me play test


3 Likes

When will this get an update with the sea buildings?

probably in a few days, depends on the tech tree addition side of thing

mod updated, except tech tree running out of spaces to add more icons. includes all the new effects/units such as sea buildings, dragons, lightning/fire effects etc.

1 Like

Currently the mod is unplayable to me. I made the tooptip mod 1st priority and restarted, but still can’t see any tooltip on newly added units.

Also the tech tree is not showing new content.

1 Like

Not too much experience playing mods. But is it possible to customize the tech tree so that we see all the unit descriptions within it?

Currently all the info of new content are displayed on the left panel, pretty inconvenient to get an overview of a civ.

Leitis lancer sounds exciting!

1 Like

yea I’ve tried, though I didn’t spend too much time in trying to get it to work in the middle, I was told those are hard coded and cannot be changed for middle portion tech tree, for custom icon and units. if that is the case theres only really two ways to do this:

  1. the way I did it now
  2. make pictures and people have to alt tab manually and check it

I guess it takes time and once you know your way around the tech it becomes much easier.

I see you are using DE version, I will check it thanks for letting me know.

I just tested the mod it is working, that reminds me my friend whom I played with yesterday and the day before also uses DE language version and he can see them just fine. (my friend also have small tree mod so we can eliminate that, dont have to disable that one)

I am guessing probably one of the mod is in conflict with MBA Language mod. maybe try disable all other mods and leave only MBA language (except small tree and MBA language) and restart the game.

if it still doesn’t work, try MBA language classic and let me know. I am using classic so it does work and I just tested DE one too.

1 Like

Tried everything you suggested and it’s still not working :slightly_frowning_face:

Would still like to check out gameplay videos if you have any.

I’ll try get a video up in a bit. first try this instead as some files maybe corrupted or game issue. do everything the same so far, have mod on highest priority and enabled, exit the game. then in your folder directory

C:\Users\user name\Games\Age of Empires 2 DE\numbers here\mods\ there should be a file called “mod-status.json

use notepad or notepad++ to edit this file, if you are successfully subscribed to MBA v1 language DE mod, one of the line will something similar to the following:

{“CheckSum”:“937578117”,"Enabled":true,“LastUpdate”:“1594525597036”,“Path”:“subscribed//15948_MBA v1 Language DE”,“Priority”:1,“PublishID”:0,“Title”:“MBA v1 Language DE”,“WorkshopID”:15948}

make sure “enabled” part is set to true, if it’s false then change it to true, save it and see if it works. if doesn’t you may need to reinstall the game as something maybe corrupted. (also, each time you disable a mod or enable a mod, it is required to restart the game, this applies to all UI mods and for both enable/disabling.)

1 Like

I did observe something weird: Every time I enter the game, your mod shows as “Downloading” (Even if last time I exit game it seems downloaded). This doesn’t happen with any other mod I subbed (whose size is even bigger).

The JSON file has no problem (the mod’s “Enabled” is true).

I’m pretty sure reinstalling the game won’t solve the problem and it’s too costly. I also verified the integrity of game files and if anything is corrupted it would have told me.

in your subscribed folder, delete MBA v1 Language DE. subscribing failed and this can happen. after you delete it, also delete the mod-status.json.

when you start the game mod_status.json will auto create, then you can try to re-sub MBA mod and that should work. just make sure after you subscribe, put on highest priority and restart the game, that step is required each time you enable/disable mod and priority change.

Still no luck. Is this the correct size of the mod?

Annotation 2020-07-17 191209

And making it worse, deleting the “MBA v1 Language DE” causes a crash when returning to main menu from mods manager.

EDIT: Resolved the crash after adjusting priorities and unsubscribing the mod :joy:

Deleting a mod folder (without unsub) messes up the priorities of subbed mods and causes redownloading of most subbed mods.

don’t delete the subscribe folder, only the mba language lol.

the file size looks correct.

so it still doesn’t work?

I just played with another friend today, his first time playing this mod, he subscribed to language DE and it works just fine so im not sure whats wrong with it. might be game corrupted overtime etc.

Yeah I surely deleted only the mba language. Just bad luck for me.

Thanks for your time anyway!

Hope this mod gets some attention and get better :smiley:

1 Like

hpoe they fix things with the next update, thanks for trying.

woosh finally an update. can no longer edit first post a big shame.

@PilgrimHYR ok so after so many months and help of several other players that have similar issue as yours, I think we found out what the issue is with tooltip/UI not showing.

all of the players having issue isn’t using English language in the game, which can be changed within game. but there is no need to change language now I have added UI txt file to all language, though they will all show english.

when you have time, could you help me try again see if it’s solved this time.

1 Like

I have trouble downloading any mod these days. Will update you when the issue is gone.

1 Like