Modding Fonts

I’ve been trying to get mod Lucida Blackletter into the game. Unlike in HD, fonts are not listed in the key-value-strings-utf8.txt
What I have found so far is two folder locations:

You can get Lucida Blackletter (or any other font) in the main menu by deleting all the fonts in AoE2DE\resources_common\wpfg\fonts and putting in a font of your choice. It will also appear on the loading screen for matches.
Unfortunately, making a mod that replaces every font file in that folder doesn’t seem to work. I think I recall hearing somewhere that wpfg mods don’t work. Perhaps because those files are loaded before mods. So you have to do it manually for now.
Still though, it is a partial success:

The question remains of how to mod the remaining fonts. Within AoE2DE\resources_common\fonts there are several massive combined files with matching .txt .png .DDS .box files. I think these control most of the remaining ingame fonts. Unfortunately, I’m not sure what to do with them - they are font asset files, but I have no experience dealing with those.
Delete them and the game refuses to launch.

So that’s where I am so far.


August 2020 and still no way to mod the fonts without changing ALL the text to a single font as described above.

1 Like

I managed to change the menu’s fonts following your method but still couldn’t find a way to change the in-game font. I found something called ‘Age of Empires 2 Definitive Edition Custom Font Generator’ though I don’t know how to use it. Seems like it worked in AoE:DE.

I’ll leave the link to the GitHub here just in case anyone is curious:

I can’t get that program to launch. It theory though, it seems like just the thing needed to modify the remaining fonts.

EDIT: oooh I think I figured it out!

I did it. With a serious shout-out to the Custom Font Generator. It was just the thing I needed. Actually quite simple to use.

note that fonts are NOT loaded from mods, so they must still be manually installed by replacing the game files.


Congrats! You figure it out before I was about to tell you that you needed to compile the program with Visual Studio 2019, that’s how I did it, thanks to Reddit someone told me about it.

What is really cool is that you can actually mod 2 sets of fonts, one for Serif and one for Sans Serif as I have here:

This one for the Serif font I used the font called ‘Neuton’, I think it gives it a much modern look than Times New Roman while still retaining that ‘medieval vibe’:

For Sans Serif I chose one called Aganè which has a bold version which helps a lot with visibility in higher resolutions, the default Sans Serif font was too thin for my liking.

Though I don’t know if it’s possible to add a vertical offset to the font from the main menu as the program did for the UI fonts.

Here’s the font I used (‘Noto Serif’) for the main menu. It seems seemingly good but the text is actually a little lower than normal on the buttons.

It’s much more noticeable while looking at names and numbers at the pre-match screen though, any help or suggestion with this?

1 Like

You don’t need to compile it. You just need to download the “release” rather than the source code.

Will this be uploaded?

Yeah, I didn’t know that at the time.

I hope there’ll be a similar tool or update to do the same for the main menu’s font. Still, this tool should be more popular, it’s so useful.

I cant even edit the files. Says I don’t have ownership. I am the admin on my own computer, what hoop havent I jumped through?

@MNVICSN Are you a MS Store User?

Yes, I have the Windows Store version.

(I didn’t get steam till recently for other games, felt it was silly to get for one game and also thought Id have better DRM control not having the steam version. Definitely regretting not getting it on steam from the outset. I am gonna get the bundle on steam when AOE 3 DE drops in price)

It is not possible to access local files of MS Store games.

It is possible but you need to jump through a bunch of technical hoops to give yourself access permissions.

I would not bother though. Steam Version is a lot more User Friendly (and it’s on sale atm).

It is not enough on sale when I already have the game though. And it won’t let me have the permissions I have tried that already.

(Edit: actually it was pretty cheap and the bundle with 1 and 3 was only 30 so switching to the steam version.)

@Zetnus So now that I have it on Steam and can actually edit the files, what I am supposed to do? Just replace the wpfg fonts or can I edit the ‘straight’ fonts folder. I am confused.

what exactly do you want to achieve?

The font when playing a game, mainly.

The main menu font can be modded by replacing the fonts in wpfg with a font of your choice, and giving them the same filename.

For the other ingame font
Use this tool

you need to generate new font files for the fonts folder. combined_0000

take a look at what I did here:


How did you get the tool to work though? I ran the release version of the Font Generator, it says to have the TexConv.exe in the Libs folder - I do have the file, although the thing might be corrupted. I tried to redownload the whole tool, it still doesn’t work.

I’d really appreciate some help. Here’s the tool’s dialogue:

"Generation started. Initializing…
Trying to extract all glyph information…
Successfully generated glyph information of 3952 char(s).
Trying to draw all glyphs to atlases…
Successfully generated 1 atlas(es) and 3952 char(s)’ information.
Trying to save 1 images to disk…
Error occured and the generation process has been terminated. Error: Cannot execute TexConv.exe to generate textures successfully. Please make sure this tool exists in the “Libs” directory and is not corrupted."

1 Like