Multiplayer only stutter?

So I’ve been looking around for people with similar issues but I believe everybody had stutter not only in MP but also in SP but in my case I have around 120+ FPS in SP all the time pretty much but in MP its below 20. Does anybody know a fix for this? I have tried reinstalling the game, lowering settings, V-sync didn’t help no, also the MP test I did I got a score of i believe 1280.


Could you provide further detail on the occurence, like a screenshot with your ingame FPS (press F11 to show)? Note that if someone else have performance issues on your match, the whole match will lag. You can avaliate this watching the colored clock that goes by the side of a player name during matches. A blue clock means a good performance, yellow a moderate and read a bad. A single red-clocked player will cause the match to lag.

Sure I’ll get the screenshot right away, but for the others performance, its definitely me because I can create a MP game with only AI and will get same result.

And heres a screenshot of SP on a ludicrous map and 8 AI’s on Ultra settings.

This is very weird given your bechmark score.

Your GPU drives are up to date?

Keep Vsync disabled, it can impact badly on performance.

This thread have a few tips to performance issues, see if any help

Yeah GPU drives are up to date, also tried with V-sync on and off and got same result on MP, here’s also the benchmark score I did just now.

I’ll try the stuff in the thread but if nothing helps I suppose I might just try and wait and see if anybody else has a solution or for devs. Only wish it didn’t affect everybody in the game also. But anyway thanks for your help dededoritos!

You’re welcome!

Anyway, my 2 cents: I don’t think you sould keep the settings on ultra (or on high, even) to play online, as much temptating as it is. I haven’t seen record of anyone doing that so far. The game simply isn’t optimized well enough yet to make it consistently. Lowering your resolution to 1080p should help a lot with the performance as well.

Just wanted to share this also because I found it hilarious hahah. Going to the lowest resolution and lowest settings didn’t help, neither did anything in that thread sadly. Gives me time to play some campains tho at least.

1 Like

For comparison, these are my settings below. I achieve around 1180 score on benchmark with these, and at online matches I can consistely get 100+ fps.

CPU: i3 7100
GPU: GTX 1050ti

My specifications are:
CPU: i7-7700K 4.20GHz
GPU: GTX 1070
RAM: 16 GB

I’m quite confused tbh, I don’t have the worst computer. I did read somewhere a while ago that some better computers have my issue but I’m not sure if my computer really counts as a really good one.

This just gets more awkward…

How’s your storage space? Is the drive in wich AoE is installed too full and/or fragmented? If so I suggest doing some cleaning and/or defragmentation.

You have a great setup there.

Well it took me a while to check how much its fragmented hah, it’s at 4% and my drive isn’t near being full.

It’s time to start screaming at the game, I guess. Your situation is very odd. Few other things that I can still recommend, if you haven’t tried yet, is disabling firewall, searching for other apps running on background and aloccating more virtual memory. You could also try to monitor the game impact on your setup via the task manager, compare how it gets on SP to MP and see if this data helps finding the problem anyhow. As much as the Campaigns still playable, gladly, I think your game should still be applicable to a refund.

I have actually looked at task manager earlier when testing and GPU, CPU or memory never even came close to 90% (was normally around 50% with browser, steam and discord opened only) so I don’t think virtual memory will help. But I guess I can try disabling firewall.

The CPU should never show high numbers, since the game only runs on a single thread. High memory consumption, however, has been a problem reported since beta. As much as I don’t have further solution to provide to you, I find difficult to drop on such a bad performance into matches without running out of RAM. Or at least something else exhausting, like experiencing high temperatures on your system components, but I think that if this is the case you would’ve noticed issues to perform other activites, not only playing AoE.

Happened the same to me with I5 6600k (HD530) and gtx 1060, do u have two gpus enabled aswell? gonna try to reproduce it tomorrow, i think its related to bios settings, add me on steam for the trial an error!

I’m not sure what you mean having 2 GPUs enabled? Like having 2 physical GPUs or something. Also what’s your Steam?

Please share results if you people achieve any progress!

Tried with no luck, I had the same issue. Now is fixed, but I wasnt able to reproduce it. Seems same issue with different cause.

This is very weird