New Units not appearing in Scenario Editor

So, I have used some of the unused unit models to create new units. The ultimate goal is to add two or three new civs to the game. I added the units by use of the Advanced Genie Editor (A.G.E.). I have also modified the language mod file, and A.G.E. recognizes the language file just fine. The problem is that once I load the game, the new units are not listed in the Scenario Editor during testing. Does anyone know how to fix this? What am I doing wrong here?

For example, one of the new units is a Gendarme, which uses the Frankish Paladin skin. The unit “Gendarme” does not appear in the list of Units in the Scenario Editor.

(I know the DAT file has loaded successfully, because I updated the monk skin for certain civs, and that works during testing.)

1 Like
  1. Check the “hide in editor” flag of the unit in Advanced Genie Editor. It has to be 0.
  2. After selecting the data mod in the scenario editor menu, create a new scenario, do not open an existing scenario.

This should solve your problem.


I am curious what is the Hwacha in your list?

The Hwacha is a modified version of the Korean War Wagon. It fires 20 rocket arrows per volley (4 armor piercing damage, +1 bonus vs. ships, +1 bonus vs. infantry). The elite version fires 20 larger rocket arrows (javelins) per volley (4 armor piercing damage, +2 bonus vs. ships, +2 bonus vs. infantry). All secondary projectiles have 25% accuracy. The elite projectiles deal area damage.

Note: The Korean War Wagon was actually designed after an earlier version of the Hwacha. That’s why I used that model for this unit.

Photos attached (7 Hwachas at the top, 4 Elite Hwachas on the left):

Hwacha Stats:

Elite Hwacha Stats:

1 Like

The “hide in editor” flags are all set to 0. What I did to test this might be a bit unorthodox though. I backed up the “empires2_x2_p1.dat” and saved the modified DAT file to the default location. Could this be causing the problem? Where should I place the modified DAT file for testing?

Thank you for your help. I greatly appreciate it!

Go to the mod manager and click “open folder”. Then go to local and create a folder with the name of your mod. Then create following folders inside your mod folder: resources, _common, dat,
Then copy the original, backuped empires2_x2_p1.dat to this folder.

In Advanced Genie Editor select the dat file in your mod folder instead of the original on in the game files. Now if you import the local mods in your mod manager, you should see your custom dat file. Everytime you edit it, you either have to restart the game or import the local mods again.

1 Like

Awesome! Thank you! This is very helpful. Not all heroes wear capes! :smile:

1 Like

hey XWHIT3W0LFx, I’m wondering if you have any public download of your AOE1DE conversion mod? I’ve been researching modding the last few days, and am curious if you have any plans to make your progress publicly available, or even open it to community contribution? I’ve always loved the original AOE unit skins and would love to see them ported to AOE2DE’s engine with their quality-of-life improvements.
I’m rather new to using AGE and SLX Studio to modify SLP files to SMX, but I would love to learn more about the process.

1 Like

But our hero, Legion @xWHIT3W0LFx is wearing a Cape . :wink:


Aye, I concur with this request. I was actually looking at trying to port over AOE1DE units to AOE2DE earlier today. I was specifically trying to port over the Trireme, Catapult Trireme, Slinger, and all elephant units, as I was hoping to use them for adding Romans and Vandals. (The elephants would be integrated for existing civs that used elephants.) But alas, I do not have the experience to know whether I’m doing it right. If someone has already done this, that would be amazing.

From my current limited understanding, AOE1DE’s unit files need to be manually converted using SLX studio. AOE1DE has 32 angles, and AOE2DE uses 16 angles? (SLX studio has a lot of features and I don’t know how to use it well yet). Look into the Historical Units Reskin mod, it appears that some of the units have been completed this way already. This looks like a TON of manual work, unless WhiteWolf or someone else already wrote any software to automate this.

Considering each unit uses hundreds of SMX files, this is quite the project.


I checked out the Historical Units Reskin mod. It’s pretty cool except for 1) many of the reskinned units are tiny compared to normal units and 2) they’re much less quality. Hopefully the author will improve it in the future. I know it’s a ton of work to accomplish without 3D rendering software.

1 Like

It seems the “key-value-modded-strings-utf8.txt” is still not being read by AOE2DE still. The new units still do not appear in the Scenario Editor.

I followed your instructions and have successfully imported the local mod folder. The hierarchy looks like this:
…mods\local\Mod Test Folder\resources
(2 subfolders)
(subfolder 1): _common\dat\empires2_x2_p1.dat
(subfolder 2): en\strings\key-value\key-value-modded-strings-utf8.txt

I feel like I’m probably making another simple mistake, but I can’t figure out what it is. What did I mess up this time? :pensive:

I tried downloading other mods to find examples. I found that apparently the Data Set mod must be separate from the Text mod. Once both are subscribed, I’m supposed to toggle on the Text mod in the Mod Menu, go to the Scenario Editor and select the Data Set mod, and then click “Create Scenario”. However, AOE2DE does not appear to allow the Text mods to work at all.

I downloaded a mod that changes some of the unique techs for certain civs. I tested it in the Scenario Editor and in a Single Player game, and all of the default text was still present. What the heck is going on here?

Note: It probably shouldn’t matter, but I set the Text mod to the highest mod priority.

I created little programs jn java to automate all the things that have to be done to get the graphics right.


Can you send me your modded files? I can look into it after work.

1 Like

Any way to add new entries to the Editor list with new names added to the language.dll file?

This is really cool. I am very interested in the work you’re doing. If there is anything I can do to help, let me know. I’m not well versed in SLX Studio, but I’m willing to learn.

1 Like